Bug #14171: Apache 1.3 can not start after php4.0.6 install
| From: | z dot yu at ecu dot edu dot au | Date: | Thu, 22 Nov 2001 09:27:37 +0000 |
| Subject: | Bug #14171: Apache 1.3 can not start after php4.0.6 install | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-71366@lists.php.net to get a copy of this message | ||
From: z.yu@ecu.edu.au
Operating system: Solaris 8 for Intel
PHP version: 4.0.6
PHP Bug Type: *General Issues
Bug description: Apache 1.3 can not start after php4.0.6 install
I installed php4.0.6 on Solaris 8 Intel (SunOS 5.8 Generic_108529-12 i86pc
i386 i86pc) with mysql 3.2.3. I have no problem to complie php.
and the following lines are added to /etc/apache/httpd.conf:
LoadModule php4_module /usr/apache/libexec/libphp4.so
AddModule mod_php4.c
When I restart apache, I get the following errors
# ./S50apache start
httpd starting.
Syntax error on line 241 of /etc/apache/httpd.conf:
Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1:
/usr/apache/bin/httpd: fatal: relocation error: file
/usr/apache/libexec/libphp4.so: symbol uncompress: referenced symbol not
found
/usr/apache/bin/apachectl start: httpd could not be started
Could you please tell me how to fix the problem.
Thanks
Regards
Greg Yu
z.yu@ecu.edu.au
--
Edit bug report at: http://bugs.php.net/?id=14171&edit=1