Bug #13160 Updated: Apache fails to start, undefined symbol "pg_encoding_to_char"
| From: | yohgaki@php.net | Date: | Wed, 05 Dec 2001 23:55:35 +0000 |
| Subject: | Bug #13160 Updated: Apache fails to start, undefined symbol "pg_encoding_to_char" | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-72694@lists.php.net to get a copy of this message | ||
ID: 13160
Updated by: yohgaki
Reported By: brian@sunset-cliffs.org
Old Status: Open
Status: Closed
Bug Type: PostgreSQL related
Operating System: Debian Linux - Potato
PHP Version: 4.0.6
New Comment:
This should be fixed in CVS and 4.1.0RC.
Previous Comments:
------------------------------------------------------------------------
[2001-09-05 21:17:25] brian@sunset-cliffs.org
This looks to be similar/related to http://www.php.net/bugs.php?id=5417
Doing an 'apachectl configtest' with PHP 4.06/Apache 1.3.20/PostgreSQL 7.1.3, I get the
following error message.
"Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: pg_encoding_to_char"
I "fixed" it by recompiling PostgreSQL 7.1.3 without '--enable-multibyte', then
removing config.cache in PHP and recompiling.
./configure for PHP
-------------------
./configure \
--prefix=/usr/local/apache-1.3.20 \
--with-apxs=/usr/local/apache-1.3.20/bin/apxs \
--with-config-file-path=/usr/local/apache-1.3.20/conf \
--with-gd \
--with-pgsql=/usr/local/pgsql \
--with-mm=/usr/local/lib \
--with-zlib \
--with-zlib-dir=/usr/lib \
--with-xml \
--with-gdbm \
--with-gettext \
--with-openssl=/usr \
--with-ldap=/usr \
--enable--sysvsem \
--enable-sysvshm \
--enable-force-cgi-redirect \
--enable-calendar \
--enable-inline-optimization \
--enable-trans-sid \
--enable-track-vars
./configure for Apache
----------------------
EAPI_MM=/usr/local/src/apache/mm-1.1.3 \
SSL_BASE=/usr/local \
./configure \
--prefix=/usr/local/apache-1.3.20 \
--enable-module=ssl \
--enable-module=most \
--enable-shared=max \
--enable-rule=EAPI \
--enable-rule=SHARED_CORE \
--enable-rule=SHARED_CHAIN \
--enable-module=so
./configure for PostgreSQL
--------------------------
./configure --prefix=/usr/local/pgsql \
--enable-multibyte \
--with-openssl=/usr/local/ --enable-syslog
(Note: remove '--enable-multibyte' in the above ./configure to eliminate the
'bug')
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=13160&edit=1