Bug #14498: Unable to start Apache with PHP4 as a DSO
| From: | oliverh at hingst dot org dot uk | Date: | Thu, 13 Dec 2001 22:36:06 +0000 |
| Subject: | Bug #14498: Unable to start Apache with PHP4 as a DSO | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-73629@lists.php.net to get a copy of this message | ||
From: oliverh@hingst.org.uk
Operating system: Cobalt Linux 5.0
PHP version: 4.1.0
PHP Bug Type: Dynamic loading
Bug description: Unable to start Apache with PHP4 as a DSO
Compiled MySQL 3.23.46 with these configure options:
./configure \
--prefix=/usr/local/mysql \
--enable-assembler \
--with-low-memory
Compiled PHP 4.10 with these options:
./configure --with-apxs=/usr/sbin/apxs \
--with-mysql=/usr/local/mysql \
--with-imap=/usr/local/src/imap-2000c \
--with-imap-ssl \
--with-zlib \
--enable-track-vars \
--with-gettext \
--with-gd \
--with-jpeg-dir=/usr/local/lib \
--with-mm=/usr/local/lib/mm \
--enable-sysvshm \
--enable-ftp
Starting Apache 1.3.22 with "apachectl start" gives me this:
Syntax error on line 238 of /etc/httpd/conf/httpd.conf:
Cannot load /usr/lib/apache/libphp4.so into server:
/usr/local/mysql/lib/mysql/libmysqlclient.so.10: undefined symbol:
my_message_no_curses
I can work-around this bug by NOT specifying the dir when configuring PHP
i.e. (--with-mysql as opposed to --with-mysql=/usr/local/mysql)
--
Edit bug report at: http://bugs.php.net/?id=14498&edit=1