Bug #14559: cannot load libphp4.so into server

From: Date: Mon, 17 Dec 2001 14:35:33 +0000
Subject: Bug #14559: cannot load libphp4.so into server
Groups: php.dev 
Request: Send a blank email to php-dev+get-74133@lists.php.net to get a copy of this message
From: mdecke@pjoetry.de Operating system: solaris 7 PHP version: 4.1.0 PHP Bug Type: Dynamic loading Bug description: cannot load libphp4.so into server Hi php.net Team, i couldn't load the libphp4.so into the server. machine: sun/sparc os : solaris 7 apache : 1.3.20 i installed gcc,binutils,make ... etc. according to the installation-guide on php.net my installation is following: - ./configure --with-apxs=/us/local/apache/apxs --with-oci8=/<path>/oracle --enable-libgcc - make - make install - edited the httpd.conf according to the installation-guide on php.net - cp php.ini-dist /usr/local/php.ini then i tried to test the configuration - apachectl configtest the result was: error on line 241 cannot load /usr/local/apache/libexec/libphp4.so into server:ld.so.1:usr/local/apache/httpd:fatal:libgcc_s.so.1:open failed: no such file or directory i looked of course into the directories - libphp4.so is in /usr/local/apache/libexec and - libgcc_s.so.1 is in /usr/local/lib i added --enable-libgcc in the configure-line because i read it in a bug-report, i thought it could fix something. thanks in advance yours Markus Decke -- Edit bug report at: http://bugs.php.net/?id=14559&edit=1

« previous php.dev (#74133) next »