Bug #14555 Updated: apache fails: libsablot.so.0: undefined symbol: XML_SetParamEntityParsing

From: Date: Mon, 17 Dec 2001 22:57:19 +0000
Subject: Bug #14555 Updated: apache fails: libsablot.so.0: undefined symbol: XML_SetParamEntityParsing
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-74204@lists.php.net to get a copy of this message
ID: 14555 Updated by: derick Reported By: php@sauen.com Old Status: Open Status: Feedback Bug Type: XSLT related Operating System: debian woody PHP Version: 4.1.0 New Comment: Please post the output of this: nm /usr/local/lib/libsablot.so.0 | grep XML_SetParamEntityParsing Previous Comments: ------------------------------------------------------------------------ [2001-12-17 17:54:08] php@sauen.com That gives one line with "XML_SetParamEntityParsing", so I assume it is in there. There was no probs compiling and installing Sablot, I have NOT found any similar issue on the gingerall pages or any other mailing lists/newsgroups I've searched. ------------------------------------------------------------------------ [2001-12-17 02:44:23] mfischer@php.net What does the output of strings /usr/local/lib/libsablot.so.0|grep XML_SetParamEntityParsing gives you? If you're missing the symbol your libsablot installation is broken. Feedback. ------------------------------------------------------------------------ [2001-12-16 22:02:05] php@sauen.com Config, compile and install works fine, apache fails to start: Apache: Starting Syntax error on line 226 of /usr/local/conf/httpd.conf: Cannot load /usr/local/libexec/libphp4.so into server: /usr/local/lib/libsablot.so.0: undefined symbol: XML_SetParamEntityParsing /usr/local/bin/apachectl start: httpd could not be started ./configure \ --with-apxs \ --with-mysql \ --with-zlib \ --with-bz2 \ --with-curl \ --with-dom \ --enable-ftp \ --with-gd \ --enable-gd-native-ttf \ --with-gmp \ --enable-sockets \ --with-openssl \ --with-ldap \ --enable-xslt \ --with-xslt-sablot \ --with-iconv apache 1.3.22 sablot 0.71 expat 1.95.2 libxml 2.4.10 xmltok 1.1 Apache and PHP was compiled and installed manually, the rest has been done with .deb packages/apt. Additional: In order to successfully compile, configure didnt stop, had to install dev-files for xmltok, libxml and sasl (used deb's) ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=14555&edit=1

« previous php.dev (#74204) next »