Bug #14409 Updated: request for nonexistent file does not return 404 error
| From: | support at teamITS dot com | Date: | Wed, 19 Dec 2001 16:34:46 +0000 |
| Subject: | Bug #14409 Updated: request for nonexistent file does not return 404 error | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-74432@lists.php.net to get a copy of this message | ||
ID: 14409
User updated by: support@teamITS.com
Reported By: support@teamITS.com
Status: Open
Bug Type: Apache related
Operating System: IRIX64 vega 6.5 04191225 IP27
PHP Version: 4.0.6
New Comment:
To clarify the comment about IIS, PHP is installed as a CGI (php.exe) on that server.
Previous Comments:
------------------------------------------------------------------------
[2001-12-10 14:38:30] support@teamITS.com
To reproduce, enter a bogus filename in a browser. For example, http://www.teamITS.com/blahblah.php. The server
returns an Internal Server Error rather than a 404 (page not found) error. I reported this to
Apache and their response was:
"This is the way the appropriate directives work on purpose (although you didn't say just
how you had PHP configured to run), since it is possible to create a virtual URL space. The PHP
module is the one deciding how to handle requests for nonexisting files."
Their issue number was mod_cgi/8683 (as PHP is installed as a CGI module on this server). Sounds to
me like they are saying PHP should be returning an error to Apache. If you want more info on the
PHP setup on our server, browse to:
http://www.teamits.com/phpinfo.php
Note that a PHP/IIS4 combination does return a 404 error.
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=14409&edit=1