Bug #7641 Updated: cgi binary with "enable-discard-path" fails with empty doc_root value
| From: | lobbin@php.net | Date: | Thu, 20 Dec 2001 14:48:50 +0000 |
| Subject: | Bug #7641 Updated: cgi binary with "enable-discard-path" fails with empty doc_root value | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-74589@lists.php.net to get a copy of this message | ||
ID: 7641
Updated by: lobbin
Reported By: ugb-listen@gmx.de
Old Status: Open
Status: Feedback
Bug Type: *Web Server problem
Operating System: Linux 2.2.16 i686
PHP Version: 4.0 Latest CVS (04/11/2000)
New Comment:
Any luck with the testing?
PHP 4.1.0 might be a wise choice as well.
R.
Previous Comments:
------------------------------------------------------------------------
[2001-08-20 12:28:41] ugb-listen@gmx.de
Unfortunately, I am currently not able to test it due to time limitation.
Please do not close the bug report yet, I might have time to
test ist in the next couple of weeks (this report is 8 months old anyway).
------------------------------------------------------------------------
[2001-08-19 02:53:39] sniper@php.net
Does this happen with latest CVS snapshot:
http://snaps.php.net/
------------------------------------------------------------------------
[2000-11-04 20:26:34] ugb-listen@gmx.de
Similar Problems have been described in Bug id #5163 and Bug id #6201,
but obviously are still not resolved completely :
when compiling the cgi version, even a simple phpinfo() doesn't work
when called via Apache (while it works fine on the command line).
The error message in the browser shows up as:
Parse error: parse error in /usr/local/apache/cgi-bin/php on line NNN
(Apache 1.3.14 - other errors were reported by users of Netscape/iPlanet)
I have tried lots of different compilation settings, and found only one common
element: the problem only occurs if --enable-discard-path is specified.
Any other combination of configure flags result in a binary that works
fine as long as --enable-discard-path is not used.
I tried both the download version 4.03pl1 and snapshot-200011041645,
the only difference with the snapshot version is that it shows a different
error message:
Warning: Unexpected character in input: ' in
/usr/local/apache/cgi-bin/php on line 116
Warning: Unexpected character in input: ' in
/usr/local/apache/cgi-bin/php on line 116
Warning: Unexpected character in input: '' (ASCII=11) state=1 in
/usr/local/apache/cgi-bin/php on line 116
Warning: Unexpected character in input: '' (ASCII=8) state=1 in
/usr/local/apache/cgi-bin/php on line 116
Parse error: parse error in /usr/local/apache/cgi-bin/php on line 116
A temporary solution is to set the doc_root in php.ini to a non-empty value.
However, under some circumstances it is undesirable to explicitly set this
value - e.g. when sharing a single php binary among different virtual
servers, so php shouldn't fail even without doc_root set.
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=7641&edit=1