Bug #14593 Updated: configure fails with apxs
| From: | sander@php.net | Date: | Sat, 22 Dec 2001 20:33:59 +0000 |
| Subject: | Bug #14593 Updated: configure fails with apxs | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-74816@lists.php.net to get a copy of this message | ||
ID: 14593
Updated by: sander
Reported By: zhamm@nc.rr.com
Old Status: Open
Status: Feedback
Bug Type: Apache related
Operating System: AIX 4.3.3
PHP Version: 4.1.0
New Comment:
Did you check out http://www.php.net/manual/en/faq.build.php#AEN74685
?
Previous Comments:
------------------------------------------------------------------------
[2001-12-18 18:12:06] zhamm@nc.rr.com
Using AIX 4.3.3 and C for AIX 5.0 compiler. When running configure, I do the following:
[root@mars /php]# export CC=/usr/bin/cc
[root@mars /php]# export CFLAGS="-g -ma"
[root@mars /php]# cd php-4.1.0/
[root@mars php-4.1.0]# ./configure --enable-c9x-inline --with-apxs=/usr/HTTPServer/bin/apxs
I get:
----------------
checking for Apache module support via DSO through APXS...
Sorry, I was not able to successfully run APXS. Possible reasons:
1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /usr/HTTPServer/bin/apxs follows
Usage: apxs -g [-S <var>=<val>] -n <modname>
apxs -q [-S <var>=<val>] <query> ...
apxs -c [-S <var>=<val>] [-o <dsofile>] [-D <name>[=<value>]]
[-I <incdir>] [-L <libdir>] [-l <libname>] [-Wc,<flags>]
REQUIRED OPTION[-bE: <filename.exp>]
[-Wl,<flags>] <files> ...
apxs -i [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
apxs -e [-S <var>=<val>] [-a] [-A] [-n <modname>] <dsofile> ...
configure: error: Aborting
--------------------------------
Not sure what's going on here, I could compile 4.0.5 on AIX using the same OS version and
compiler. I did make sure that /usr/HTTPServer/bin/apxs has a good pointer to perl (it defaults to
/usr/local/bin/perl, which is wrong). In apxs, there is a note about apache modules:
## IMPORTANT NOTE FOR APXS USE ON AIX (ONLY):
##1. AIX requires that all dynamically linkable objects to EXPORT their public
## interfaces in a .exp file. This is required at the link step.
## If you do not have an .exp file, then you can generate one containing
## a single line with the name of the module. For example, in our sample
## module, example_module.c we generate an example_module.exp with
## 1 line -> example_module.
## For AIX only we have added an additional option -bE: <filename.exp>
## which is supplied as option on input to APXS script.
##2. Some 3rd party modules use a ./configure script with an APXS option. These
## configure scripts use the APXS script with a -q (query) option to get
## information on Compiler flags and Link flags. If the congfigure script
## relies on getting CFG_LDFLAGS_SHLIB from APXS script then the configure
## script will fail. The CFG_LDFLAGS_SHLIB in APXS script are not complete
## without the :bE options passed as input to APXS. Many configure script
## on AIX have an option to supply these Link Flags.
##3. NOTE: The httpd.exp file on IHS 1.3.6 is installed into
## /usr/HTTPServer/example_module
## but this script relies on httpd.exp being located in
##
## /usr/HTTPServer/libexec
## Please copy httpd.exp to /usr/HTTPServer/libexec before executing
## the APXS script.
Any help would be appreciated.
Zack
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=14593&edit=1