From: dw59@earthlink.net
Operating system: Cobalt (Red Hat) Linux 6.0
PHP version: 4.1.1
PHP Bug Type: *Web Server problem
Bug description: Apache fails to start after PHP compile
After compile of PHP 4.1.1 Apache failed to start with the following
warning:
/etc/rc.d/init.d/httpd start
Setting up Web Service: Syntax error on line 58 of
/etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server:
/etc/httpd/modules/libphp4.so: undefined symbol: gdImageColorResolve
/usr/sbin/httpd
Configure line:
./configure --prefix=/usr --with-mysql --with-apxs=/usr/sbin/apxs --with-gd
--with-gettext=/usr --enable-safe-mode --with-config-file-path=/etc/httpd
--with-exec-dir=/usr/bin --with-zlib --enable-magic-quotes
--with-regex=system --with-ttf=/usr/lib/libttf.so --enable-track-vars
--enable-xml --disable-debug --with-db --with-interbase=shared
--with-pgsql=shared --with-ldap --with-imap
I removed --with-gd and everything worked fine. Possible due to GD
compatability? PHP 4.0.6 compiled OK with same gd library currently
installed on system.
Thanks,
Dennis Williams
--
Edit bug report at: http://bugs.php.net/?id=14881&edit=1