Bug #15146 Updated: Apache fails to start - lib/php/libphp4.so: undefined symbol: pthread_getspecif
| From: | yohgaki@php.net | Date: | Mon, 21 Jan 2002 16:15:47 +0000 |
| Subject: | Bug #15146 Updated: Apache fails to start - lib/php/libphp4.so: undefined symbol: pthread_getspecif | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-77696@lists.php.net to get a copy of this message | ||
ID: 15146
Updated by: yohgaki
Reported By: ams@izoard.com
Old Status: Open
Status: Bogus
Bug Type: Dynamic loading
Operating System: Debian Linux 2.2.19
PHP Version: 4.1.1
New Comment:
You cannot specify 2 SAPIs, apache and servlet.
BTW, if this typo?
--with-axs=/vol/stage/apache/bin/apxs
should be
--with-apxs=/vol/stage/apache/bin/apxs
If you properly configure/compile Apache/ModSSL, CFLASG=-DEAPI is not
needed.
Previous Comments:
------------------------------------------------------------------------
[2002-01-21 10:20:34] ams@izoard.com
Apache 1.3.22 with PHP 4.1.1 fails to start:
bash$ /vol/stage/apache/bin/apachectl sslstart
Syntax error on line 242 of /vol/stage/apache/conf/httpd.conf:
Cannot load /vol/stage/apache/lib/php/libphp4.so into server:
/vol/stage/apache/lib/php/libphp4.so: undefined symbol:
pthread_getspecific
/vol/stage/apache/bin/apachectl sslstart: httpd could not be started
Configured as follows:
CFLAGS=-DEAPI ./configure --with-mysql
--with-axs=/vol/stage/apache/bin/apxs --with-imap
--with-libjpeg=/usr/local/lib --enable-ftp
--with-servlet=/usr/local/JSDK2.0 --with-openssl=/vol/stage
--with-gnu-ld --with-java=/usr/local/java --with-png-dir
--with-tiff-dir --prefix=/vol/stage/apache --with-zlib
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=15146&edit=1