Bug #15193 Updated: Module loads but does not work

From: Date: Fri, 25 Jan 2002 01:02:48 +0000
Subject: Bug #15193 Updated: Module loads but does not work
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-78054@lists.php.net to get a copy of this message
ID: 15193 Comment by: stephen@brightonline.com.au Reported By: stephen@brightonline.com.au Status: Feedback Bug Type: Dynamic loading Operating System: solaris 2.8 PHP Version: 4.1.1 New Comment: Thank-you for the reply. The filters have worked for php, however loading the module still renders my cgi scripts non-operational. The error message is Server error! Premature end of script headers: /var/www/webmail/index.cgi Error 500 If I remove the module, the script works fine. There is no additional information provided in the error logs. Regards Stephen Previous Comments: ------------------------------------------------------------------------ [2002-01-24 07:24:42] sander@php.net Does it work now? ------------------------------------------------------------------------ [2002-01-24 03:01:05] manu@php.net be careful the configuration change for Apache 2 you must use filter ! watch README from Apache2filter http://cvs.php.net/co.php/php4/sapi/apache2filter/README?r=1.8 you must replace : LoadModule php4_module modules/libphp4.so AddType application/x-httpd-php .php By LoadModule php4_module modules/libphp4.so <Files *.php> SetOutputFilter PHP SetInputFilter PHP </Files> ------------------------------------------------------------------------ [2002-01-23 21:34:27] stephen@brightonline.com.au I am trying to get php 4.1.1 as a DSO to work with apache 2.0.28 running on solaris 2.8. While I can compile both apache and php fine, when I load it as a module, php does not work, and it stops any other CGI (such as perl) working as well. Apache returns a 500 error saying the script header did not complete when I try to run a .cgi program. When I test a php script it asks to be downloaded. apache config ./configure --prefix=/opt/apache --localstatedir=/var/run --enable-proxy --enable-proxy-http --enable-proxy-connect --enable-cgi --enable-rewrite --enable-so I have also try with --enable-php4 php config ./configure --prefix=/opt/php --with-apxs2=/opt/apache/bin/apxs --enable-track-vars --enable-versioning I have also tried with --enable-libgcc --with-gnu-ld httpd.conf file is change to add the LoadModule php4_module modules/libphp4.so AddType application/x-httpd-php .php ------------------------------------------------------------------------ Edit this bug report at http://bugs.php.net/?id=15193&edit=1

« previous php.dev (#78054) next »