Bug #15356 Updated: Warning when running CGI
| From: | sander@php.net | Date: | Sun, 03 Feb 2002 17:07:06 +0000 |
| Subject: | Bug #15356 Updated: Warning when running CGI | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-78964@lists.php.net to get a copy of this message | ||
ID: 15356
Updated by: sander@php.net
Reported By: eric@schorvitz.com
Old Status: Open
Status: Bogus
Bug Type: Scripting Engine problem
Operating System: Red Hat Linux 7.2
PHP Version: 4.1.0
New Comment:
If it does work normally WITHOUT the Zend-thing, it's a problem with
Zend. Report this somewhere on their site.
If not, reopen this report.
Previous Comments:
------------------------------------------------------------------------
[2002-02-03 11:45:54] eric@schorvitz.com
I run PHP 4.1.0 as an apache module and as a cgi (for command line and
cron activities). I installed the newest version of the Zend
Accelerator and everything appeared to be working just fine until I
tried to run php from the command line. I get the following warning:
[user@box user]$ php --version
Content-type: text/html
PHP Warning: (null): Unable to initialize module
Module compiled with debug=96, thread-safety=75 module API=1079959680
PHP compiled with debug=0, thread-safety=0 module API=20010901
These options need to match
in Unknown on line 0 ¼': Unable to initialize module
Module compiled with debug=144, thread-safety=167 module
API=1073877708
PHP compiled with debug=0, thread-safety=0 module API=20010901
These options need to match
in Unknown on line 0
My code executes correctly from the Web (via module compile) and from
command line (even though I get the error everything executes fine).
When I do phpinfo() from the browser, the Zend Accelerator info
displays correctly.
Here is how I build the cgi (and the commented out line is what I
include to compile the module):
#! /bin/sh
./configure \
--with-mysql=/home/mysql \
--with-gettext=/usr/share \
--with-gd \
--with-freetype-dir=/usr/local/src/freetype-2.0.5 \
--with-jpeg-dir=/usr/local/src/jpeg-6b \
--with-t1lib=/usr/local/src/t1lib-1.3.1 \
--with-zlib-dir=/usr/local/src/zlib-1.1.3 \
--with-png-dir=/usr/local/src/libpng-1.2.1 \
--with-curl=/usr/local/src/curl-7.9.2 \
--with-pspell
#--with-apxs=/home/apache/bin/apxs \
Im running:
Apache 1.3.22
PHP 4.1.0
RedHat 7.2
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=15356&edit=1