php4.0.6, apache install problem

From: Date: Fri, 15 Feb 2002 17:45:48 +0000
Subject: php4.0.6, apache install problem
Groups: php.dev 
Request: Send a blank email to php-dev+get-80080@lists.php.net to get a copy of this message
Hi, I am not sure whether this is the correct list to ask this ques. I've installed php 4.0.6 since I am working with mapserver which works with 4.0.6 only. This is my configuration: ./configure --prefix=/rstc/user1/erc/pushkar/php-4.0.6 --with-apxs=/rstc/user1/erc/pushkar/apache_1.3.22/bin/apxs After this I add the foll. to my httpd.conf file of apache (1.3.22), solaris, sparc. LoadModule php4_module libexec/libphp4.so AddModule /rstc/user1/erc/pushkar/php-4.0.6/sapi/apache/mod_php4.c During php install. libphp4.so got copied to the libexec dir. of apache correctly, however mod_php4.c is in php dir. to where I have given the path. My apache config is: ./configure --with-layout=Apache --prefix=/rstc/user1/erc/pushkar/apache_1.3.22 --enable-module=so However when I try to start up apache I get the foll. error: Banshee[540] pushkar$ apachectl start Syntax error on line 205 of /rstc/user1/erc/pushkar/apache_1.3.22/conf/httpd.conf: Cannot load /rstc/user1/erc/pushkar/apache_1.3.22/libexec/libphp4.so into server: ld.so.1: /rstc/user1/erc/pushkar/apache_1.3.22/bin/httpd: fatal: relocation error: file /rstc/user1/erc/pushkar/apache_1.3.22/libexec/libphp4.so: symbol ap_block_alarms: referenced symbol not found ./apachectl start: httpd could not be started Can anybody suggest what is wrong, I tried the mailing list but the solns. didn't work. Thanks, ------------------------------------------------------------------------------ PUSHKAR S. PRADHAN Research Assistant MISSISSIPPI STATE UNIVERSITY, STARKVILLE, MS 39759. Engineering Research Center Box 9627 Mississippi State, MS 39762-9627 ------------------------------------------------------------------------------

« previous php.dev (#80080) next »