msession and mod_mm
| From: | mlwmohawk at mohawksoft dot com | Date: | Mon, 18 Feb 2002 00:53:54 +0000 |
| Subject: | msession and mod_mm | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-80127@lists.php.net to get a copy of this message | ||
I had a report of a problem with mod_mm and msession. If you configure PHP
to use both msession and the mm session handler, you will render apache
unable to start.
The session.save_path is used by both msession and mod_mm. When mod_mm
uses it, it expects it to be a valid working directory. When msesion uses
it, it expects it to be a server host name which is running the msessiond
daemon.
If mod_mm does not find a valid working directory, it will fail at module
init, thus preventing apache from starting.
The short term solution is chose msession or mod_mm, but not both. The
long term solution is to create an "[msession]" category in the php.ini
file, and use msession.server_host as a key.
I can not get to it this week, but anyone with some spare time is welcome
to have at it.