PHP w/LDAP support crapping out
| From: | J. Rashaad Jackson | Date: | Mon, 25 Feb 2002 18:33:15 +0000 |
| Subject: | PHP w/LDAP support crapping out | ||
| Groups: | php.dev php.install | ||
| Request: | Send a blank email to php-dev+get-80382@lists.php.net to get a copy of this message | ||
I am attempting to compile PHP v.4.1.0 with support for Openldap v.1.2.12.
Below is my configure line:
./configure \
--with-apxs=/usr/local/apache/bin/apxs \
--with-openssl=/usr/local/ssl \
--with-imap-ssl=/usr/local/ssl \
--with-imap=/usr/local/src/imap-2000c \
--with-ldap=/usr/local/openldap-1.2.12um7 \
--with-mcrypt \
--with-mm \
--with-mysql \
--with-xml \
--with-zlib \
--with-gettext \
--enable-inline-optimization \
--enable-track-vars
All the individual piece configure, make, and install with nary an error.
But when I move to fire up the server, I get:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: ldap_value_free
/usr/local/apache/bin/apachectl restart: httpd could not be started
I know this has been covered, but the only solution I found by searching was
to add the lib directory to my /etc/ld.so.conf and run ldconfig. I tried
that and it's not working. Below is my /etc/ld.so.conf file:
/usr/local/openldap-1.2.12um7/lib
/usr/local/lib
/usr/lib
/lib
Any help would be GREATLY appreciated. I'm at the limits of my
understanding with this. Thanks!
--
I have spoken.
J. Rashaad Jackson UNIX Systems Administrator
2032 Samuel T. Dana Building (W) 734.615.1422
Ann Arbor, MI 48109 (M) 734.649.6641
http://www.umich.edu/~jrashaad
(F) 734.763.8965