Re: Re: Function to retrieve headers for message/rfc822 attachments

From: Date: Tue, 05 Mar 2002 17:46:53 +0000
Subject: Re: Re: Function to retrieve headers for message/rfc822 attachments
References: 1 2 3 4  Groups: php.dev 
Request: Send a blank email to php-dev+get-80753@lists.php.net to get a copy of this message
I was trying to keep the naming consistent with the naming of the functions in the c-client lib. The actual c-client function called is mail_fetch_header, so it became imap_fetch_header. It seems to be the general way in which the original imap module developers named their functions. But, I would have no objections to changing the name to make it less confusing... -Brad Vlad Krupin wrote: > Sorry, I'm just catching up with email backlog, so this email might be > irrelevant by now, but just in case it isn't: > > imap_fetch_header() is probably not a very good name because we already have imap_fetchheader() > and I believe they might be a bit too similar in names (I don't know what the proposed function > does, if it is good or not, I just don't like the name). IMAP extension has already got a good > share of confusingly similar function names IMHO. > > $.02 > > Vlad >

« previous php.dev (#80753) next »