RFC: Small changes in CODING_STANDARD
| From: | Yasuo Ohgaki | Date: | Mon, 18 Mar 2002 06:42:21 +0000 |
| Subject: | RFC: Small changes in CODING_STANDARD | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-81415@lists.php.net to get a copy of this message | ||
Hi all,
Calling function may become a problem also.
Any comments following changes?
Index: CODING_STANDARDS
===================================================================
RCS file: /repository/php4/CODING_STANDARDS,v
retrieving revision 1.12
diff -u -r1.12 CODING_STANDARDS
--- CODING_STANDARDS 14 Mar 2002 03:25:46 -0000 1.12 +++ CODING_STANDARDS 18 Mar 2002 06:28:08 -0000@@ -66,6 +66,9 @@ [8] Use assert(). assert.h is included in php.h if it is available. Not only
does good assertion catch bugs, but it also helps with code readability. + - Do not use assignment in assert condition to avoid Heisenbugs. + - Do not use assert for error handling. Use assert only for the + condition that must be always true.Naming Conventions ------------------ -- Yasuo Ohgaki