Bug #1689: Apache cannot load mod_php3.so

From: Date: Fri, 09 Jul 1999 23:18:34 +0000
Subject: Bug #1689: Apache cannot load mod_php3.so
Groups: php.dev 
Request: Send a blank email to php-dev+get-8264@lists.php.net to get a copy of this message
From: morriscode@aol.com Operating system: FreeBSD 3.2 PHP version: 3.0.11 PHP Bug Type: Installation problem Bug description: Apache cannot load mod_php3.so I enabled mod_php3 in Apache both by using apxs, then by using the Apache ./configure --add-module approach. I followed the instructions at the Apache website for installing third party modules. Both completed without errors, but either way, when I try to start HTTPD, I get the message: Syntax error on line 231 of /etc/httpd/httpd.conf: Cannot load /usr/local/apache/libexec/mod_php3.so into server: /usr/local/apache/libexec/mod_php3.so: Undefined symbol "php3_ini" /usr/local/apache/bin/apachectl start: httpd could not be started I tried renaming my php3.ini file to php3_ini but that was just a shot in the dark. My httpd.conf file includes the lines LoadModule php3_module libexec/mod_php3.so and AddModule mod_php3.c Both are at the end of their respective sections. The php3.ini file is located in /etc/httpd. I would include the php3.ini file here but it's not even being read and it's just the default configuration. I configured PHP this way: ./configure --with-apxs=/usr/local/apache/bin/apxs \ --with-config-file-path=/etc/httpd \ --with-mysql \ --with-gd \ --with-zlib \ --with-system-regex Apache was originally configured: ./configure --sysconfdir=/etc/httpd \ --datadir=/home/httpd \ --logfiledir=/var/log/httpd \ --enable-module=most \ --enable-shared=max \ --disable-rule=WANTHSREGEX Then the php module was added: #> apxs -c mod_php3.c #> apxs -i -a -n php3 mod_php3.so (completed without errors and added appropriate lines in httpd.conf)

« previous php.dev (#8264) next »