Re: PATCH - improvements for imap_headerinfo() (fwd)

From: Date: Mon, 13 May 2002 00:30:01 +0000
Subject: Re: PATCH - improvements for imap_headerinfo() (fwd)
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-83966@lists.php.net to get a copy of this message
On Mon, May 13, 2002 at 12:35:12AM +0300, Jani Taskinen wrote: Reviewed and committed. - Jon > > Can you check this patch too? :) > > --Jani > > ---------- Forwarded message ---------- > Date: 24 Apr 2002 15:02:45 -0400 > From: Adam Kauffman <adam.kauffman@mindspring.com> > To: Jani Taskinen <sniper@iki.fi> > Cc: php-dev@lists.php.net > Subject: Re: [PHP-DEV] PATCH - improvements for imap_headerinfo() > > These changes don't (although I realize you shouldn't just take my word > for it) break the functionality of imap_headerinfo(). It just is a > streamlined way of doing it. > > The function as it stands does a mail_fetchheader_full(), takes the > result of that, and turns it into an envelope object. Afterwards, it > has to free that object. The c-client provides a way to get just the > envelope with mail_fetchenvelope(). It is beneficial to use this for a > few reasons: > > 1. As you can see it makes the code much simpler > 2. It is faster. For each message you don't have to fetch full headers > and turn them into an envelope object. You can simply just get the > envelope object. > 3. Simpler for the IMAP server. Instead of making it do a BODY.PEEK, it > just has to fetch the envelope (which some IMAP servers cache). > > Adam > > On Wed, 2002-04-24 at 14:33, Jani Taskinen wrote: > > > > What was this patch supposed to do again? > > At first glance it looks like it's modifying the > > imap_headerinfo() function quite dramatically and > > propably breaks it too.. > > > > Have you compared the output of this function without > > this patch and with it and does it return the same kind > > of object? (and send patches as attachements..) > > > > --Jani -- Jon Parise (jon@csh.rit.edu) . Information Technology (2001) http://www.csh.rit.edu/~jon/ : Computer Science House Member

« previous php.dev (#83966) next »