Re: Change of cgi behaviour in 4.3.0

From: Date: Wed, 25 Sep 2002 07:26:25 +0000
Subject: Re: Change of cgi behaviour in 4.3.0
References: 1 2  Groups: php.dev 
Request: Send a blank email to php-dev+get-88589@lists.php.net to get a copy of this message
On Wed, 25 Sep 2002 08:36:42 +0200 (CEST), Sascha Schumann wrote: > On Wed, 25 Sep 2002, Edin Kadribasic wrote: > > > For some reason http status reporting has been changed in the > > current CVS version of PHP. This breaks PHP under IIS and possibly > > other servers. Please see > > http://bugs.php.net/bug.php?id=19207 for > > details. > > The reason is that it did not work properly with Apache > before. > > When seeing a status line in RFC 2616 format from a CGI, > Apache will issue a 505 error, because Apache expects it to > be in the informal CGI RFC format. > > Note that this specific change was requested after I improved > the SAPI layer to always send out the status line. If a user > had called header() to set the status code, the error would > have been the same, regardless of the SAPI layer change. > > If IIS cannot accept the CGI RFC format, a configuration > option needs to be added which chooses one of the formats. This is probably the best solution to the problem. We just have to remember to explain the issue in the release notes when 4.3.0 gets released. Perhaps also make the old format default on Windows since probably most people use php-cgi with IIS. Edin

« previous php.dev (#88589) next »