Re: Re: cvs: php4 /ext/snmp CREDITS php_snmp.h snmp.c

From: Date: Tue, 12 Nov 2002 21:42:26 +0000
Subject: Re: Re: cvs: php4 /ext/snmp CREDITS php_snmp.h snmp.c
References: 1 2 3 4  Groups: php.dev 
Request: Send a blank email to php-dev+get-90896@lists.php.net to get a copy of this message
On Tue, 12 Nov 2002, Harrie Hazewinkel wrote: > >> These function names don't follow the PHP standards, I think we should > >> definitely come up with better names. > > > > I agree. what's wrong with snmp_get, snmp_walk, and so on? > > I believe it is neccessary to have the 'v3' in the name. It makes very clear > to people that it is for snmpv3 and not any opther snmp version. > > SNMPv3 is the protocol version that has security support and is known > as under SNMPv3 by many people. But what use does it have in it's name? We don't have PGsqlV6 and pgsqlv7_, or mysqlv3_ and mysqlv4_ (or take the gd functions). > > Anyway, where would be the function name guide lines on the website. > I cannot find it and a pointer would be appreciated. See the CODING_STANDARDS file in the root of the php4/ CVS module. Derick -- --------------------------------------------------------------------------- Derick Rethans http://derickrethans.nl/ JDI Media Solutions --------------[ if you hold a unix shell to your ear, do you hear the c? ]-

« previous php.dev (#90896) next »