Bug #1884: .htaccess error / pcfg_openfile problem
| From: | jbaach at mediathek dot de | Date: | Mon, 26 Jul 1999 19:30:42 +0000 |
| Subject: | Bug #1884: .htaccess error / pcfg_openfile problem | ||
| Groups: | php.dev | ||
| Request: | Send a blank email to php-dev+get-9187@lists.php.net to get a copy of this message | ||
From: jbaach@mediathek.de
Operating system: Linux (SuSe 5.2)
PHP version: 3.0.11
PHP Bug Type: Other
Bug description: .htaccess error / pcfg_openfile problem
I sent this message yesterday to the mailinglist (US and German):
I am/was trying to upgrade my LAMP Server on my SuSE 5.2 Linux Box from
Apache 1.2.6, PHP 3.0,.... to
Apache 1.3.6 with
openssl-0.9.3a,
mod_ssl-2.3.3-1.3.6,
mod_auth_mysql-2.20,
PHP 3.0.11 with
mysql-3.22.23b,
pdflib-0.6,
mhash-0.5.0,
libmcrypt-2.0,
gd1.5
Everything compiles fine, and even the Servers runs. The problem is that
whenever I configure some <Directory ...> AllowOverride all
</Directory>, these can only be accessed when there is a .htaccess file
located in the directory. If there is not one, I get an "403 Error", and
I get a line telling me something like
......[crit] .. /home..../.htaccess pcfg_openfile: unable tho check
htaccessfile, ensure it is readable
This happens whenever there is _no_ .htaccess file in the directory.
This is also true for directories which do not contain any index files,
but are allowed for indexing (Options Indexes).
I tried many configurations during the last hours, and this problem even
occours with the httpd.conf file that is installed by the 'make install'
after compiling the apache.
I found (in the apache bug base) that there was some similar mistake
with older versions of apache (1.3.2), but the patches that were
mentioned there do not fit to the apache 1.3.6 code (which does not
surprise me too much ;-).
##### Workaround #######
After 6 hours of testing (rebuilding php and apache) I found out that whenever the libmcrypt is
compiled with php, this error occours. I tried libmcrypt v. 2.0 and 2.2.1. Without this library the
server works fine.
---------PHP do-conf-------
CFLAGS='-O2 -I/usr/local/openssl/include' ./configure
--with-apache=/usr/local/src/apache_1.3.6
--with-mysql=/usr/local/mysql/current --with-msql
--with-pdflib=/usr/local --with-zlib --enable-sysvshm=yes
--enable-sysvsem=yes --with-config-file-path=/etc
--enable-track-vars=yes --with-mcrypt --enable-url-includes --with-mhash
--with-gd=/usr
------------------------------
------Apache configure with-----
SSL_BASE=/usr/local/openssl ./configure --prefix=/usr/local/apache/1.3.6
\
--enable-module=ssl \
--activate-module=src/modules/php3/libphp3.a \
--enable-module=php3 \
--activate-module=src/modules/auth_mysql/libauth_mysql.a \
--enable-module=log_referer \
--enable-module=log_agent
------------------------------------