Bug #67132 [NEW]: Long docblock causes memoryleak.
| From: | m dot celmare at gmail dot com | Date: | Fri, 25 Apr 2014 13:53:22 +0000 |
| Subject: | Bug #67132 [NEW]: Long docblock causes memoryleak. | ||
| Groups: | php.doc.bugs | ||
| Request: | Send a blank email to doc-bugs+get-11174@lists.php.net to get a copy of this message | ||
From: m dot celmare at gmail dot com
Operating system: Windows 7 64bit
PHP version: 5.4.27
Package: Doc Build problem
Bug Type: Bug
Bug description:Long docblock causes memoryleak.
Description:
------------
When using Swagger-PHP to parse API Models with massive docblocks Apache
resets the connection. PHP doesn't record any error in the
php-error.log. The operating system records the following error in it's
log:
Problem signature:
Problem Event Name: APPCRASH
Application Name: httpd.exe
Application Version: 2.4.9.0
Application Timestamp: 5326ca71
Fault Module Name: php5ts.dll
Fault Module Version: 5.4.27.0
Fault Module Timestamp: 533ca875
Exception Code: c00000fd
Exception Offset: 0006d2c2
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: fe6d
Additional Information 2: fe6de80cc3219ffbfd252ae4bf2c0ab7
Additional Information 3: 284c
Additional Information 4: 284c285a14d3981816a2687969853162
This problem appeared both in PHP 5.4.27 and PHP 5.4.16 both being the
32bit version. I was able to reproduce the issue with both:
WAMPSERVER (32 bits & PHP 5.4) 2.4
XAMPP (1.8.2 / PHP 5.4.27) 32bits
Test script:
---------------
<?php
namespace Controllers\API\Company\RequestModels;
/**
* @SWG\Model()
*/
class Search {
/**
* @SWG\Property(required=true, type="SearchFilter")
*/
public $filter;
/**
* @SWG\Property(required=true, type="string",
enum="['active_member.asc','active_member.desc','name.asc','name.desc','jobs_count.asc','jobs_count.desc','cv_download_limit.asc','cv_download_limit.desc','references_count.asc','references_count.desc','last_login.asc','last_login.desc','register_date.asc','register_date.desc','last_comment_date_created.asc','last_comment_date_created.desc']")
*/
public $sort;
/**
* @SWG\Property(required=true, type="integer")
*/
public $pageNr;
/**
* @SWG\Property(required=true, type="integer")
*/
public $pageSize;
}
Expected result:
----------------
When parsing with Swagger PHP a JSON should be produced.
Actual result:
--------------
Apache resets the connection.
The Operating System logs the following error:
Problem signature:
Problem Event Name: APPCRASH
Application Name: httpd.exe
Application Version: 2.4.9.0
Application Timestamp: 5326ca71
Fault Module Name: php5ts.dll
Fault Module Version: 5.4.27.0
Fault Module Timestamp: 533ca875
Exception Code: c00000fd
Exception Offset: 0006d2c2
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: fe6d
Additional Information 2: fe6de80cc3219ffbfd252ae4bf2c0ab7
Additional Information 3: 284c
Additional Information 4: 284c285a14d3981816a2687969853162
--
Edit bug report at https://bugs.php.net/bug.php?id=67132&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=67132&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=67132&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=67132&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=67132&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=67132&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=67132&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=67132&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=67132&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=67132&r=support
Expected behavior: https://bugs.php.net/fix.php?id=67132&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=67132&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=67132&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=67132&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=67132&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=67132&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=67132&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=67132&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=67132&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=67132&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=67132&r=mysqlcfg