Doc #71210 [Ver]: Documentation is wrong for PHP7

From: Date: Fri, 08 Jan 2016 23:27:00 +0000
Subject: Doc #71210 [Ver]: Documentation is wrong for PHP7
References: 1  Groups: php.doc.bugs 
Request: Send a blank email to doc-bugs+get-13075@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71210&edit=1 ID: 71210 Updated by: tpunt@php.net Reported by: geowil11 at gmail dot com Summary: Documentation is wrong for PHP7 Status: Verified Type: Documentation Problem Package: *Web Server problem Operating System: Windows 8.1 PHP Version: 7.0.1 Block user comment: N Private report: N New Comment: Related to: Bug #53445 Previous Comments: ------------------------------------------------------------------------ [2015-12-24 15:37:19] cmb@php.net Related To: Bug #71213 ------------------------------------------------------------------------ [2015-12-24 15:10:39] cmb@php.net > http://php.net/manual/en/install.windows.manual.php > http://php.net/manual/en/install.windows.apache2.php The information on these pages is at least partially identical to install.txt[1] which already has been updated for PHP 7 (although it still needs more careful review). > Are these servers still supported? Support for NSAPI (Sun/Oracle)[2] and ISAPI (required for Sambar)[3] has been dropped as of PHP 7. Xitami might still be supported by PHP 7, but it seems that the Xitami development has been ceased[4]. [1] <https://github.com/php/php-src/blob/master/win32/install.txt> [2] <https://marc.info/?l=php-internals&m=143228457212923&w=2> [3] <https://wiki.php.net/rfc/removal_of_dead_sapis_and_exts#sapiisapi> [4] <http://www.xitami.com/main:start> ------------------------------------------------------------------------ [2015-12-24 07:00:10] requinix@php.net Bug #71168 fixed one Unix page but there are many others that need to be looked at. Here are a few I saw. Notable pages: http://php.net/manual/en/install.unix.openbsd.php http://php.net/manual/en/install.windows.manual.php http://php.net/manual/en/install.windows.apache2.php http://php.net/manual/en/install.macosx.bundled.php Are these servers still supported? http://php.net/manual/en/install.unix.sun.php http://php.net/manual/en/install.windows.sambar.php http://php.net/manual/en/install.windows.xitami.php http://php.net/manual/en/install.windows.sun.php There's also the Debian page http://php.net/manual/en/install.unix.debian.php but it doesn't like there are official packages for 7 yet. ------------------------------------------------------------------------ [2015-12-24 05:46:08] geowil11 at gmail dot com Description: ------------ --- From manual page: http://www.php.net/install.windows.apache2 --- # LoadModule php5_module "c:/php/php5apache2.dll" AddHandler application/x-httpd-php .php # configure the path to php.ini PHPIniDir "C:/php" Expected result: ---------------- Apache2 server should start Actual result: -------------- Fails with error message: httpd.exe: Syntax error on line 522 of C:/Apache24/conf/httpd.conf: Can't locate API module structure `php5_module' in file C:/PHP_7.01/php7apache2_4.dll: No error ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=71210&edit=1

« previous php.doc.bugs (#13075) next »