Doc #75883 [NEW]: Documentation about name of a session should be less restrictive
From: thomas dot gerbet at enalean dot com
Operating system:
PHP version: Irrelevant
Package: Documentation problem
Bug Type: Documentation Problem
Bug description:Documentation about name of a session should be less restrictive
Description:
------------
---
From manual page: http://www.php.net/function.session-name
---
Documentation mentions that only alphanum chars should be used as a
session name since the name can be used in URLs and cookies.
This is a bit too restrictive and prevent for example to use the cookie
prefixes restriction [1] browser feature.
According to RFC1738 and RFC3986 the characters $-_.+!*'(), should also
be safe to use in URLs and it seems that RFC6265 does not add more
limitations for cookies. These characters can probably be added to the
documentation as "safe to use" as the name of a session.
[1] https://tools.ietf.org/html/draft-west-cookie-prefixes
--
Edit bug report at https://bugs.php.net/bug.php?id=75883&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=75883&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=75883&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=75883&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=75883&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=75883&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=75883&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=75883&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=75883&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=75883&r=support
Expected behavior: https://bugs.php.net/fix.php?id=75883&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=75883&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=75883&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=75883&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=75883&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=75883&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=75883&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=75883&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=75883&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=75883&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=75883&r=mysqlcfg
Thread (5 messages)
- thomas dot gerbet at enalean dot com