Bug->Doc #76191 [Opn->Ver]: php.exe can not be started
| From: | cmb@php.net | Date: | Fri, 06 Apr 2018 11:21:23 +0000 |
| Subject: | Bug->Doc #76191 [Opn->Ver]: php.exe can not be started | ||
| References: | 1 | Groups: | php.doc.bugs |
| Request: | Send a blank email to doc-bugs+get-15587@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=76191&edit=1
ID: 76191
Updated by: cmb@php.net
Reported by: max at dtksoft dot com
Summary: php.exe can not be started
-Status: Open
+Status: Verified
-Type: Bug
+Type: Documentation Problem
-Package: memcache
+Package: *General Issues
Operating System: MS Windows Server 2008 SP2
PHP Version: 7.2.4
-Assigned To:
+Assigned To: cmb
Block user comment: N
Private report: N
New Comment:
As of PHP 7.2.0, the minimum supported versions are Windows
7/Server 2008 R2[1], which is not properly documented as
Windows installation requirement[2].
[1] <http://www.php.net/manual/en/migration72.incompatible.php#migration72.incompatible.windows-support>
[2] <http://www.php.net/manual/en/install.windows.requirements.php>
Previous Comments:
------------------------------------------------------------------------
[2018-04-06 10:44:48] max at dtksoft dot com
Description:
------------
Hello,
We have build an application based on apache+php and testing all supported OS. We have updated both
products to the latest versions:
httpd-2.4.33-win64-VC15 (Apache Lounge)
php-7.2.4-Win32-VC15-x64
After that we can't start our product because of this error:
"The Apache service named reported the following error:
>>> httpd.exe: Syntax error on line 182 of C:/Program Files/DTK Software/DTK
>>> LPR/apache/conf/httpd.conf: Cannot load php/php7apache2_4.dll into server: The specified procedure
>>> could not be found."
After investigation we have concluded that "php.exe" can not be started but only on MS
Windows Server 2008 SP2 (important not 2008 R2), but previous version 7.1.16 of "php.exe"
does work fine on this OS.
Screenshot uploaded to: https://imgur.com/a/UolSJ
Could you please investigate.
Test script:
---------------
Requirements:
- MS Windows Server 2008 SP2 (important that it is not 2008 R2)
- php-7.2.4-Win32-VC15-x64
1) Run Command Prompt
2) locate php-7.2.4-Win32-VC15-x64 folder
3) run php.exe -a command
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=76191&edit=1