Doc #76728 [Opn->Spm]: VIPADA SANGKAEW
| From: | peehaa@php.net | Date: | Fri, 10 Aug 2018 18:04:15 +0000 |
| Subject: | Doc #76728 [Opn->Spm]: VIPADA SANGKAEW | ||
| References: | 1 | Groups: | php.doc.bugs |
| Request: | Send a blank email to doc-bugs+get-15953@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=76728&edit=1
ID: 76728
Updated by: peehaa@php.net
Reported by: vipadasangkaew at gmail dot com
Summary: VIPADA SANGKAEW
-Status: Open
+Status: Spam
Type: Documentation Problem
Package: *General Issues
Operating System: weekend._CONFIRMING._To
PHP Version: Next Minor Version
Block user comment: N
Private report: N
Previous Comments:
------------------------------------------------------------------------
[2018-08-10 17:58:56] vipadasangkaew at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/language.variables.external
---
Please find minutes at
https://www.w3.org/2018/08/06-aria-apg-minutes.html
James Nurthen | Accessibility Engineer | Adobe | p. 415.832.2734 | c. 415.987.1918 |
nurthen@adobe.com
On 8/3/18, 1:30 PM, "Matt King" <a11ythinker@gmail.com> wrote:
Monday, 6 August 2018 ARIA Authoring Practices Task Force
Time: 10:00 AM US Pacific, 1:00 PM US Eastern
duration: 60 minutes
IRC server: irc.w3.org, port: 6665, channel: #aria-apg
Agenda: https://github.com/w3c/aria-practices/wiki/August-6%2C-2018-Meeting
Topics:
* Review APG 1.1 Release 3 Plan
* Handling invalid spinbutton input
* WCAG requirements for tooltip
* aria-controls and aria-expanded on tabs
* Purpose and intended effect of separators in menus
* Future meetings and other business
-------------------------------------------------------
To join the WebEx audio conference, you may call in via phone or join the online meeting and
request a call back to any number.
US toll call-in: +1-617-324-0000
Access code (meeting number): 640 859 469
Mobile Auto Dial:+1-617-324-0000,,,640859469#
To join the online meeting:
1. Go to https://mit.webex.com/mit/j.php?MTID=ma880be53415dc3d751387cd2fcc47cb7
2. Enter your name and email address.
3. Enter the meeting password. You may ask for it on the IRC channel if you do not know it.
4. Click "Join".
WebEx support:
1. Go to https://mit.webex.com/mit/mc
2. From the left navigation bar, choose "Support".
Test script:
---------------
Thanks for the feedback! I've addressed this in https://github.com/httpwg/http-extensions/commit/c2ae923f03a25432c145292b0ceda5f99f750e22,
with a couple clarifications inline.
On Tue, Jul 31, 2018 at 6:06 AM Alexey Melnikov <alexey.melnikov@isode.com> wrote:
Hi,
The document is well written, but I have a short list of issues I would like to discuss:
2.1. Response Header Field Syntax
Expect-CT = #expect-ct-directive
expect-ct-directive = directive-name [ "=" directive-value ]
directive-name = token
directive-value = token / quoted-string
Figure 1: Syntax of the Expect-CT header field
Optional white space ("OWS") is used as defined in Section 3.2.3 of
I don't see "OWS" used above. Should it be used around the "=" character?
It looks like you've copied syntanx from RFC 6797, which used old HTTP ABNF with "implied
*LWS" rule.
So you need to update it to explicitly insert OWS. (It is already a part of #expect-ct-directive
construct though.)
This was leftover from mashing up RFC 6797 and 7469, and I think it's actually just not needed
at all anymore (no OWS is intended around the "=").
2.1.1. The report-uri Directive
The first mention of HSTS in Section 2.1.1 needs a reference to [RFC6797].
UAs SHOULD limit the rate at which they send reports. For example,
it is unnecessary to send the same report to the same "report-uri"
more than once.
"More than once" in which period. Ever? I think you need to elaborate/clarify here.
In Section 3.1:
* The "serialized_sct" key, with a string value. If the value of
the "version" key is "1", the UA MUST set this value to the
base64 encoded [RFC4648] serialized
Which base64 alphabet? There is one in section 4 and another one in section 5 of that RFC.
Is this really needed? Happy to include it for clarity's sake, but Section 5 of RFC 4648
already says:
This encoding may be referred to as "base64url". This encoding
should not be regarded as the same as the "base64" encoding and
should not be referred to as only "base64". Unless clarified
otherwise, "base64" refers to the base 64 in the previous section.
"SignedCertificateTimestamp" structure from Section 3.2 of
[RFC6962]. If the value of the "version" key is "2", the UA
MUST set this value to the base64 encoded [RFC4648] serialized
As above.
"TransItem" structure representing the SCT, as defined in
Section 4.5 of [I-D.ietf-trans-rfc6962-bis].
6.1. Header Field Registry
This document registers the "Expect-CT" header field in the
"Permanent Message Header Field Names" registry located at
https://www.iana.org/assignments/message-headers
[4].
Header field name: Expect-CT
Applicable protocol: http
Status: standard
As per 3864, I think this field has to have the value "experimental":
Status:
Specify "standard", "experimental", "informational",
"historic",
"obsoleted", or some other appropriate value according to the type
and status of the primary document in which it is defined. For
non-IETF specifications, those formally approved by other
standards bodies should be labelled as "standard"; others may be
"informational" or "deprecated" depending on the reason for
registration.
Best Regards,
Alexey
Expected result:
----------------
Hi,
The document is well written, but I have a short list of issues I would like to discuss:
2.1. Response Header Field Syntax
Expect-CT = #expect-ct-directive
expect-ct-directive = directive-name [ "=" directive-value ]
directive-name = token
directive-value = token / quoted-string
Figure 1: Syntax of the Expect-CT header field
Optional white space ("OWS") is used as defined in Section 3.2.3 of
I don't see "OWS" used above. Should it be used around the "=" character?
It looks like you've copied syntanx from RFC 6797, which used old HTTP ABNF with "implied
*LWS" rule.
So you need to update it to explicitly insert OWS. (It is already a part of #expect-ct-directive
construct though.)
2.1.1. The report-uri Directive
The first mention of HSTS in Section 2.1.1 needs a reference to [RFC6797].
UAs SHOULD limit the rate at which they send reports. For example,
it is unnecessary to send the same report to the same "report-uri"
more than once.
"More than once" in which period. Ever? I think you need to elaborate/clarify here.
In Section 3.1:
* The "serialized_sct" key, with a string value. If the value of
the "version" key is "1", the UA MUST set this value to the
base64 encoded [RFC4648] serialized
Which base64 alphabet? There is one in section 4 and another one in section 5 of that RFC.
"SignedCertificateTimestamp" structure from Section 3.2 of
[RFC6962]. If the value of the "version" key is "2", the UA
MUST set this value to the base64 encoded [RFC4648] serialized
As above.
"TransItem" structure representing the SCT, as defined in
Section 4.5 of [I-D.ietf-trans-rfc6962-bis].
6.1. Header Field Registry
This document registers the "Expect-CT" header field in the
"Permanent Message Header Field Names" registry located at
https://www.iana.org/assignments/message-headers
[4].
Header field name: Expect-CT
Applicable protocol: http
Status: standard
As per 3864, I think this field has to have the value "experimental":
Status:
Specify "standard", "experimental", "informational",
"historic",
"obsoleted", or some other appropriate value according to the type
and status of the primary document in which it is defined. For
non-IETF specifications, those formally approved by other
standards bodies should be labelled as "standard"; others may be
"informational" or "deprecated" depending on the reason for
registration.
Best Regards,
Alexey
Thanks for the feedback! I've addressed this in https://github.com/httpwg/http-extensions/commit/c2ae923f03a25432c145292b0ceda5f99f750e22,
with a couple clarifications inline.
On Tue, Jul 31, 2018 at 6:06 AM Alexey Melnikov <alexey.melnikov@isode.com> wrote:
Hi,
The document is well written, but I have a short list of issues I would like to discuss:
2.1. Response Header Field Syntax
Expect-CT = #expect-ct-directive
expect-ct-directive = directive-name [ "=" directive-value ]
directive-name = token
directive-value = token / quoted-string
Figure 1: Syntax of the Expect-CT header field
Optional white space ("OWS") is used as defined in Section 3.2.3 of
I don't see "OWS" used above. Should it be used around the "=" character?
It looks like you've copied syntanx from RFC 6797, which used old HTTP ABNF with "implied
*LWS" rule.
So you need to update it to explicitly insert OWS. (It is already a part of #expect-ct-directive
construct though.)
This was leftover from mashing up RFC 6797 and 7469, and I think it's actually just not needed
at all anymore (no OWS is intended around the "=").
2.1.1. The report-uri Directive
The first mention of HSTS in Section 2.1.1 needs a reference to [RFC6797].
UAs SHOULD limit the rate at which they send reports. For example,
it is unnecessary to send the same report to the same "report-uri"
more than once.
"More than once" in which period. Ever? I think you need to elaborate/clarify here.
In Section 3.1:
* The "serialized_sct" key, with a string value. If the value of
the "version" key is "1", the UA MUST set this value to the
base64 encoded [RFC4648] serialized
Which base64 alphabet? There is one in section 4 and another one in section 5 of that RFC.
Is this really needed? Happy to include it for clarity's sake, but Section 5 of RFC 4648
already says:
This encoding may be referred to as "base64url". This encoding
should not be regarded as the same as the "base64" encoding and
should not be referred to as only "base64". Unless clarified
otherwise, "base64" refers to the base 64 in the previous section.
"SignedCertificateTimestamp" structure from Section 3.2 of
[RFC6962]. If the value of the "version" key is "2", the UA
MUST set this value to the base64 encoded [RFC4648] serialized
As above.
"TransItem" structure representing the SCT, as defined in
Section 4.5 of [I-D.ietf-trans-rfc6962-bis].
6.1. Header Field Registry
This document registers the "Expect-CT" header field in the
"Permanent Message Header Field Names" registry located at
https://www.iana.org/assignments/message-headers
[4].
Header field name: Expect-CT
Applicable protocol: http
Status: standard
As per 3864, I think this field has to have the value "experimental":
Status:
Specify "standard", "experimental", "informational",
"historic",
"obsoleted", or some other appropriate value according to the type
and status of the primary document in which it is defined. For
non-IETF specifications, those formally approved by other
standards bodies should be labelled as "standard"; others may be
"informational" or "deprecated" depending on the reason for
registration.
Best Regards,
Alexey
Actual result:
--------------
Please find minutes at
https://www.w3.org/2018/08/06-aria-apg-minutes.html
James Nurthen | Accessibility Engineer | Adobe | p. 415.832.2734 | c. 415.987.1918 |
nurthen@adobe.com
On 8/3/18, 1:30 PM, "Matt King" <a11ythinker@gmail.com> wrote:
Monday, 6 August 2018 ARIA Authoring Practices Task Force
Time: 10:00 AM US Pacific, 1:00 PM US Eastern
duration: 60 minutes
IRC server: irc.w3.org, port: 6665, channel: #aria-apg
Agenda: https://github.com/w3c/aria-practices/wiki/August-6%2C-2018-Meeting
Topics:
* Review APG 1.1 Release 3 Plan
* Handling invalid spinbutton input
* WCAG requirements for tooltip
* aria-controls and aria-expanded on tabs
* Purpose and intended effect of separators in menus
* Future meetings and other business
-------------------------------------------------------
To join the WebEx audio conference, you may call in via phone or join the online meeting and
request a call back to any number.
US toll call-in: +1-617-324-0000
Access code (meeting number): 640 859 469
Mobile Auto Dial:+1-617-324-0000,,,640859469#
To join the online meeting:
1. Go to https://mit.webex.com/mit/j.php?MTID=ma880be53415dc3d751387cd2fcc47cb7
2. Enter your name and email address.
3. Enter the meeting password. You may ask for it on the IRC channel if you do not know it.
4. Click "Join".
WebEx support:"VIPADA
SANGKAEW,ID:1-311-100-10101-8,THAILAND,(+66)92-326-4355,"VIPADASANGKAEW@GMAIL.COM".
1. Go to https://mit.webex.com/mit/mc
2. From the left navigation bar, choose "Support".
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=76728&edit=1