Doc #79401 [Com]: --with-openssl no longer accepts a directory
Edit report at https://bugs.php.net/bug.php?id=79401&edit=1
ID: 79401
Comment by: bayerdweruf dot f at googlemail dot com
Reported by: omero72 at hotmail dot de
Summary: --with-openssl no longer accepts a directory
Status: Verified
Type: Documentation Problem
Package: OpenSSL related
Operating System: macOS 10.10.5 (Yosemite)
PHP Version: 7.4.4
Block user comment: N
Private report: N
New Comment:
That was great thnaks.
(https://www.mibridges.me/)github.com
Previous Comments:
------------------------------------------------------------------------
[2020-03-21 17:21:15] cmb@php.net
Great that you've got it working! And no need to apologize; this
needs to be documented in the manual proper (not only in the
migration guide).
------------------------------------------------------------------------
[2020-03-21 15:37:23] omero72 at hotmail dot de
Ops! I didn't know it checked the openssl based solely on pkg-config. It turns out that my
openssl related .pc files under /usr/local/lib/pkgconfig were incomplete. I have corrected the .pc
file thereunder and php7 got built perfectly.
------------------------------------------------------------------------
[2020-03-21 09:12:05] cmb@php.net
As of PHP 7.4.0, --with-openssl no longer accepts a directory;
instead the location of the library is determined by
pkg-config[1], and this likely detected your system library,
instead of the custom one you're intending to use.
[1] <https://www.php.net/manual/en/migration74.other-changes.php#migration74.other-changes.pkg-config>
------------------------------------------------------------------------
[2020-03-20 21:13:28] omero72 at hotmail dot de
Description:
------------
./configure --prefix=$PHP7 --mandir=/usr/share/man --infodir=/usr/share/info --sysconfdir=/etc
--with-config-file-path=/etc --with-zlib --with-zlib-dir=/usr --with-iconv --enable-exif
--enable-ftp --enable-mbstring --enable-mbregex --enable-sockets --with-pdo-mysql --with-mysqli
--with-openssl=/usr/local/openssl-1.1.1d --with-curl --enable-fpm
configures fine but, make fails with (truncated)
/Users/yose/Downloads/php-7.4.4/ext/openssl/openssl.c:1150:7: error: no member named
'global_config' in
'struct php_x509_request'
req->global_config = CONF_load(NULL, default_ssl_conf_filename, NULL);
~~~ ^
/Users/yose/Downloads/php-7.4.4/ext/openssl/openssl.c:1150:23: warning: 'CONF_load' is
deprecated: first deprecated in
OS X 10.7 [-Wdeprecated-declarations]
req->global_config = CONF_load(NULL, default_ssl_conf_filename, NULL);
^
/usr/include/openssl/conf.h:123:8: note: 'CONF_load' has been explicitly marked deprecated
here
LHASH *CONF_load(LHASH *conf,const char *file,long *eline)
DEPRECATED_IN_MAC_OS_X_VERSION_10_7_AND_LATER;
^
/Users/yose/Downloads/php-7.4.4/ext/openssl/openssl.c:1151:11: error: no member named
'global_config' in
'struct php_x509_request'
if (req->global_config == NULL) {
~~~ ^
...
fatal error: too many errors emitted, stopping now [-ferror-limit=]
Compiler is GCC-10.0
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=79401&edit=1
Thread (2 messages)