#43129 [Opn->Fbk]: ldap_start_tls fails without ldap.conf

From: Date: Wed, 21 Nov 2007 14:04:48 +0000
Subject: #43129 [Opn->Fbk]: ldap_start_tls fails without ldap.conf
References: 1  Groups: php.doc.bugs 
Request: Send a blank email to doc-bugs+get-228@lists.php.net to get a copy of this message
ID: 43129 Updated by: vrana@php.net Reported By: micah at onshore dot com -Status: Open +Status: Feedback Bug Type: Documentation problem Operating System: Windows XP PHP Version: 5.2.4 New Comment: Isn't the path to ldap.conf get some environment variable? How did you figure out to use C:\OpenLDAP\sysconf? Previous Comments: ------------------------------------------------------------------------ [2007-10-29 20:55:31] jani@php.net Reclassified. ------------------------------------------------------------------------ [2007-10-29 17:44:59] micah at onshore dot com Description: ------------ I get a TLS Connect error when I do not have the ldap.conf file in C:\OpenLDAP\sysconf. In that file I need 'TLS_REQCERT never'. This is not documented on the start_tls function. Also, it would be nice if we can specify where the file goes. Or, even better, if we can just set this as an LDAP option without the conf file. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=43129&edit=1

« previous php.doc.bugs (#228) next »