Doc #53030 [Com]: Enabling "LoadModule php5_module" crashes apache2
| From: | privateer at bluewin dot ch | Date: | Sun, 10 Oct 2010 08:42:28 +0000 |
| Subject: | Doc #53030 [Com]: Enabling "LoadModule php5_module" crashes apache2 | ||
| References: | 1 | Groups: | php.doc.bugs |
| Request: | Send a blank email to doc-bugs+get-5186@lists.php.net to get a copy of this message | ||
Edit report at http://bugs.php.net/bug.php?id=53030&edit=1
ID: 53030
Comment by: privateer at bluewin dot ch
Reported by: privateer at bluewin dot ch
Summary: Enabling "LoadModule php5_module" crashes apache2
Status: Feedback
Type: Documentation Problem
Package: Apache2 related
Operating System: Windows XP SP3
PHP Version: 5.3.3
Block user comment: N
New Comment:
Please close the bug.
Previous Comments:
------------------------------------------------------------------------
[2010-10-10 10:41:13] privateer at bluewin dot ch
The problem solved itself with a restart of the computer. I should have
known better...
Thanks for your help!
------------------------------------------------------------------------
[2010-10-09 18:46:06] kalle@php.net
Does it also fail if the paths are using backslashes instead of
forwardslashes? E.g.: C:\Programme\PHP\...
------------------------------------------------------------------------
[2010-10-09 16:31:03] privateer at bluewin dot ch
Description:
------------
First, the facts:
Windows XP SP3
Apache HTTP Server 2.2
PHP 5.3.3 (MSI installer)
The problem: when I try to start apache with PHP enabled, apache crashes
and throws this windows error:
szAppName : httpd.exe
szAppVer : 2.2.16.0
szModName : php5ts.dll
szModVer : 5.3.3.0
offset : 000e74ec
I have made the following changes to Apache http.conf:
Added LoadModule php5_module "C:/Programme/PHP/php5apache2_2.dll"
Added PHPIniDir "C:/Programme/PHP"
I have made the following changes to php.ini:
short_open_tag = On
error_reporting = E_ALL | E_STRICT
display_errors = On
I also made sure to add C:/Programme/PHP to windows PATH[/i].
When I comment LoadModule ... and PHPIniDir ... in the httpd.conf,
apache starts without any problems.
What is wrong?
Expected result:
----------------
The apache server starts up
Actual result:
--------------
The apache server crashes and Windows reports the following:
szAppName : httpd.exe
szAppVer : 2.2.16.0
szModName : php5ts.dll
szModVer : 5.3.3.0
offset : 000e74ec
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/bug.php?id=53030&edit=1