Doc #47178 [Opn->Csd]: Missing gzip headers in gzencode() output

From: Date: Mon, 12 Nov 2012 02:33:59 +0000
Subject: Doc #47178 [Opn->Csd]: Missing gzip headers in gzencode() output
References: 1  Groups: php.doc.bugs 
Request: Send a blank email to doc-bugs+get-9084@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=47178&edit=1 ID: 47178 Updated by: aharvey@php.net Reported by: wharmby at uk dot ibm dot com Summary: Missing gzip headers in gzencode() output -Status: Open +Status: Closed Type: Documentation Problem -Package: Zlib related +Package: Documentation problem Operating System: Windows XP PHP Version: 5.4 -Assigned To: +Assigned To: aharvey Block user comment: N Private report: N New Comment: This bug has been fixed in the documentation's XML sources. Since the online and downloadable versions of the documentation need some time to get updated, we would like to ask you to be a bit patient. Thank you for the report, and for helping us make our documentation better. Previous Comments: ------------------------------------------------------------------------ [2012-11-12 02:33:35] aharvey@php.net Automatic comment from SVN on behalf of aharvey Revision: http://svn.php.net/viewvc/?view=revision&revision=328313 Log: Update gzencode() documentation for the new FORCE_DEFLATE behaviour in PHP 5.4. Fixes doc bug #47178 (Missing gzip headers in gzencode() output). ------------------------------------------------------------------------ [2012-01-18 17:13:57] mike@php.net This bug has been fixed in SVN. Snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. Thank you for the report, and for helping us make PHP better. I removed the XFAIL now, and added a note to the UPDGRADE guide. ------------------------------------------------------------------------ [2011-09-30 06:51:46] mike@php.net So can this ticket be changed to closed? The code will be released with PHP- 5.4... ------------------------------------------------------------------------ [2010-05-31 15:23:27] mike@php.net So? This code went into trunk now. ------------------------------------------------------------------------ [2009-03-03 22:11:13] mike@php.net Hi Andy! Sorry for the standard-bla of the quick fix in my previos response. Interestingly, gzencode(..., FORCE_DEFLATE) does not make any sense to me in PHP versions lower than v6. I cannot remember why or even if I noticed this legacy behaviour back when I reimplemented zlib code. For clarification: RFC1951 = raw deflate - not much to say here RFC1950 = zlib encoding, AKA HTTP deflate; - being [zlib header][deflated data][adler checksum] RFC1952 = gzip encoding - being [gzip header][deflated data][crc32 checksum, original size] The output of PHP5s gzencode(..., FORCE_DEFLATE) is neither of the previous formats, but rather zlib encoded data additionally prepended with a gzip header: [gzip header][zlib header][deflated data][adler checksum] This is obscure IMHO. Obviously, this exists and is even documented for ages, so I kindly ask you to take this issue to internals@ for discussion, so people can decide what's going to happen. Thank you. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=47178 -- Edit this bug report at https://bugs.php.net/bug.php?id=47178&edit=1

« previous php.doc.bugs (#9084) next »