cvs: phpdoc-da /reference/mail/functions mail.xml

From: Date: Sat, 02 Oct 2004 09:41:20 +0000
Subject: cvs: phpdoc-da /reference/mail/functions mail.xml
Groups: php.doc.da 
Request: Send a blank email to doc-da+get-261@lists.php.net to get a copy of this message
lauer Sat Oct 2 05:41:20 2004 EDT Added files: /phpdoc-da/reference/mail/functions mail.xml Log: Initial translation

http://cvs.php.net/co.php/phpdoc-da/reference/mail/functions/mail.xml?r=1.1&p=1 Index: phpdoc-da/reference/mail/functions/mail.xml +++ phpdoc-da/reference/mail/functions/mail.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.28 Maintainer: lauer Status: ready --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> <refpurpose>Send mail</refpurpose> </refnamediv> <refsect1> <title>Beskrivelse</title> <methodsynopsis> <type>bool</type><methodname>mail</methodname> <methodparam><type>string</type><parameter>til</parameter></methodparam> <methodparam><type>string</type><parameter>emne</parameter></methodparam> <methodparam><type>string</type><parameter>besked</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>ekstra_hovedvaribler</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>ekstra_parameter</parameter></methodparam> </methodsynopsis> <simpara> <function>mail</function> sender automatisk en email med beskeden angivet i <paramenter>besked</paramenter> til modtageren angivet i <parameter>til</parameter>. Flere modtagere kan angives ved at indsætte et comma mellem hvor adresse i <parameter>til</parameter>. E-mail med vedhæftet fil og specielle typer af indhold kan også sendes med denne funktion. Det er muligt ved hjælp af MIME-encoding - læs mere om det i denne <ulink url="&url.email.mime.zend;"> Zend artikel</ulink> eller i <ulink url="&url.pear.package;Mail_Mime"> PEAR Mime Klasser</ulink>. </simpara> <simpara> De følgende RFC's forklarer også mere om problemstillingen: <ulink url="&url.rfc;1896">RFC 1896</ulink>, <ulink url="&url.rfc;2045">RFC 2045</ulink>, <ulink url="&url.rfc;2046">RFC 2046</ulink>, <ulink url="&url.rfc;2047">RFC 2047</ulink>, <ulink url="&url.rfc;2048">RFC 2048</ulink>, og <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> <function>mail</function> returner &true; hvis e-mailen blev modtaget korrekt, og ellers &false. </para> <warning> <para> Windows versionen af <function>mail</function> er forskellige fra Unix versionen på mange måder. For det første bruger den ikke en lokal program til at sende mailen, men bruger en direkte forbindelse til en <literal>MTA</literal> som enten kan være lokal eller ekstern. For det andet er hovedvariablerne som <literal>From:</literal>, <literal>Cc:</literal>, <literal>Bcc:</literal> og <literal>Date:</literal> er <emphasis role="strong">ikke</emphasis> kontroleret af <literal>MTA</literal> i første omgang, men bearbejdet af PHP. PHP &lt; 4.3 understøtter kun <literal>Cc:</literal> elementet (og skulle korrekt med store og små bogstaver). PHP &gt;= 4.3 understøtter alle de nævte hovedvariabler og er ikke længere styret af store og små bogstaver. </para> </warning> <para> <example> <title>Afsendelse af en e-mail.</title> <programlisting role="php"> <![CDATA[ <?php mail("joecool@example.com", "Mit emne", "Linje 1\nLinje 2\nLinje 3"); ?> ]]> </programlisting> </example> </para> <simpara> Hvis den fjerde streng argument er angivet, bliver denne streng indsat til sidst i brevhovedet. Den bliver typisk brugt til at tilføje ekstra variabler til brevhovet. Ved flere ekstra variabler skal de separateres med en linjeafslutning og ny linje. </simpara> <note> <para> Du skal bruge <literal>\r\n</literal> til at separatere hovedvariablerne, selvom nogen Unix mailafsendings programmer vil virke med kun en enkel ny linje. (<literal>\n</literal>). </para> </note> <para> <example> <title>Afsending af mails med extra hovedvariabler.</title> <programlisting role="php"> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}\r\n" . "Reply-To: webmaster@{$_SERVER['SERVER_NAME']}\r\n" . "X-Mailer: PHP/" . phpversion()); ?> ]]> </programlisting> </example> </para> <para> Elementet <parameter>ekstra_parameter</parameter> kan blive brugt til at tilføje flere parameter til programmet der afsender e-mailen, som er blevet valgt ved brug af <literal>sendmail_path</literal> i indstillingerne af PHP. For eksempel kan den bruges til at sende webmasterens e-mailadresse med ved brug af sendmail med <literal>-f</literal> sendmail paramenteren. Du kan også få brug for at sende hvilken bruger webserveren bruger til at sende mailen med, for at undgå en 'X-Warning' bliver tilføjet i brevhovedet når du sender webmasterens e-mailadresse med ved overstående metode. <example> <title>Afsendning af e-mail med ekstra hovedvariabler og ekstra paramenter til sendmail-programmet.</title> <programlisting role="php"> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}", "-fwebmaster@{$_SERVER['SERVER_NAME']}"); ?> ]]> </programlisting> </example> </para> <note> <para> Den femte paramenter blev tilføjet i PHP 4.0.5. Siden PHP 4.2.4 er denne parameter slået fra i <link linkend="ini.safe-mode">safe_mode</link> og <function>mail</function> funktionen vil komme med en advarsel og returner &false; hvis du prøver at bruge den. </para> </note> <para> Du kan også gøre brug af en simpel strengmetode til at bruge en kompleks e-mailbesked <example> <title>Afsending af en kompleks besked.</title> <programlisting role="php"> <![CDATA[ <?php /* recipients */ $to = "mary@example.com" . ", " ; // note the comma $to .= "kelly@example.com"; /* subject */ $subject = "Birthday Reminders for August"; /* message */ $message = ' <html> <head> <title>Birthday Reminders for August</title> </head> <body> <p>Here are the birthdays upcoming in August!</p> <table> <tr> <th>Person</th><th>Day</th><th>Month</th><th>Year</th> </tr> <tr> <td>Joe</td><td>3rd</td><td>August</td><td>1970</td> </tr> <tr> <td>Sally</td><td>17th</td><td>August</td><td>1973</td> </tr> </table> </body> </html> '; /* To send HTML mail, you can set the Content-type header. */ $headers = "MIME-Version: 1.0\r\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; /* additional headers */ $headers .= "To: Mary <mary@example.com>, Kelly <kelly@example.com>\r\n"; $headers .= "From: Birthday Reminder <birthday@example.com>\r\n"; $headers .= "Cc: birthdayarchive@example.com\r\n"; $headers .= "Bcc: birthdaycheck@example.com\r\n"; /* and now mail it */ mail($to, $subject, $message, $headers); ?> ]]> </programlisting> </example> </para> <note> <para> Vær sikker på at du ikke har linjeskift i <parameter>til</parameter> eller <parameter>emne</parameter>, da e-mailen muligvis ikke vil blive sendt korrekt så. </para> </note> <note> <para> Parameteren <parameter>til</parameter> skal ikke være en adresse i form af &quot;Something &lt;someone@example.com&gt;&quot;. Mailprogrammet vil ikke altid sende mailen korrekt. (Især under Windows). </para> </note> <para> Se også <function>imap_mail</function>. </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->
« previous php.doc.da (#261) next »