cvs: phpdoc-de /reference/mail functions.xml ini.xml reference.xml /reference/mail/functions ezmlm-hash.xml mail.xml

From: Date: Fri, 27 Jun 2003 13:42:12 +0000
Subject: cvs: phpdoc-de /reference/mail functions.xml ini.xml reference.xml /reference/mail/functions ezmlm-hash.xml mail.xml
Groups: php.doc.de 
Request: Send a blank email to doc-de+get-792@lists.php.net to get a copy of this message
wiesemann Fri Jun 27 09:42:12 2003 EDT Added files: /phpdoc-de/reference/mail ini.xml /phpdoc-de/reference/mail/functions ezmlm-hash.xml Modified files: /phpdoc-de/reference/mail functions.xml reference.xml /phpdoc-de/reference/mail/functions mail.xml Log: sync to en, setting me as the maintainer

Index: phpdoc-de/reference/mail/functions.xml diff -u /dev/null phpdoc-de/reference/mail/functions.xml:1.3 --- /dev/null Fri Jun 27 09:42:12 2003 +++ phpdoc-de/reference/mail/functions.xml Fri Jun 27 09:42:12 2003 @@ -0,0 +1,2 @@ +&reference.mail.functions.ezmlm-hash; +&reference.mail.functions.mail; Index: phpdoc-de/reference/mail/reference.xml diff -u phpdoc-de/reference/mail/reference.xml:1.3 phpdoc-de/reference/mail/reference.xml:1.4 --- phpdoc-de/reference/mail/reference.xml:1.3 Fri May 31 13:24:39 2002 +++ phpdoc-de/reference/mail/reference.xml Fri Jun 27 09:42:12 2003 @@ -1,11 +1,51 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> +<!-- EN-Revision: 1.9 Maintainer: wiesemann Status: ready --> <reference id="ref.mail"> - <title>Mail Funktionen</title> + <title>Mail-Funktionen</title> <titleabbrev>Mail</titleabbrev> <partintro> - <simpara> - Die <function>mail</function> Funktionen erlauben das Versenden von Mail.</simpara> + + <section id="mail.intro"> + &reftitle.intro; + <para> + Die <function>mail</function>-Funktion erlaubt das Versenden von Mail. + </para> + </section> + + <section id="mail.requirements"> + &reftitle.required; + <para> + PHP muss während des Kompilierens Zugriff auf die Binärversion von + <literal>sendmail</literal> auf Ihrem Rechner haben. Falls Sie ein + anderes Mail-Programm, wie z.B. qmail oder postfix, benutzen, müssen + Sie dafür sorgen, dass Sie den passenden, mitgelieferten sendmail-Wrapper + verwenden. PHP sucht nach sendmail zunächst im + System-<literal>PATH</literal> und anschließend hier: + <literal>/usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib</literal>. + Wir empfehlen, dass sendmail auf Ihrem Rechner im <literal>PATH</literal> + verfügbar ist. Der Benutzer, der PHP kompiliert hat, muss die Berechtigung + haben, auf die Binärversion von sendmail zuzugreifen. + </para> + </section> + + <section id="mail.installation"> + &reftitle.install; + &no.install; + </section> + + &reference.mail.ini; + + <section id="mail.resources"> + &reftitle.resources; + &no.resource; + </section> + + <section id="mail.constants"> + &reftitle.constants; + &no.constants; + </section> + </partintro> &reference.mail.functions; Index: phpdoc-de/reference/mail/functions/mail.xml diff -u phpdoc-de/reference/mail/functions/mail.xml:1.2 phpdoc-de/reference/mail/functions/mail.xml:1.3 --- phpdoc-de/reference/mail/functions/mail.xml:1.2 Sun Jun 9 06:55:48 2002 +++ phpdoc-de/reference/mail/functions/mail.xml Fri Jun 27 09:42:12 2003 @@ -1,7 +1,6 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> -<!-- splitted from ./de/functions/mail.xml, last change in rev 1.2 --> -<!-- last change to 'mail' in en/ tree in rev 1.2 --> +<!-- $Revision: 1.3 $ --> +<!-- EN-Revision: 1.17 Maintainer: wiesemann Status: ready --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> @@ -15,32 +14,195 @@ <methodparam><type>string</type><parameter>subject</parameter></methodparam> <methodparam><type>string</type><parameter>message</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>additional_headers</parameter></methodparam> + <methodparam choice="opt"><type>string</type><parameter>additional_parameters</parameter></methodparam> </methodsynopsis> <simpara> <function>mail</function> veschickt die Nachricht in <parameter>message</parameter> an den Empfänger in <parameter>to</parameter>. Mehrere Empfänger können angegeben werden, indem ein Komma zwischen die Adressen in - <parameter>to</parameter> gesetzt wird.</simpara> + <parameter>to</parameter> gesetzt wird. + E-Mails mit angehängten Dateien und speziellen Inhaltstypen können mit + dieser Funktion gesendet werden. Dies wird durch MIME-Kodierung ermöglicht. + Für weitere Informationen siehe diesen <ulink + url="&url.email.mime.zend;">Zend-Artikel</ulink> oder die <ulink + url="&url.email.mime.pear;">PEAR Mime-Klassen</ulink>. + </simpara> + <simpara> + Die folgenden RFCS könnten auch hilfreich sein: + <ulink url="&url.rfc;1896">RFC 1896</ulink>, + <ulink url="&url.rfc;2045">RFC 2045</ulink>, + <ulink url="&url.rfc;2046">RFC 2046</ulink>, + <ulink url="&url.rfc;2047">RFC 2047</ulink>, + <ulink url="&url.rfc;2048">RFC 2048</ulink> und + <ulink url="&url.rfc;2049">RFC 2049</ulink>. + </simpara> + <para> + <function>mail</function> gibt &true; zurück, wenn die Mail erfolgreich + für den Versand akzeptiert wurde, sonst &false;. + </para> + <warning> + <para> + Die Windows-Implementierung der <function>mail</function>-Funktion + unterscheidet sich stark von der Unix-Implemtierung. Zum einen benutzt + sie keine lokales Programm, um die Mails zu erstellen, sondern sie + arbeitet auf Sockets. D.h., dass ein <literal>MTA</literal> benötigt + wird, der auf einem Netzwerk-Socket lauscht (entweder auf dem eigenen + oder einem entfernten Rechner). Zum anderen werden die + benutzerdefinierten Header wie <literal>From:</literal>, + <literal>Cc:</literal>, <literal>Bcc:</literal> und + <literal>Date:</literal> <emphasis role="strong">nicht</emphasis> + direkt durch den <literal>MTA</literal> interpretiert, sondern zunächst + von <literal>PHP</literal> geparst. <literal>PHP</literal> &lt; 4.3 + unterstützte nur den <literal>Cc:</literal>-Header (und berücksichtigte + die Groß-/Kleinschreibung). <literal>PHP</literal> &gt;= 4.3 + unterstützt alle genannten Header und ist berücksichtigt nicht mehr die + Groß-/Kleinschreibung. + </para> + </warning> <para> <example> - <title>Verschicken von Mail.</title> + <title>Verschicke von Mail.</title> <programlisting> -mail("rasmus@lerdorf.on.ca", "My Subject", "Line 1\nLine 2\nLine 3"); +<![CDATA[ +<?php +mail("nobody@example.com", "Betreff", "Zeile 1\nZeile 2\nZeile 3"); +?> +]]> </programlisting> - </example></para> + </example> + </para> <simpara> Wenn ein vierter String-Parameter übergeben wird, dann wird dieser an das Ende des Mail-Headers gehängt. Mehrfache Header werden - durch einen Zeilenumbruch getrennt.</simpara> + durch einen Zeilenumbruch getrennt. + </simpara> + <note> + <para> + Sie müssen die Header mit <literal>\r\n</literal> trennen, auch wenn + einige Unix-MTAs auch mit einem einfachen Zeilenumbruch + (<literal>\n</literal>) korrekt arbeiten. + </para> + </note> + <para> + <example> + <title>Verschicke Mail mit zusätzlichen Headern.</title> + <programlisting> +<![CDATA[ +<?php +mail("nobody@example.com", "Betreff", $message, + "From: webmaster@{$_SERVER['SERVER_NAME']}\r\n" + ."Reply-To: webmaster@{$_SERVER['SERVER_NAME']}\r\n" + ."X-Mailer: PHP/" . phpversion()); +?> +]]> + </programlisting> + </example> + </para> <para> + Der Parameter <parameter>additional_parameters</parameter> kann benutzt + werden, um zusätzliche Parameter an das Programm zu übergeben, das + für den Mail-Versand über die Option <literal>sendmail_path</literal> + konfiguriert wurde. Zum Beispiel kann dies genutzt werden, um die + Envelope-Absenderadresse anzugeben, wenn sendmail benutzt wird + (Option <literal>-f</literal>). Eventuell müssen Sie den Benutzer, + unter dem Ihr Webserver läuft, als sendmail-Option übergeben, um zu + verhindern, dass Ihrer Mail ein 'X-Warning'-Header angehängt wird, + wenn Sie die Envelope-Absenderadresse auf diese Art setzen. <example> - <title>Verschicke Mail mit zusätzlichen Headers.</title> + <title>Verschicke Mail mit zusätzlichen Headern und einem zusätzlichen Kommandozeilen-Parameter.</title> <programlisting> -mail("nobody@aol.com", "the subject", $message, - "From: webmaster@$SERVER_NAME\nReply-To: webmaster@$SERVER_NAME\nX-Mailer: PHP/" . phpversion()); +<![CDATA[ +<?php +mail("nobody@example.com", "Betreff", $message, + "From: webmaster@{$_SERVER['SERVER_NAME']}", "-fwebmaster@{$_SERVER['SERVER_NAME']}"); +?> +]]> </programlisting> - </example></para> + </example> + </para> + <note> + <para> + Der fünfte Parameter wurde in PHP 4.0.5 hinzugefügt. Seit PHP 4.2.3 ist + dieser Parameter im <link linkend="ini.safe-mode">safe_mode</link> + deaktiviert; <function>mail</function> gibt eine Warnung aus und gibt + &false; zurück, wenn Sie den Parameter trotzdem verwenden. + </para> + </note> + <para> + Sie können einfache String-Zusammensetzungen verwenden, um komplexe + Mails zu erstellen. + <example> + <title>Verschicke komplexe Mail.</title> + <programlisting> +<![CDATA[ +<?php +/* Empfänger */ +$to = "Mary <mary@example.com>" . ", " ; // beachten Sie das Komma +$to .= "Kelly <kelly@example.com>"; + +/* Betreff */ +$subject = "Geburtstags-Erinnerung für August"; + +/* Nachricht */ +$message = ' +<html> +<head> + <title>Geburtstags-Erinnerung für August</title> +</head> +<body> +<p>Hier sind die Geburtstage im August!</p> +<table> + <tr> + <th>Person</th><th>Tag</th><th>Monat</th><th>Jahr</th> + </tr> + <tr> + <td>Joe</td><td>3.</td><td>August</td><td>1970</td> + </tr> + <tr> + <td>Sally</td><td>17.</td><td>August</td><td>1973</td> + </tr> +</table> +</body> +</html> +'; + +/* Um eine HTML-Mail zu senden, können Sie den den "Content-type"-Header. + setzen */ +$headers = "MIME-Version: 1.0\r\n"; +$headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; + +/* zusätzliche Header */ +$headers .= "From: Geburtstags-Erinnerung <geburtstag@example.com>\r\n"; + +$headers .= "Cc: geburtstagsarchiv@example.com\r\n"; +$headers .= "Bcc: geburtstagscheck@example.com\r\n"; + +/* Verschicken der Mail */ +mail($to, $subject, $message, $headers); +?> +]]> + </programlisting> + </example> + </para> + <note> + <para> + Achten Sie darauf, dass Sie keine Zeilenumbruch-Zeichen + in den Parametern <parameter>to</parameter> oder + <parameter>subject</parameter> verwenden, da sonst Ihre Mail + eventuell nicht korrekt gesendet werden kann. + </para> + </note> + <note> + <para> + Der <parameter>to</parameter>-Parameter darf nicht in der Form + &quot;irgendwas &lt;irgendwer@example.com&gt;&quot; sein, da + dies von PHP nicht korrekt an den MTA übergeben werden kann. + </para> + </note> + <para> + Siehe auch <function>imap_mail</function>. + </para> </refsect1> </refentry> Index: phpdoc-de/reference/mail/ini.xml +++ phpdoc-de/reference/mail/ini.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.4 Maintainer: wiesemann Status: ready --> <section id="mail.configuration"> &reftitle.runtime; &extension.runtime; <para> <table> <title>Mail-Konfigurationsoptionen</title> <tgroup cols="3"> <thead> <row> <entry>Name</entry> <entry>Standard</entry> <entry>änderbar</entry> </row> </thead> <tbody> <row> <entry>SMTP</entry> <entry>"localhost"</entry> <entry>PHP_INI_ALL</entry> </row> <row> <entry>smtp_port</entry> <entry>"25"</entry> <entry>PHP_INI_ALL</entry> </row> <row> <entry>sendmail_from</entry> <entry>NULL</entry> <entry>PHP_INI_ALL</entry> </row> <row> <entry>sendmail_path</entry> <entry>DEFAULT_SENDMAIL_PATH</entry> <entry>PHP_INI_SYSTEM</entry> </row> </tbody> </tgroup> </table> Für weitere Details und die Definition der PHP_INI_*-Konstanten siehe <function>ini_set</function>. </para> &ini.descriptions.title; <para> <variablelist> <varlistentry id="ini.smtp"> <term> <parameter>SMTP</parameter> <type>string</type> </term> <listitem> <para> Wird nur unter Windows benutzt: DNS-Name oder IP-Adresse des SMTP-Servers, den PHP für Mails, die mit der <function>mail</function>-Funktion verschickt werden, nutzen soll. </para> </listitem> </varlistentry> <varlistentry id="ini.smtp-port"> <term> <parameter>smtp_port</parameter> <type>int</type> </term> <listitem> <para> Wird nur unter Windows benutzt: Nummer des Ports des Servers (angegeben in der <literal>SMTP</literal>-Option), um eine Verbindung herzustellen, wenn eine Mail mit der <function>mail</function>-Funktion verschickt wird. Standardwert ist 25. Diese Option ist verfügbar ab <literal>PHP</literal> 4.3.0. </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-from"> <term> <parameter>sendmail_from</parameter> <type>string</type> </term> <listitem> <para> "From:"-Mail-Adresse, die beim Mail-Versand unter Windows benutzt werden soll. </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-path"> <term> <parameter>sendmail_path</parameter> <type>string</type> </term> <listitem> <para> Pfad, in dem sich das <command>sendmail</command>-Programm befindet, z.B. <filename>/usr/sbin/sendmail</filename> oder <filename>/usr/lib/sendmail</filename>. <command>configure</command> versucht, die richtige Position automatisch zu finden. Falls die automatische Erkennung aber fehlschlägt und der Standardwert auf Ihrem Rechner falsch ist, dann können Sie hier den richtigen Pfad setzen. </para> <para> Falls Sie auf Ihrem Rechner sendmail nicht benutzen, müssen Sie den Pfad angeben, in sich der sendmail-Wrapper/-Ersatz befindet, sofern vorhanden. Zum Beispiel können <ulink url="&url.qmail;">Qmail</ulink>-Benutzer diese Option auf <filename>/var/qmail/bin/sendmail</filename> oder <filename>/var/qmail/bin/qmail-inject</filename> setzen. </para> <para> <command>qmail-inject</command> benötigt keine Optionen, um Mails korrekt zu verarbeiten. </para> </listitem> </varlistentry> </variablelist> </para> </section> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> Index: phpdoc-de/reference/mail/functions/ezmlm-hash.xml +++ phpdoc-de/reference/mail/functions/ezmlm-hash.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.9 Maintainer: wiesemann Status: ready --> <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> <refpurpose>Berechnet den Hash-Wert, der von EZMLM benötigt wird</refpurpose> </refnamediv> <refsect1> <title>Beschreibung</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> <methodparam><type>string</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> <function>ezmlm_hash</function> berechnet den Hash-Wert, der benötigt wird, wenn EZMLM-Mailinglisten in einer MySQL-Datenbank gespeichert werden. </simpara> <para> <example> <title>Hash-Wert berechnen und einen Benutzer hinzufügen</title> <programlisting> <![CDATA[ <?php $user = "joecool@example.com"; $hash = ezmlm_hash($user); $query = sprintf("INSERT INTO beispiel VALUES (%s, '%s')", $hash, $user); $db->query($query); // die PHPLIB-DB-Klasse wird benutzt ?> ]]> </programlisting> </example> </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->
« previous php.doc.de (#792) next »