cvs: phpdoc-el /reference/mail/functions ezmlm-hash.xml mail.xml
| From: | Dimitris Glezos | Date: | Mon, 21 Jul 2003 23:31:57 +0000 |
| Subject: | cvs: phpdoc-el /reference/mail/functions ezmlm-hash.xml mail.xml | ||
| Groups: | php.doc.el | ||
| Request: | Send a blank email to doc-el+get-27@lists.php.net to get a copy of this message | ||
subbie Mon Jul 21 19:31:57 2003 EDT
Added files:
/phpdoc-el/reference/mail/functions ezmlm-hash.xml mail.xml
Log:
added
Index: phpdoc-el/reference/mail/functions/ezmlm-hash.xml +++ phpdoc-el/reference/mail/functions/ezmlm-hash.xml <?xml version="1.0" encoding="iso-8859-7"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.9 Maintainer: legionnaire Status: ready --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.6 --> <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> <refpurpose>Õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé áðü ôï EZMLM</refpurpose> </refnamediv> <refsect1> <title>ÐåñéãñáöÞ</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> <methodparam><type>string</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> Ç <function>ezmlm_hash</function> õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé êáôÜ ôçí äéáôÞñçóç EZMLM mailing lists óå ìéá MySQL database. </simpara> <para> <example> <title>Õðïëïãßæïíôáò ôï hash êáé åããñÜöïíôáò Ýíá ÷ñÞóôç</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; $hash = ezmlm_hash ($user); $query = sprintf ("INSERT INTO sample VALUES (%s, '%s')", $hash, $user); $db->query($query); // using PHPLIB db interface ]]> </programlisting> </example> </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> Index: phpdoc-el/reference/mail/functions/mail.xml +++ phpdoc-el/reference/mail/functions/mail.xml <?xml version="1.0" encoding="iso-8859-7"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.17 Maintainer: legionnaire Status: ready --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> <refpurpose>ÁðïóôïëÞ mail</refpurpose> </refnamediv> <refsect1> <title>ÐåñéãñáöÞ</title> <methodsynopsis> <type>bool</type><methodname>mail</methodname> <methodparam><type>string</type><parameter>to</parameter></methodparam> <methodparam><type>string</type><parameter>subject</parameter></methodparam> <methodparam><type>string</type><parameter>message</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>additional_headers</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>additional_parameters</parameter></methodparam> </methodsynopsis> <simpara> Ç <function>mail</function> áõôïìÜôá óôÝëíåé ìå mail ôï ìÞíõìá üðùò ïñßæåôáé óôï <parameter>message</parameter> óôïí ðáñáëÞðôç üðùò ïñßæåôáé óôï <parameter>to</parameter>. Ðïëëáðëïß ðáñáëÞðôåò ìðïñïýí íá ïñéóôïýí ìå ôçí ðñïóèÞêç åíüò êüììáôïò áíÜìåóá óå êÜèå äéåýèõíóç óôï <parameter>to</parameter>. Email ìå óõííçìÝíá áñ÷åßá êáé åéäéêïýò ôýðïõò ðåñéå÷ïìÝíïõ ìðïñïýí íá áðïóôáëïýí ìå ôçí ÷ñÞóç áõôÞò ôçò óõíÜñôçóçò. Áõôü ðñáãìáôïðïéåßôáé ìÝóù MIME-êùäéêïðïßçóçò - ãéá ðåñéóóüôåñåò ðëçñïöïñßåò, äåßôå áõôü: <ulink url="&url.email.mime.zend;"> ôï Üñèñï Zend</ulink> Þ ôéò<ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> Ôá ðáñáêÜôù RFC's ìðïñïýí åðéóÞò íá âïçèÞóïõí: <ulink url="&url.rfc;1896">RFC 1896</ulink>, <ulink url="&url.rfc;2045">RFC 2045</ulink>, <ulink url="&url.rfc;2046">RFC 2046</ulink>, <ulink url="&url.rfc;2047">RFC 2047</ulink>, <ulink url="&url.rfc;2048">RFC 2048</ulink>, and <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> Ç <function>mail</function> åðéóôñÝöåé &true; åÜí ôï mail ðáñáäüèçêå åðéôõ÷þò, &false; óå áíôßèåôç ðåñßðôùóç. </para> <warning> <para> Ç åãêáôÜóôáóç óôá Windows ôçò <function>mail</function> äéáöÝñåé ðïéêéëïôñüðùò áðü ôçí áíôßóôïé÷ç óôï UNIX. Êáôáñ÷Þí, äåí ÷ñçóéìïðïéåß Ýíá ôïðéêü binary áñ÷åßï ãéá íá óõíèÝôåé ìçíýìáôá áëëÜ ìüíï åíåñãåß óå direct sockets ðïõ óçìáßíåé üôé Ýíá <literal>MTA</literal> áðáéôåßôáé ðïõ èá "áêïýåé" óå Ýíá network socket (ôï ïðïßï ìðïñåß íá åßíáé åßôå óôï localhost -ôïðéêÜ- åßôå óôï áðïìáêñõóìÝíï ìç÷Üíçìá). ¸ðåéôá, ôá custom headers üðùò <literal>From:</literal>, <literal>Cc:</literal>, <literal>Bcc:</literal> êáé <literal>Date:</literal> <emphasis role="strong">äåí</emphasis> åñìçíåýïíôáé áðü ôï <literal>MTA</literal> óôçí áñ÷Þ, áëëÜ áíáëýïíôáé áðü ôçí <literal>PHP</literal>. Ç <literal>PHP</literal> < 4.3 õðïóôÞñéæå ìüíï ôï óôïé÷åßï header <literal>Cc:</literal> (êáé Þôáí case-sensitive). Ç <literal>PHP</literal> >= 4.3 õðïóôçñßæåé üëá ôá ðñïáíáöåñèÝíôá óôïé÷åßá header êáé äåí åßíáé ðëÝïí case-sensitive. </para> </warning> <para> <example> <title>ÓôÝëíïíôáò mail.</title> <programlisting> <![CDATA[ <?php mail("joecool@example.com", "My Subject", "Line 1\nLine 2\nLine 3"); ?> ]]> </programlisting> </example> </para> <simpara> ÅÜí ðåñáóôåß Ýíá fourth string argument, áõôü ôï string åéóÜãåôáé óôï ôÝëïò ôïõ header. Áõôü ÷ñçóéìïðïéåßôáé êõñßùò ãéá íá ðñïóôåèïýí åðéðëÝïí headers. Ðïëëáðëïß åðéðëÝïí headers ÷ùñßæïíôáé ìå Ýíá return (enter) êáé ìéá íÝá ãñáììÞ. </simpara> <note> <para> ÐñÝðåé íá ÷ñçóéìïðïéåßôå ôï <literal>\r\n</literal> ãéá íá ÷ùñßæåôå ôá headers, áí êáé êÜðïéïé Unix mail transfer agents åíäÝ÷åôáé íá äïõëåýïõí ìüíï ìå ìéÜ íÝá ãñáììÞ (<literal>\n</literal>). </para> </note> <para> <example> <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers.</title> <programlisting> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}\r\n" ."Reply-To: webmaster@{$_SERVER['SERVER_NAME']}\r\n" ."X-Mailer: PHP/" . phpversion()); ?> ]]> </programlisting> </example> </para> <para> Ç ðáñÜìåôñïò <parameter>additional_parameters</parameter> ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ðåñáóôåß ìéá åðéðñüóèåôç ðáñÜìåôñïò óôï ðñüãñáììá, ôï ïðïßï Ý÷åé ñõèìéóôåß íá ÷ñçóéìïðïéåß üôáí óôÝëíåôáé mail ìå ÷ñÞóç ôçò <literal>sendmail_path</literal> ñýèìéóçò. Ãéá ðáñÜäåéãìá, áõôü ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ïñßóåé ôçí äéåýèõíóç ôïõ áðïóôïëÝá üôáí ãßíåôáé ÷ñÞóç ôïõ sendmail ìå ôçí åðéëïãÞ <literal>-f</literal>. ºóùò ÷ñåéáóôåß íá ðñïóèÝóåôå ôïí ÷ñÞóôç, ðïõ ï web server óáò ÷ñçóéìïðïéåß óýìöùíá ìå ôéò ñõèìßóåéò ôïõ sendmail, ãéá íá áðïôñÝøåôå íá ðñïóôåèåß óôï ìÞíõìá Ýíá 'X-Warning' header üôáí ïñßæåôå ôïí áðïóôïëÝá ìå áõôÞ ôç ìÝèïäï. <example> <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers êáé ïñßæïíôáò ìéá åðéðñüóèåôç command line ðáñÜìåôñï.</title> <programlisting> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}", "-fwebmaster@{$_SERVER['SERVER_NAME']}"); ?> ]]> </programlisting> </example> </para> <note> <para> ÁõôÞ ç ðÝìðôç ðáñÜìåôñïò ðñïóôÝèçêå óôçí PHP 4.0.5. Áðü ôçí PHP 4.2.3 áõôÞ ç ðáñÜìåôñïò åßíáé áðåíåñãïðïéçìÝíç óôï <link linkend="ini.safe-mode">safe_mode</link> êáé ç óõíÜñôçóç <function>mail</function> èá åìöáíßóåé Ýíá ìÞíõìá ðñïçäïðïéÞóçò êáé èá åðéóôñÝøåé &false; åÜí ðñïóðáèåßôå íá ôçí ÷ñçóéìïðïéÞóåôå. </para> </note> <para> Ìðïñåßôå åðßóçò íá ÷ñçóéìïðïéÞóåôå áðëÝò ôå÷íéêÝò string building ãéá íá äçìéïõñãÞóåôå ðïëýðëïêá ìçíýìáôá email. <example> <title>ÓôÝëíïíôáò ðïëýðëïêá email.</title> <programlisting> <![CDATA[ <?php /* recipients */ $to = "Mary <mary@example.com>" . ", " ; // note the comma $to .= "Kelly <kelly@example.com>"; /* subject */ $subject = "Birthday Reminders for August"; /* message */ $message = ' <html> <head> <title>Birthday Reminders for August</title> </head> <body> <p>Here are the birthdays upcoming in August!</p> <table> <tr> <th>Person</th><th>Day</th><th>Month</th><th>Year</th> </tr> <tr> <td>Joe</td><td>3rd</td><td>August</td><td>1970</td> </tr> <tr> <td>Sally</td><td>17th</td><td>August</td><td>1973</td> </tr> </table> </body> </html> '; /* To send HTML mail, you can set the Content-type header. */ $headers = "MIME-Version: 1.0\r\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; /* additional headers */ $headers .= "From: Birthday Reminder <birthday@example.com>\r\n"; $headers .= "Cc: birthdayarchive@example.com\r\n"; $headers .= "Bcc: birthdaycheck@example.com\r\n"; /* and now mail it */ mail($to, $subject, $message, $headers); ?> ]]> </programlisting> </example> </para> <note> <para> Öñïíôßóôå íá ìçí Ý÷åôå ôßðïôá newline ÷áñáêôÞñåò óôï <parameter>to</parameter> Þ <parameter>subject</parameter>, äéáöïñåôéêÜ ôï mail ßóùò íá ìçí óôáëåß óùóôÜ. </para> </note> <note> <para> Ç <parameter>to</parameter> ðáñÜìåôñïò äåí ìðïñåß íá åßíáé ìéá äéåýèõíóç ôçò ìïñöÞò "Something <someone@example.com>". Ç åíôïëÞ mail äåí èá ôï áíáëýóåé óùóôÜ êáôÜ ôçí åðéêïéíùíßá ìå ôï MTA. </para> </note> <para> Äåßôå åðßóçò <function>imap_mail</function>. </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->
Index: phpdoc-el/reference/mail/functions/ezmlm-hash.xml +++ phpdoc-el/reference/mail/functions/ezmlm-hash.xml <?xml version="1.0" encoding="iso-8859-7"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.9 Maintainer: legionnaire Status: ready --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.6 --> <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> <refpurpose>Õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé áðü ôï EZMLM</refpurpose> </refnamediv> <refsect1> <title>ÐåñéãñáöÞ</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> <methodparam><type>string</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> Ç <function>ezmlm_hash</function> õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé êáôÜ ôçí äéáôÞñçóç EZMLM mailing lists óå ìéá MySQL database. </simpara> <para> <example> <title>Õðïëïãßæïíôáò ôï hash êáé åããñÜöïíôáò Ýíá ÷ñÞóôç</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; $hash = ezmlm_hash ($user); $query = sprintf ("INSERT INTO sample VALUES (%s, '%s')", $hash, $user); $db->query($query); // using PHPLIB db interface ]]> </programlisting> </example> </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> Index: phpdoc-el/reference/mail/functions/mail.xml +++ phpdoc-el/reference/mail/functions/mail.xml <?xml version="1.0" encoding="iso-8859-7"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.17 Maintainer: legionnaire Status: ready --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> <refpurpose>ÁðïóôïëÞ mail</refpurpose> </refnamediv> <refsect1> <title>ÐåñéãñáöÞ</title> <methodsynopsis> <type>bool</type><methodname>mail</methodname> <methodparam><type>string</type><parameter>to</parameter></methodparam> <methodparam><type>string</type><parameter>subject</parameter></methodparam> <methodparam><type>string</type><parameter>message</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>additional_headers</parameter></methodparam> <methodparam choice="opt"><type>string</type><parameter>additional_parameters</parameter></methodparam> </methodsynopsis> <simpara> Ç <function>mail</function> áõôïìÜôá óôÝëíåé ìå mail ôï ìÞíõìá üðùò ïñßæåôáé óôï <parameter>message</parameter> óôïí ðáñáëÞðôç üðùò ïñßæåôáé óôï <parameter>to</parameter>. Ðïëëáðëïß ðáñáëÞðôåò ìðïñïýí íá ïñéóôïýí ìå ôçí ðñïóèÞêç åíüò êüììáôïò áíÜìåóá óå êÜèå äéåýèõíóç óôï <parameter>to</parameter>. Email ìå óõííçìÝíá áñ÷åßá êáé åéäéêïýò ôýðïõò ðåñéå÷ïìÝíïõ ìðïñïýí íá áðïóôáëïýí ìå ôçí ÷ñÞóç áõôÞò ôçò óõíÜñôçóçò. Áõôü ðñáãìáôïðïéåßôáé ìÝóù MIME-êùäéêïðïßçóçò - ãéá ðåñéóóüôåñåò ðëçñïöïñßåò, äåßôå áõôü: <ulink url="&url.email.mime.zend;"> ôï Üñèñï Zend</ulink> Þ ôéò<ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> Ôá ðáñáêÜôù RFC's ìðïñïýí åðéóÞò íá âïçèÞóïõí: <ulink url="&url.rfc;1896">RFC 1896</ulink>, <ulink url="&url.rfc;2045">RFC 2045</ulink>, <ulink url="&url.rfc;2046">RFC 2046</ulink>, <ulink url="&url.rfc;2047">RFC 2047</ulink>, <ulink url="&url.rfc;2048">RFC 2048</ulink>, and <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> Ç <function>mail</function> åðéóôñÝöåé &true; åÜí ôï mail ðáñáäüèçêå åðéôõ÷þò, &false; óå áíôßèåôç ðåñßðôùóç. </para> <warning> <para> Ç åãêáôÜóôáóç óôá Windows ôçò <function>mail</function> äéáöÝñåé ðïéêéëïôñüðùò áðü ôçí áíôßóôïé÷ç óôï UNIX. Êáôáñ÷Þí, äåí ÷ñçóéìïðïéåß Ýíá ôïðéêü binary áñ÷åßï ãéá íá óõíèÝôåé ìçíýìáôá áëëÜ ìüíï åíåñãåß óå direct sockets ðïõ óçìáßíåé üôé Ýíá <literal>MTA</literal> áðáéôåßôáé ðïõ èá "áêïýåé" óå Ýíá network socket (ôï ïðïßï ìðïñåß íá åßíáé åßôå óôï localhost -ôïðéêÜ- åßôå óôï áðïìáêñõóìÝíï ìç÷Üíçìá). ¸ðåéôá, ôá custom headers üðùò <literal>From:</literal>, <literal>Cc:</literal>, <literal>Bcc:</literal> êáé <literal>Date:</literal> <emphasis role="strong">äåí</emphasis> åñìçíåýïíôáé áðü ôï <literal>MTA</literal> óôçí áñ÷Þ, áëëÜ áíáëýïíôáé áðü ôçí <literal>PHP</literal>. Ç <literal>PHP</literal> < 4.3 õðïóôÞñéæå ìüíï ôï óôïé÷åßï header <literal>Cc:</literal> (êáé Þôáí case-sensitive). Ç <literal>PHP</literal> >= 4.3 õðïóôçñßæåé üëá ôá ðñïáíáöåñèÝíôá óôïé÷åßá header êáé äåí åßíáé ðëÝïí case-sensitive. </para> </warning> <para> <example> <title>ÓôÝëíïíôáò mail.</title> <programlisting> <![CDATA[ <?php mail("joecool@example.com", "My Subject", "Line 1\nLine 2\nLine 3"); ?> ]]> </programlisting> </example> </para> <simpara> ÅÜí ðåñáóôåß Ýíá fourth string argument, áõôü ôï string åéóÜãåôáé óôï ôÝëïò ôïõ header. Áõôü ÷ñçóéìïðïéåßôáé êõñßùò ãéá íá ðñïóôåèïýí åðéðëÝïí headers. Ðïëëáðëïß åðéðëÝïí headers ÷ùñßæïíôáé ìå Ýíá return (enter) êáé ìéá íÝá ãñáììÞ. </simpara> <note> <para> ÐñÝðåé íá ÷ñçóéìïðïéåßôå ôï <literal>\r\n</literal> ãéá íá ÷ùñßæåôå ôá headers, áí êáé êÜðïéïé Unix mail transfer agents åíäÝ÷åôáé íá äïõëåýïõí ìüíï ìå ìéÜ íÝá ãñáììÞ (<literal>\n</literal>). </para> </note> <para> <example> <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers.</title> <programlisting> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}\r\n" ."Reply-To: webmaster@{$_SERVER['SERVER_NAME']}\r\n" ."X-Mailer: PHP/" . phpversion()); ?> ]]> </programlisting> </example> </para> <para> Ç ðáñÜìåôñïò <parameter>additional_parameters</parameter> ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ðåñáóôåß ìéá åðéðñüóèåôç ðáñÜìåôñïò óôï ðñüãñáììá, ôï ïðïßï Ý÷åé ñõèìéóôåß íá ÷ñçóéìïðïéåß üôáí óôÝëíåôáé mail ìå ÷ñÞóç ôçò <literal>sendmail_path</literal> ñýèìéóçò. Ãéá ðáñÜäåéãìá, áõôü ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ïñßóåé ôçí äéåýèõíóç ôïõ áðïóôïëÝá üôáí ãßíåôáé ÷ñÞóç ôïõ sendmail ìå ôçí åðéëïãÞ <literal>-f</literal>. ºóùò ÷ñåéáóôåß íá ðñïóèÝóåôå ôïí ÷ñÞóôç, ðïõ ï web server óáò ÷ñçóéìïðïéåß óýìöùíá ìå ôéò ñõèìßóåéò ôïõ sendmail, ãéá íá áðïôñÝøåôå íá ðñïóôåèåß óôï ìÞíõìá Ýíá 'X-Warning' header üôáí ïñßæåôå ôïí áðïóôïëÝá ìå áõôÞ ôç ìÝèïäï. <example> <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers êáé ïñßæïíôáò ìéá åðéðñüóèåôç command line ðáñÜìåôñï.</title> <programlisting> <![CDATA[ <?php mail("nobody@example.com", "the subject", $message, "From: webmaster@{$_SERVER['SERVER_NAME']}", "-fwebmaster@{$_SERVER['SERVER_NAME']}"); ?> ]]> </programlisting> </example> </para> <note> <para> ÁõôÞ ç ðÝìðôç ðáñÜìåôñïò ðñïóôÝèçêå óôçí PHP 4.0.5. Áðü ôçí PHP 4.2.3 áõôÞ ç ðáñÜìåôñïò åßíáé áðåíåñãïðïéçìÝíç óôï <link linkend="ini.safe-mode">safe_mode</link> êáé ç óõíÜñôçóç <function>mail</function> èá åìöáíßóåé Ýíá ìÞíõìá ðñïçäïðïéÞóçò êáé èá åðéóôñÝøåé &false; åÜí ðñïóðáèåßôå íá ôçí ÷ñçóéìïðïéÞóåôå. </para> </note> <para> Ìðïñåßôå åðßóçò íá ÷ñçóéìïðïéÞóåôå áðëÝò ôå÷íéêÝò string building ãéá íá äçìéïõñãÞóåôå ðïëýðëïêá ìçíýìáôá email. <example> <title>ÓôÝëíïíôáò ðïëýðëïêá email.</title> <programlisting> <![CDATA[ <?php /* recipients */ $to = "Mary <mary@example.com>" . ", " ; // note the comma $to .= "Kelly <kelly@example.com>"; /* subject */ $subject = "Birthday Reminders for August"; /* message */ $message = ' <html> <head> <title>Birthday Reminders for August</title> </head> <body> <p>Here are the birthdays upcoming in August!</p> <table> <tr> <th>Person</th><th>Day</th><th>Month</th><th>Year</th> </tr> <tr> <td>Joe</td><td>3rd</td><td>August</td><td>1970</td> </tr> <tr> <td>Sally</td><td>17th</td><td>August</td><td>1973</td> </tr> </table> </body> </html> '; /* To send HTML mail, you can set the Content-type header. */ $headers = "MIME-Version: 1.0\r\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; /* additional headers */ $headers .= "From: Birthday Reminder <birthday@example.com>\r\n"; $headers .= "Cc: birthdayarchive@example.com\r\n"; $headers .= "Bcc: birthdaycheck@example.com\r\n"; /* and now mail it */ mail($to, $subject, $message, $headers); ?> ]]> </programlisting> </example> </para> <note> <para> Öñïíôßóôå íá ìçí Ý÷åôå ôßðïôá newline ÷áñáêôÞñåò óôï <parameter>to</parameter> Þ <parameter>subject</parameter>, äéáöïñåôéêÜ ôï mail ßóùò íá ìçí óôáëåß óùóôÜ. </para> </note> <note> <para> Ç <parameter>to</parameter> ðáñÜìåôñïò äåí ìðïñåß íá åßíáé ìéá äéåýèõíóç ôçò ìïñöÞò "Something <someone@example.com>". Ç åíôïëÞ mail äåí èá ôï áíáëýóåé óùóôÜ êáôÜ ôçí åðéêïéíùíßá ìå ôï MTA. </para> </note> <para> Äåßôå åðßóçò <function>imap_mail</function>. </para> </refsect1> </refentry> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->