cvs: phpdoc /fr/functions imap.xml mcal.xml strings.xml

From: Date: Thu, 01 Feb 2001 13:42:42 +0000
Subject: cvs: phpdoc /fr/functions imap.xml mcal.xml strings.xml
Groups: php.doc 
Request: Send a blank email to phpdoc+get-969334093@lists.php.net to get a copy of this message
dams Thu Feb 1 05:42:42 2001 EDT Modified files: /phpdoc/fr/functions strings.xml mcal.xml imap.xml Log: Notice some acronyms

Index: phpdoc/fr/functions/strings.xml diff -u phpdoc/fr/functions/strings.xml:1.21 phpdoc/fr/functions/strings.xml:1.22 --- phpdoc/fr/functions/strings.xml:1.21 Tue Jan 30 00:45:20 2001 +++ phpdoc/fr/functions/strings.xml Thu Feb 1 05:42:42 2001 @@ -1491,7 +1491,7 @@ 8-bit r&eacute;sultant du d&eacute;codage de la cha&icirc;ne <parameter>str</parameter>. <function>quoted_printable_decode</function> est similaire &agrave; <function>imap_qprint</function>, hormis le fait - qu'elle ne requiert pas le module IMAP. + qu'elle ne requiert pas le module <acronym>IMAP</acronym>. </simpara> </refsect1> </refentry> Index: phpdoc/fr/functions/mcal.xml diff -u phpdoc/fr/functions/mcal.xml:1.5 phpdoc/fr/functions/mcal.xml:1.6 --- phpdoc/fr/functions/mcal.xml:1.5 Tue Jan 30 00:45:20 2001 +++ phpdoc/fr/functions/mcal.xml Thu Feb 1 05:42:42 2001 @@ -8,7 +8,8 @@ <para> Libmcal est une librairie C de calendriers. Elle est &eacute;crite pour &ecirc;tre tr&egrave;s modulaire, et dispose de nombreux modules. - MCAL est l'&eacute;quivalent de IMAP pour les calendriers. + MCAL est l'&eacute;quivalent de <acronym>IMAP</acronym> pour les + calendriers. </para> <para> Avec mcal, un calendrier peut &ecirc;tre ouvert comme une bo&icirc;te Index: phpdoc/fr/functions/imap.xml diff -u phpdoc/fr/functions/imap.xml:1.6 phpdoc/fr/functions/imap.xml:1.7 --- phpdoc/fr/functions/imap.xml:1.6 Tue Jan 30 00:45:19 2001 +++ phpdoc/fr/functions/imap.xml Thu Feb 1 05:42:42 2001 @@ -23,14 +23,15 @@ <function>imap_open</function> pour plus d'informations. </simpara> <para> - Ce document ne peut entrer dans les d&eacute;tails de toutes les sujets abord&eacute;s. - Plus d'informations sont disponibles avec la documentation de la librairie - C (<filename>docs/internal.txt</filename>). ainsi que les RFC suivantes : + Ce document ne peut entrer dans les d&eacute;tails de toutes les sujets + abord&eacute;s. Plus d'informations sont disponibles avec la documentation + de la librairie C (<filename>docs/internal.txt</filename>). ainsi que + les RFC suivantes : <itemizedlist> <listitem> <simpara> <ulink url="&url.rfc;rfc821.html">RFC821</ulink>: Simple Mail - Transfer Protocol (SMTP). + Transfer Protocol (<acronym>SMTP</acronym>). </simpara> </listitem> <listitem> @@ -42,19 +43,19 @@ <listitem> <simpara> <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>: Internet - Message Access Protocol (IMAP) Version 4rev1. + Message Access Protocol (<acronym>IMAP</acronym>) Version 4rev1. </simpara> </listitem> <listitem> <simpara> <ulink url="&url.rfc;rfc1939.html">RFC1939</ulink>: Post - Office Protocol Version 3 (POP3). + Office Protocol Version 3 (<acronym>POP3</acronym>). </simpara> </listitem> <listitem> <simpara> <ulink url="&url.rfc;rfc977.html">RFC977</ulink>: Network News - Transfer Protocol (NNTP). + Transfer Protocol (<acronym>NNTP</acronym>). </simpara> </listitem> <listitem> @@ -85,7 +86,7 @@ <refnamediv> <refname>imap_append</refname> <refpurpose> - Ajoute une cha&icirc;ne dans une bo&icirc;te au lettre. + Ajoute une cha&icirc;ne dans une bo&icirc;te aux lettres. </refpurpose> </refnamediv> <refsect1> @@ -242,8 +243,9 @@ </listitem> <listitem> <simpara> - Driver - protocole utilis&eacute; pour acc&eacute;der &agrave; la bo&icirc;te aux lettres: - POP3, IMAP, NNTP + Driver - protocole utilis&eacute; pour acc&eacute;der &agrave; la + bo&icirc;te aux lettres: <acronym>POP3</acronym>, <acronym>IMAP</acronym>, + <acronym>NNTP</acronym>. </simpara> </listitem> <listitem> @@ -280,9 +282,10 @@ </funcprototype> </funcsynopsis> <para> - <function>imap_close</function> termine un flot IMAP. Prend un argument - optionnel <parameter>flag</parameter>, CL_EXPUNGE, qui va retirer - automatiquement de la liste la bo&icirc;te aux lettres. + <function>imap_close</function> termine un flot <acronym>IMAP</acronym>. + <function>imap_close</function> prend un argument optionnel + <parameter>flag</parameter>, CL_EXPUNGE, qui va retirer + automatiquement de la liste la bo&icirc;te aux lettres. </para> </refsect1> </refentry> @@ -838,7 +841,7 @@ <parameter>headers</parameter>, et retourne un objet contenant differents &eacute;l&eacute;ments, similaires &agrave; la fonction <function>imap_header</function>, hormis les flags, et autres - &eacute;l&eacute;ments li&eacute;s au serveur IMAP. + &eacute;l&eacute;ments li&eacute;s au serveur <acronym>IMAP</acronym>. </para> </refsect1> </refentry> @@ -948,15 +951,15 @@ </listitem> <listitem> <simpara> - LATT_UNMARKED - Cette bo&icirc;te aux lettres n'est pas marqu&eacute;e. Utilis&eacute; uniquement - avec UW-IMAPD. + LATT_UNMARKED - Cette bo&icirc;te aux lettres n'est pas + marqu&eacute;e. Utilis&eacute; uniquement avec UW-IMAPD. </simpara> </listitem> </itemizedlist> </para> <para> - <parameter>ref</parameter> ne devrait &ecirc;tre que le serveur IMAP sous - la forme <literal>{imap_server:imap_port}</literal>, et + <parameter>ref</parameter> ne devrait &ecirc;tre que le serveur <acronym>IMAP</acronym> + sous la forme <literal>{imap_server:imap_port}</literal>, et <parameter>pattern</parameter> sp&eacute;cifie la position dans la hi&eacute;rarchie des bo&icirc;tes aux lettres, o&uacute; il faut commencer &agrave; charcher. Si vous voulez passer en revue toute la @@ -1200,22 +1203,24 @@ </funcprototype> </funcsynopsis> <para> - <function>imap_open</function> retourne un flot IMAP en cas de succ&egrave;s, - et <literal>FALSE</literal> en cas d'erreur. <function>imap_open</function> peut aussi &ecirc;tre - utilis&eacute;e pour ouvrir des flots sur des serveurs POP3 et NNTP. + <function>imap_open</function> retourne un flot <acronym>IMAP</acronym> + en cas de succ&egrave;s, et <literal>FALSE</literal> en cas d'erreur. + <function>imap_open</function> peut aussi &ecirc;tre utilis&eacute;e pour + ouvrir des flots sur des serveurs <acronym>POP3</acronym> et <acronym>NNTP</acronym>. + </para> + <para> + Un nom de bo&icirc;te aux lettres est constitu&eacute; d'une adresse de serveur, + et d'une adresse de bo&icirc;te sur ce serveur. Le mot reserv&eacute; INBOX + repr&eacute;sente la bo&icirc;te aux lettres de l'utilisateur courant. + L'adresse du serveur, mise entre accolades '{' et '}', est constitu&eacute; + du nom du serveur ou de son adresse IP, d'une sp&eacute;cification de protocole + (commencant par '/') et d'un port optionnel (sp&eacute;cifi&eacute; avec ':'). + Cette partie est obligatoire dans les param&egrave;tres de la bo&icirc;te aux + lettres. Les noms de bo&icirc;tes aux lettres qui contiennent des caract&egrave;res + sp&eacute;ciaux (en dehors de l'espace ASCII) doivent &ecirc;tre encod&eacute;s + avec <function>imap_utf7_encode</function>. </para> <para> - Un nom de bo&icirc;te aux lettre est constitu&eacute; d'une adresse de serveur, - et d'une adresse de bo&icirc;te sur ce serveur. Le mot reserv&eacute; INBOX repr&eacute;sente - la bo&icirc;te aux lettres de l'utilisateur courant. L'adresse du serveur, - mise entre accolades '{' et '}', est constitu&eacute; du nom du serveur ou de - son adresse IP, d'une sp&eacute;cification de protocole (commencant par '/') - et d'un port optionnel (sp&eacute;cifi&eacute; avec ':'). Cette partie est obligatoire - dans les param&egrave;tres de la bo&icirc;te aux lettres. Les noms de bo&icirc;tes aux lettres - qui contiennent des caract&egrave;res sp&eacute;ciaux (en dehors de l'espace ASCII) doivent - &ecirc;tre encod&eacute;s avec <function>imap_utf7_encode</function>. - </para> - <para> Les options sont un masque de bit, qui peut prendre une ou plusieurs des valeurs suivantes : <itemizedlist> @@ -1231,8 +1236,8 @@ </listitem> <listitem> <simpara> - OP_HALFOPEN - Pour les noms IMAP et NNTP, ouvre une connexion - mais n'ouvre pas une bo&icirc;te aux lettre. + OP_HALFOPEN - Pour les noms <acronym>IMAP</acronym> et <acronym>NNTP</acronym>, + ouvre une connexion mais n'ouvre pas une bo&icirc;te aux lettres. </simpara> </listitem> <listitem> @@ -1244,7 +1249,7 @@ </itemizedlist> </para> <para> - Pour se connecter &agrave; un serveur IMAP, on peut utiliser la + Pour se connecter &agrave; un serveur <acronym>IMAP</acronym>, on peut utiliser la commande suivante : <informalexample> <programlisting role="php"> @@ -1253,8 +1258,8 @@ ?&gt; </programlisting> </informalexample> - Pour se connecter &agrave; un serveur POP3 qui fonctionne sur le port 110 - de la machine locale on peut utiliser la commande suivante : + Pour se connecter &agrave; un serveur <acronym>POP3</acronym> qui fonctionne sur + le port 110 de la machine locale on peut utiliser la commande suivante : <informalexample> <programlisting role="php"> &lt;?php @@ -1262,8 +1267,8 @@ ?&gt; </programlisting> </informalexample> - Pour se connecter &agrave; un serveur NNTP qui fonctionne sur le port 119 - de la machine locale on peut utiliser la commande: + Pour se connecter &agrave; un serveur<acronym>NNTP</acronym> qui fonctionne sur + le port 119 de la machine locale on peut utiliser la commande: <informalexample> <programlisting role="php"> &lt;?php @@ -1293,11 +1298,13 @@ Retourne <literal>TRUE</literal> si le flot existe toujours, et <literal>FALSE</literal> sinon. </para> <para> - <function>imap_ping</function> v&eacute;rifie que le flot IMAP est toujours actif, - en lui envoyant un ping. Cette fonction permet de se rendre compte que du mail - est arriv&eacute; : c'est m&ecirc;me la m&eacute;thode pr&eacute;conis&eacute;e pour des tests p&eacute;riodiques de - v&eacute;rification du courrier. Cette fonction peut aussi servir &agrave; garder une connexion - ouverte, avec les serveurs dot&eacute;s d'un d&eacute;lai d'&eacute;xpiration. + <function>imap_ping</function> v&eacute;rifie que le flot <acronym>IMAP</acronym> + est toujours actif, en lui envoyant un ping. Cette fonction permet de se rendre + compte que du mail est arriv&eacute; : c'est m&ecirc;me la m&eacute;thode + pr&eacute;conis&eacute;e pour des tests p&eacute;riodiques de + v&eacute;rification du courrier. Cette fonction peut aussi servir + &agrave; garder une connexion ouverte, avec les serveurs dot&eacute;s + d'un d&eacute;lai d'&eacute;xpiration. </para> <para> <example> @@ -1379,7 +1386,8 @@ </funcsynopsis> <para> <function>imap_reopen</function> r&eacute;ouvre la connexion sp&eacute;cifi&eacute;e - au serveur IMAP ou NNTP, avec une nouvelle bo&icirc;tes aux lettres. + au serveur <acronym>IMAP</acronym> ou <acronym>NNTP</acronym>, + avec une nouvelle bo&icirc;tes aux lettres. </para> <para> Les options sont des masques de bit, qui peuvent contenir les valeurs suivantes : @@ -1396,8 +1404,8 @@ </listitem> <listitem> <simpara> - OP_HALFOPEN - Pour les noms IMAP et NNTP, ouvre une connexion - mais n'ouvre pas une bo&icirc;te aux lettre. + OP_HALFOPEN - Pour les noms <acronym>IMAP</acronym> et <acronym>NNTP</acronym>, + ouvre une connexion mais n'ouvre pas une bo&icirc;te aux lettres. </simpara> </listitem> <listitem> @@ -1426,10 +1434,12 @@ </funcprototype> </funcsynopsis> <para> - Souscrit &agrave; la bo&icirc;te aux lettres <parameter>mbox</parameter>. + <function>imap_subscribe</function> souscrit &agrave; la bo&icirc;te aux + lettres <parameter>mbox</parameter>. </para> <para> - Retourne <literal>TRUE</literal> en cas de succ&egrave;s, et <literal>FALSE</literal> en cas d'&eacute;chec. + <function>imap_subscribe</function> retourne <literal>TRUE</literal> en cas de + succ&egrave;s, et <literal>FALSE</literal> en cas d'&eacute;chec. </para> </refsect1> </refentry> @@ -1455,7 +1465,8 @@ <function>imap_delete</function>. </para> <para> - Retourne <literal>TRUE</literal> en cas de succ&egrave;s, et <literal>FALSE</literal> en cas d'erreur. + <function>imap_subscribe</function> retourne <literal>TRUE</literal> en cas + de succ&egrave;s, et <literal>FALSE</literal> en cas d'erreur. </para> </refsect1> </refentry> @@ -1476,11 +1487,12 @@ </funcprototype> </funcsynopsis> <para> - <function>imap_unsubscribe</function> termine la souscription &agrave; - la bo&icirc;te aux lettres <parameter>mbox</parameter>. + <function>imap_unsubscribe</function> termine la souscription &agrave; + la bo&icirc;te aux lettres <parameter>mbox</parameter>. </para> <para> - Retourne <literal>TRUE</literal> en cas de succ&egrave;s, et <literal>FALSE</literal> en cas d'erreur. + <function>imap_unsubscribe</function> retourne <literal>TRUE</literal> + en cas de succ&egrave;s, et <literal>FALSE</literal> en cas d'erreur. </para> </refsect1> </refentry> @@ -1712,7 +1724,7 @@ <para> <parameter>mailbox</parameter> retourne une adresse email proprement format&eacute;e, &agrave; partir du nom de la bo&icirc;te aux - lettre de l'h&ocirc;te <parameter>host</parameter>, et + lettres de l'h&ocirc;te <parameter>host</parameter>, et des informations personnelles <parameter>personal</parameter>. </para> <para> @@ -1957,9 +1969,9 @@ c'est &agrave; dire sans canonisation des CRLF FT_PREFETCHTEXT RFC822.TEXT doit &ecirc;tre pr&eacute; t&eacute;l&eacute;charg&eacute; en m&ecirc;me temps que l'ent&ecirc;te. - Cela r&eacute;duit le RTT sur une connexion IMAP, si le message complet - est souhait&eacute;. (e.g. dans une op&eacute;ration de sauvegarde dans - un fichier). + Cela r&eacute;duit le RTT sur une connexion <acronym>IMAP</acronym>, si + le message complet est souhait&eacute;. (e.g. dans une op&eacute;ration + de sauvegarde dans un fichier). </literallayout> </informalexample> </para> @@ -2033,10 +2045,10 @@ </funcsynopsis> <para> <function>imap_search</function> effectue une recherche dans la bo&icirc;te aux - lettres courantes, sur le flot IMAP courant. <parameter>criteria</parameter> - est une cha&icirc;ne, d&eacute;limit&eacute;e par des espaces, dans laquelle - les mots-cl&eacute;s suivants sont accept&eacute;s. Tous les arguments - multi-mots doivent &ecirc;tre entre guillemets : + lettres courantes, sur le flot <acronym>IMAP</acronym> courant. + <parameter>criteria</parameter> est une cha&icirc;ne, d&eacute;limit&eacute;e + par des espaces, dans laquelle les mots-cl&eacute;s suivants sont accept&eacute;s. + Tous les arguments multi-mots doivent &ecirc;tre entre guillemets : <itemizedlist> <listitem> <simpara> @@ -2196,10 +2208,10 @@ </funcsynopsis> <para> <function>imap_last_error</function> retourne le texte complet de la - derni&egrave;re erreur IMAP (si elle existe) qui est survenu lors de - la derni&egrave;re requ&ecirc;te. La pile d'erreur n'est pas touch&eacute;e. - Appeler <function>imap_last_error</function> successivement dans nouvelles - erreurs retournera la m&ecirc;me erreur. + derni&egrave;re erreur <acronym>IMAP</acronym> (si elle existe) qui + est survenu lors de la derni&egrave;re requ&ecirc;te. La pile d'erreur + n'est pas touch&eacute;e. Appeler <function>imap_last_error</function> + successivement dans nouvelles erreurs retournera la m&ecirc;me erreur. </para> </refsect1> </refentry> @@ -2219,11 +2231,11 @@ </funcprototype> </funcsynopsis> <para> - <function>imap_errors</function> retourne tous les messages d'erreurs IMAP - g&eacute;n&eacute;r&eacute;s depuis le dernier appel &agrave; - <function>imap_errors</function>, ou depuis le d&eacute;but de la page. - Lorsque <function>imap_errors</function> est appel&eacute;s, la pile - d'erreur est vid&eacute;e. + <function>imap_errors</function> retourne tous les messages d'erreurs + <acronym>IMAP</acronym> g&eacute;n&eacute;r&eacute;s depuis le dernier + appel &agrave; <function>imap_errors</function>, ou depuis le + d&eacute;but de la page. Lorsque <function>imap_errors</function> est + appel&eacute;s, la pile d'erreur est vid&eacute;e. </para> </refsect1> </refentry> @@ -2244,10 +2256,10 @@ </funcsynopsis> <para> <function>imap_alerts</function> retourne tous les messages d'alerte - IMAP g&eacute;n&eacute;r&eacute;s depuis le dernier appel &agrave; - <function>imap_alerts</function> ou depuis le d&eacute;but de la page. - Lorsque <function>imap_alerts</function> est appel&eacute;, la pile - d'alerte est vid&eacute;e. + <acronym>IMAP</acronym> g&eacute;n&eacute;r&eacute;s depuis le dernier + appel &agrave; <function>imap_alerts</function> ou depuis le d&eacute;but + de la page. Lorsque <function>imap_alerts</function> est appel&eacute;, la + pile d'alertes est vid&eacute;e. </para> </refsect1> </refentry>
« previous php.doc (#969334093) next »