cvs: phpdoc /he/functions mail.xml
| From: | matty rozen | Date: | Mon, 08 Apr 2002 20:15:43 +0000 |
| Subject: | cvs: phpdoc /he/functions mail.xml | ||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969344158@lists.php.net to get a copy of this message | ||
matroz Mon Apr 8 16:15:43 2002 EDT
Modified files:
/phpdoc/he/functions mail.xml
Log:
finished translating,using zvi ble translation
Index: phpdoc/he/functions/mail.xml diff -u phpdoc/he/functions/mail.xml:1.1 phpdoc/he/functions/mail.xml:1.2 --- phpdoc/he/functions/mail.xml:1.1 Tue Mar 26 03:38:06 2002 +++ phpdoc/he/functions/mail.xml Mon Apr 8 16:15:43 2002 @@ -1,59 +1,60 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- EN-Revision: 1.37 Maintainer: matroz Status: working --> +<!-- EN-Revision: 1.37 Maintainer: matroz Status: done --> <reference id="ref.mail"> - <title>ôåð÷öéåú ãåàø</title> - <titleabbrev>Mail</titleabbrev> + <title>ôåð÷öééú äãåàø</title> + <titleabbrev>ãåàø</titleabbrev> <partintro> <simpara> - äôåð÷öéä <function>mail</function> îàôùøú ùìéçú ãåàø + îàôùøú ìê ìùìåç ãåàø <function>ãåàø</function>ôåð÷öééú ä </simpara> <variablelist> - <title>äðçéåú ÷åðôéâåøöéú ãåàø</title> + <title>îðçé úöåøú äãåàø</title> <varlistentry id="ini.smtp"> <term> <parameter>SMTP</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - DNS name or IP address of the SMTP server PHP under Windows - should use for mail sent with the <function>mail</function> - function.</para> + ùí DNS àå ëúåáú IP ùì ùøú ä-SMPT áùôú PHP úçú ååéðãåñ éëåì + .<function>ãåàø</function>ìùîù ìùìéçú ãåàø áòæøú ôåð÷öééú ä + </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-from"> <term> <parameter>sendmail_from</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - Which "From:" mail address should be used in mail sent from - PHP under Windows.</para> + ëùäôøîèø "From:" öøéê ìäéåú ëúåáú ãåàø ú÷éðä ùéëåìä ìäéåú áùéîåù + áùìéçú ãåàø î-PHP úçú ååéðãåñ. + </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-path"> <term> <parameter>sendmail_path</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - Where the <command>sendmail</command> program can be found, - usually <filename>/usr/sbin/sendmail</filename> or + ëùäôøîèø <command>sendmail</command> äåà úåëðä ùéëåìä ìäîöà + ìøåá á-<filename>/usr/sbin/sendmail</filename> àå <filename>/usr/lib/sendmail</filename> - <command>configure</command> does an honest attempt of - locating this one for you and set a default, but if it fails, - you can set it here.</para> + òåùä ðñéåï àîéúé ùì + çéôåù úåëðä æå å÷åáòú áøéøú îçãì, àáì àí äéà ìà îöìéçä + àúä éëåì ì÷áåò æàú ëàï. </para> <para> - Systems not using sendmail should set this directive to the - sendmail wrapper/replacement their mail system offers, if any. - For example, <ulink url="&url.qmail;">Qmail</ulink> - users can normally set it to + îòøëåú ùìà îùúîùåú áôåð÷öééú ä-sendmail éëåìåú ì÷áåò äðçééä æàú + ìîòøëú äãåàø äçìåôéú ùäîòøëú ùìäí îöéòä, àí éùðä. + ìãåâîä, îùúîùé <ulink url="&url.qmail;">Qmail</ulink> + éëåìéí áãøê ëìì ì÷áåò ôøîèø æä ì- <filename>/var/qmail/bin/sendmail</filename>.</para> </listitem> </varlistentry> @@ -62,48 +63,47 @@ <refentry id="function.mail"> <refnamediv> - <refname>mail</refname> - <refpurpose>send mail</refpurpose> + <refname>ãåàø</refname> + <refpurpose>ùìç ãåàø</refpurpose> </refnamediv> <refsect1> - <title>Description</title> + <title>úéàåø</title> <methodsynopsis> - <type>bool</type><methodname>mail</methodname> - <methodparam><type>string</type><parameter>to</parameter></methodparam> - <methodparam><type>string</type><parameter>subject</parameter></methodparam> - <methodparam><type>string</type><parameter>message</parameter></methodparam> - <methodparam choice="opt"><type>string</type><parameter>additional_headers</parameter></methodparam> - <methodparam choice="opt"><type>string</type><parameter>additional_parameters + <type>ôåð÷öééä áåìéàðéú</type><methodname>ãåàø</methodname> + <methodparam><type>îçøåæú</type><parameter>äðîòï</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>äðåùà</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>ääåãòä</parameter></methodparam> + <methodparam choice="opt"><type>îçøåæú</type><parameter>additional_headers</parameter></methodparam> + <methodparam choice="opt"><type>îçøåæú</type><parameter>additional_parameters </parameter></methodparam> </methodsynopsis> <simpara> - <function>mail</function> automatically mails the message - specified in <parameter>message</parameter> to the receiver - specified in <parameter>to</parameter>. Multiple recipients can - be specified by putting a comma between each address in - <parameter>to</parameter>. Email with attachments and special - types of content can be sent using this function. This is - accomplished via MIME-encoding - for more information, see this - <ulink url="&url.email.mime.zend;"> - Zend article</ulink> or the <ulink url="&url.email.mime.pear;"> + <function>ãåàø</function> ùåìçú áàåôï àåèåîèé àú ääåãòä + äîúåàøú á-<parameter>message</parameter> ìðîòï äîúåàø + á-<parameter>to</parameter>. ùìéçä ìäøáä ðîòðéí éëåìä ìäúáöò + òì éãé ëúéáú ôñé÷ áéï ëì ëúåáú áôøîèø <parameter>to</parameter>. + ãåàì òí ÷åáöéí îöåøôéí (attachments) åòí ñåâéí îéåçãéí ùì úåëï + éëåìéí ìäùìç òí äôåð÷öéä äæàú. úäìéê æä îåùìí ãøê ä- MIME-encoding + - ú÷ï äîàôùø ìäòáéø áãåàì ëì ñåâ ÷åáõ. ìòåã îéãò, òééï á<ulink url="&url.email.mime.zend;"> + îàîø î-Zend àå á- + <ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> - The following RFC's may also be useful: + ä÷éùåøéí äáàéí ì-RFC éëåìéí ìäéåú âí ëï ùéîåùééí: <ulink url="&url.rfc1896;">RFC 1896</ulink>, <ulink url="&url.rfc2045;">RFC 2045</ulink>, <ulink url="&url.rfc2046;">RFC 2046</ulink>, <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and + <ulink url="&url.rfc2048;">RFC 2048</ulink>, å <ulink url="&url.rfc2049;">RFC 2049</ulink>. </simpara> <para> - <function>mail</function> returns &true; if the mail - is successfully sent, &false; otherwise. + <function>ãåàø</function> îçæéøä &true; àí äãåàø ðùìç áäöìçä, å-&false; àçøú. </para> <para> <example> - <title>Sending mail.</title> + <title>ùìéçú ãåàø</title> <programlisting> <![CDATA[ mail("joecool@example.com", "My Subject", "Line 1\nLine 2\nLine 3"); @@ -111,23 +111,23 @@ </programlisting> </example></para> <simpara> - If a fourth string argument is passed, this string is inserted at - the end of the header. This is typically used to add extra - headers. Multiple extra headers are separated with a carriage return - and newline. + àí îùúðä øáéòé îñåâ îçøåæú ðùìç áðåñó, îçøåæú æå îåëðñú áñåó + äëåúøú (header). äùéîåù áîùúðä æä äåà ìøåá áùáéì ìäåñéó òåã + ëåúøåú (headers). áëãé ìäåñéó ëîä ëåúøåú, éù ìäôøéãí áòæøú äçæøú + äñîï ìäúçìú äùåøä (/r) åùåøä çãùä (/n). </simpara> <note> <para> - You must use <literal>\r\n</literal> to seperate headers, although - some Unix mail transfer agents may work with just a single newline - (<literal>\n</literal>). The Cc: header is case sensitive and must - be written as <literal>Cc:</literal> on Win32 systems. The Bcc: - header is also not supported on Win32 systems. + àúä çééá ìäùúîù áúååéí <literal>\r\n</literal> ëãé ìäôøéã ëåúøåú, ìîøåú + ùñåëðé äòáøú ãåàø îñåééîéí ùì Unix éëåìéí ìòáåã ø÷ òí ùåøä + çãùä (<literal>\n</literal>). äëåúøú Cc: äéà øâéùä ìäáãì áéï àåúéåú ÷èðåú + ìâãåìåú (-áàðâìéú) åçééá ìäëúá áîòøëåú Win32 ëê: <literal>Cc:</literal>. + äëåúøú Bcc: àéðä ðúîëú áîòøëåú Win32. </para> </note> <para> <example> - <title>Sending mail with extra headers.</title> + <title>ùìéçú ãåàø òí ëåúøåú ðåñôåú.</title> <programlisting> <![CDATA[ mail("nobody@example.com", "the subject", $message, @@ -139,16 +139,15 @@ </example> </para> <para> - The <parameter>additional_parameters</parameter> parameter - can be used to pass additional parameters to the program configured - to use when sending mail using the <literal>sendmail_path</literal> - configuration setting. For example, this can be used to set the - envelope sender address when using sendmail. You may need to add - the user that your web server runs as to your sendmail configuration - to prevent a 'X-Warning' header from being added to the message when - you set the envelope sender using this method. + äôøîèøéí äðåñôéí (<parameter>additional_parameters</parameter>) éëåìéí + ìùîù ìäòáøú ôøîèøéí ðåñôéí ìúåëðä äîåâãøú ìùéîåù ëùùåìçéí ãåàø + áòæøú äúåëðä äîåâãøú áúé÷éä <literal>sendmail_path</literal>. ìãåâîä, + àôùø ìäùúîù áàôùøåú æå áùáéì ì÷áåò àú îòèôú ëúåáú äùåìç ëùîùúîùéí + áúåëðä Sendmail. àúä úäéä öøéê ìäåñéó àú äîùúîù ùùøú äàéðèøðè îôòéì + áäâãøåú äúåëðä Sendmail áùáéì ìîðåò àú äåñôú äëåúøú 'X-Warning' + ìäåãòä ùìê, ëùàúä ÷åáò àú îòèôú ëúåáú òí äùéèä äæàú. <example> - <title>Sending mail with extra headers and setting an additional command line parameter.</title> + <title>ùìéçú ãåàø òí úåøåú ðåñôåú å÷áéòú ô÷åãä ðåñôú ëôøîèø.</title> <programlisting> <![CDATA[ mail("nobody@example.com", "the subject", $message, @@ -159,19 +158,19 @@ </para> <note> <para> - This fifth parameter was added in PHP 4.0.5. + äôøîèø äçîéùé äåñó áâéøñä PHP 4.0.5. </para> </note> <para> - You can also use simple string building techniques to build complex - email messages. + àúä éëåì âí ëï ìäùúîù áèëðé÷åú ôùåèåú ùì áðééú îçøåæåú ëãé ìáðåú + äåãòåú ãåàì îåøëáåú. <example> - <title>Sending complex email.</title> + <title>ùìéçú äåãòåú îåøëáåú.</title> <programlisting> <![CDATA[ /* recipients */ -$to = "Mary <mary@example.com>" . ", " ; //note the comma -$to .= "Kelly <kelly@example.com>"; +$to = "Moshe <moshe@example.com>" . ", " ; //àì úùëç àú äôñé÷! +$to .= "David <david@example.com>"; /* subject */ $subject = "Birthday Reminders for August"; @@ -197,17 +196,17 @@ </html> '; -/* To send HTML mail, you can set the Content-type header. */ +/* áëãé ìùìåç ãåàø îñåâ HTML, àú éëåì ì÷áåò àú ëåúøåú ñåâ äúåëï (Content-type).*/ $headers = "MIME-Version: 1.0\r\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; -/* additional headers */ +/* ëåúøåú ðåñôåú */ $headers .= "From: Birthday Reminder <birthday@example.com>\r\n"; $headers .= "Cc: birthdayarchive@example.com\r\n"; $headers .= "Bcc: birthdaycheck@example.com\r\n"; -/* and now mail it */ +/* åòëùéå - ùìç àú æä! */ mail($to, $subject, $message, $headers); ]]> </programlisting> @@ -215,9 +214,8 @@ </para> <note> <para> - Make sure you do not have any newline characters in the - <parameter>to</parameter> or <parameter>subject</parameter>, - or the mail may not be sent properly. + ååãà àú æä ùàéï ìê ùåí úå ùì ùåøä çãùä áôøîèø <parameter>to</parameter> àå + áôøîèø <parameter>subject</parameter>, àçøú äãåàø ìà éùìç äéèá. </para> </note> </refsect1> @@ -226,27 +224,27 @@ <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> - <refpurpose>Calculate the hash value needed by EZMLM</refpurpose> + <refpurpose>çùá àú òøê ä-hash äãøåù òì éãé EZMLM</refpurpose> </refnamediv> <refsect1> - <title>Description</title> + <title>úéàåø</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> - <methodparam><type>string</type><parameter>addr</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> - <function>ezmlm_hash</function> calculates the hash value needed - when keeping EZMLM mailing lists in a MySQL database. + äôåð÷öéä <function>ezmlm_hash</function> îçùáú àú òøê ä-hash äãøåù ëùùåîøéí øùéîåú + ãåàø EZMLM áîàâø ðúåðéí îñåâ MySql. </simpara> <para> <example> - <title>Calculating the hash and subscribing a user</title> + <title>çéùåá ä-hash åøéùåí îùúîù</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; $hash = ezmlm_hash ($user); $query = sprintf ("INSERT INTO sample VALUES (%s, '%s')", $hash, $user); -$db->query($query); // using PHPLIB db interface +$db->query($query); // PHPLIB db ùéîåù áîîù÷ ]]> </programlisting> </example>
Index: phpdoc/he/functions/mail.xml diff -u phpdoc/he/functions/mail.xml:1.1 phpdoc/he/functions/mail.xml:1.2 --- phpdoc/he/functions/mail.xml:1.1 Tue Mar 26 03:38:06 2002 +++ phpdoc/he/functions/mail.xml Mon Apr 8 16:15:43 2002 @@ -1,59 +1,60 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- EN-Revision: 1.37 Maintainer: matroz Status: working --> +<!-- EN-Revision: 1.37 Maintainer: matroz Status: done --> <reference id="ref.mail"> - <title>ôåð÷öéåú ãåàø</title> - <titleabbrev>Mail</titleabbrev> + <title>ôåð÷öééú äãåàø</title> + <titleabbrev>ãåàø</titleabbrev> <partintro> <simpara> - äôåð÷öéä <function>mail</function> îàôùøú ùìéçú ãåàø + îàôùøú ìê ìùìåç ãåàø <function>ãåàø</function>ôåð÷öééú ä </simpara> <variablelist> - <title>äðçéåú ÷åðôéâåøöéú ãåàø</title> + <title>îðçé úöåøú äãåàø</title> <varlistentry id="ini.smtp"> <term> <parameter>SMTP</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - DNS name or IP address of the SMTP server PHP under Windows - should use for mail sent with the <function>mail</function> - function.</para> + ùí DNS àå ëúåáú IP ùì ùøú ä-SMPT áùôú PHP úçú ååéðãåñ éëåì + .<function>ãåàø</function>ìùîù ìùìéçú ãåàø áòæøú ôåð÷öééú ä + </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-from"> <term> <parameter>sendmail_from</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - Which "From:" mail address should be used in mail sent from - PHP under Windows.</para> + ëùäôøîèø "From:" öøéê ìäéåú ëúåáú ãåàø ú÷éðä ùéëåìä ìäéåú áùéîåù + áùìéçú ãåàø î-PHP úçú ååéðãåñ. + </para> </listitem> </varlistentry> <varlistentry id="ini.sendmail-path"> <term> <parameter>sendmail_path</parameter> - <type>string</type> + <type>îçøåæú</type> </term> <listitem> <para> - Where the <command>sendmail</command> program can be found, - usually <filename>/usr/sbin/sendmail</filename> or + ëùäôøîèø <command>sendmail</command> äåà úåëðä ùéëåìä ìäîöà + ìøåá á-<filename>/usr/sbin/sendmail</filename> àå <filename>/usr/lib/sendmail</filename> - <command>configure</command> does an honest attempt of - locating this one for you and set a default, but if it fails, - you can set it here.</para> + òåùä ðñéåï àîéúé ùì + çéôåù úåëðä æå å÷åáòú áøéøú îçãì, àáì àí äéà ìà îöìéçä + àúä éëåì ì÷áåò æàú ëàï. </para> <para> - Systems not using sendmail should set this directive to the - sendmail wrapper/replacement their mail system offers, if any. - For example, <ulink url="&url.qmail;">Qmail</ulink> - users can normally set it to + îòøëåú ùìà îùúîùåú áôåð÷öééú ä-sendmail éëåìåú ì÷áåò äðçééä æàú + ìîòøëú äãåàø äçìåôéú ùäîòøëú ùìäí îöéòä, àí éùðä. + ìãåâîä, îùúîùé <ulink url="&url.qmail;">Qmail</ulink> + éëåìéí áãøê ëìì ì÷áåò ôøîèø æä ì- <filename>/var/qmail/bin/sendmail</filename>.</para> </listitem> </varlistentry> @@ -62,48 +63,47 @@ <refentry id="function.mail"> <refnamediv> - <refname>mail</refname> - <refpurpose>send mail</refpurpose> + <refname>ãåàø</refname> + <refpurpose>ùìç ãåàø</refpurpose> </refnamediv> <refsect1> - <title>Description</title> + <title>úéàåø</title> <methodsynopsis> - <type>bool</type><methodname>mail</methodname> - <methodparam><type>string</type><parameter>to</parameter></methodparam> - <methodparam><type>string</type><parameter>subject</parameter></methodparam> - <methodparam><type>string</type><parameter>message</parameter></methodparam> - <methodparam choice="opt"><type>string</type><parameter>additional_headers</parameter></methodparam> - <methodparam choice="opt"><type>string</type><parameter>additional_parameters + <type>ôåð÷öééä áåìéàðéú</type><methodname>ãåàø</methodname> + <methodparam><type>îçøåæú</type><parameter>äðîòï</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>äðåùà</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>ääåãòä</parameter></methodparam> + <methodparam choice="opt"><type>îçøåæú</type><parameter>additional_headers</parameter></methodparam> + <methodparam choice="opt"><type>îçøåæú</type><parameter>additional_parameters </parameter></methodparam> </methodsynopsis> <simpara> - <function>mail</function> automatically mails the message - specified in <parameter>message</parameter> to the receiver - specified in <parameter>to</parameter>. Multiple recipients can - be specified by putting a comma between each address in - <parameter>to</parameter>. Email with attachments and special - types of content can be sent using this function. This is - accomplished via MIME-encoding - for more information, see this - <ulink url="&url.email.mime.zend;"> - Zend article</ulink> or the <ulink url="&url.email.mime.pear;"> + <function>ãåàø</function> ùåìçú áàåôï àåèåîèé àú ääåãòä + äîúåàøú á-<parameter>message</parameter> ìðîòï äîúåàø + á-<parameter>to</parameter>. ùìéçä ìäøáä ðîòðéí éëåìä ìäúáöò + òì éãé ëúéáú ôñé÷ áéï ëì ëúåáú áôøîèø <parameter>to</parameter>. + ãåàì òí ÷åáöéí îöåøôéí (attachments) åòí ñåâéí îéåçãéí ùì úåëï + éëåìéí ìäùìç òí äôåð÷öéä äæàú. úäìéê æä îåùìí ãøê ä- MIME-encoding + - ú÷ï äîàôùø ìäòáéø áãåàì ëì ñåâ ÷åáõ. ìòåã îéãò, òééï á<ulink url="&url.email.mime.zend;"> + îàîø î-Zend àå á- + <ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> - The following RFC's may also be useful: + ä÷éùåøéí äáàéí ì-RFC éëåìéí ìäéåú âí ëï ùéîåùééí: <ulink url="&url.rfc1896;">RFC 1896</ulink>, <ulink url="&url.rfc2045;">RFC 2045</ulink>, <ulink url="&url.rfc2046;">RFC 2046</ulink>, <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and + <ulink url="&url.rfc2048;">RFC 2048</ulink>, å <ulink url="&url.rfc2049;">RFC 2049</ulink>. </simpara> <para> - <function>mail</function> returns &true; if the mail - is successfully sent, &false; otherwise. + <function>ãåàø</function> îçæéøä &true; àí äãåàø ðùìç áäöìçä, å-&false; àçøú. </para> <para> <example> - <title>Sending mail.</title> + <title>ùìéçú ãåàø</title> <programlisting> <![CDATA[ mail("joecool@example.com", "My Subject", "Line 1\nLine 2\nLine 3"); @@ -111,23 +111,23 @@ </programlisting> </example></para> <simpara> - If a fourth string argument is passed, this string is inserted at - the end of the header. This is typically used to add extra - headers. Multiple extra headers are separated with a carriage return - and newline. + àí îùúðä øáéòé îñåâ îçøåæú ðùìç áðåñó, îçøåæú æå îåëðñú áñåó + äëåúøú (header). äùéîåù áîùúðä æä äåà ìøåá áùáéì ìäåñéó òåã + ëåúøåú (headers). áëãé ìäåñéó ëîä ëåúøåú, éù ìäôøéãí áòæøú äçæøú + äñîï ìäúçìú äùåøä (/r) åùåøä çãùä (/n). </simpara> <note> <para> - You must use <literal>\r\n</literal> to seperate headers, although - some Unix mail transfer agents may work with just a single newline - (<literal>\n</literal>). The Cc: header is case sensitive and must - be written as <literal>Cc:</literal> on Win32 systems. The Bcc: - header is also not supported on Win32 systems. + àúä çééá ìäùúîù áúååéí <literal>\r\n</literal> ëãé ìäôøéã ëåúøåú, ìîøåú + ùñåëðé äòáøú ãåàø îñåééîéí ùì Unix éëåìéí ìòáåã ø÷ òí ùåøä + çãùä (<literal>\n</literal>). äëåúøú Cc: äéà øâéùä ìäáãì áéï àåúéåú ÷èðåú + ìâãåìåú (-áàðâìéú) åçééá ìäëúá áîòøëåú Win32 ëê: <literal>Cc:</literal>. + äëåúøú Bcc: àéðä ðúîëú áîòøëåú Win32. </para> </note> <para> <example> - <title>Sending mail with extra headers.</title> + <title>ùìéçú ãåàø òí ëåúøåú ðåñôåú.</title> <programlisting> <![CDATA[ mail("nobody@example.com", "the subject", $message, @@ -139,16 +139,15 @@ </example> </para> <para> - The <parameter>additional_parameters</parameter> parameter - can be used to pass additional parameters to the program configured - to use when sending mail using the <literal>sendmail_path</literal> - configuration setting. For example, this can be used to set the - envelope sender address when using sendmail. You may need to add - the user that your web server runs as to your sendmail configuration - to prevent a 'X-Warning' header from being added to the message when - you set the envelope sender using this method. + äôøîèøéí äðåñôéí (<parameter>additional_parameters</parameter>) éëåìéí + ìùîù ìäòáøú ôøîèøéí ðåñôéí ìúåëðä äîåâãøú ìùéîåù ëùùåìçéí ãåàø + áòæøú äúåëðä äîåâãøú áúé÷éä <literal>sendmail_path</literal>. ìãåâîä, + àôùø ìäùúîù áàôùøåú æå áùáéì ì÷áåò àú îòèôú ëúåáú äùåìç ëùîùúîùéí + áúåëðä Sendmail. àúä úäéä öøéê ìäåñéó àú äîùúîù ùùøú äàéðèøðè îôòéì + áäâãøåú äúåëðä Sendmail áùáéì ìîðåò àú äåñôú äëåúøú 'X-Warning' + ìäåãòä ùìê, ëùàúä ÷åáò àú îòèôú ëúåáú òí äùéèä äæàú. <example> - <title>Sending mail with extra headers and setting an additional command line parameter.</title> + <title>ùìéçú ãåàø òí úåøåú ðåñôåú å÷áéòú ô÷åãä ðåñôú ëôøîèø.</title> <programlisting> <![CDATA[ mail("nobody@example.com", "the subject", $message, @@ -159,19 +158,19 @@ </para> <note> <para> - This fifth parameter was added in PHP 4.0.5. + äôøîèø äçîéùé äåñó áâéøñä PHP 4.0.5. </para> </note> <para> - You can also use simple string building techniques to build complex - email messages. + àúä éëåì âí ëï ìäùúîù áèëðé÷åú ôùåèåú ùì áðééú îçøåæåú ëãé ìáðåú + äåãòåú ãåàì îåøëáåú. <example> - <title>Sending complex email.</title> + <title>ùìéçú äåãòåú îåøëáåú.</title> <programlisting> <![CDATA[ /* recipients */ -$to = "Mary <mary@example.com>" . ", " ; //note the comma -$to .= "Kelly <kelly@example.com>"; +$to = "Moshe <moshe@example.com>" . ", " ; //àì úùëç àú äôñé÷! +$to .= "David <david@example.com>"; /* subject */ $subject = "Birthday Reminders for August"; @@ -197,17 +196,17 @@ </html> '; -/* To send HTML mail, you can set the Content-type header. */ +/* áëãé ìùìåç ãåàø îñåâ HTML, àú éëåì ì÷áåò àú ëåúøåú ñåâ äúåëï (Content-type).*/ $headers = "MIME-Version: 1.0\r\n"; $headers .= "Content-type: text/html; charset=iso-8859-1\r\n"; -/* additional headers */ +/* ëåúøåú ðåñôåú */ $headers .= "From: Birthday Reminder <birthday@example.com>\r\n"; $headers .= "Cc: birthdayarchive@example.com\r\n"; $headers .= "Bcc: birthdaycheck@example.com\r\n"; -/* and now mail it */ +/* åòëùéå - ùìç àú æä! */ mail($to, $subject, $message, $headers); ]]> </programlisting> @@ -215,9 +214,8 @@ </para> <note> <para> - Make sure you do not have any newline characters in the - <parameter>to</parameter> or <parameter>subject</parameter>, - or the mail may not be sent properly. + ååãà àú æä ùàéï ìê ùåí úå ùì ùåøä çãùä áôøîèø <parameter>to</parameter> àå + áôøîèø <parameter>subject</parameter>, àçøú äãåàø ìà éùìç äéèá. </para> </note> </refsect1> @@ -226,27 +224,27 @@ <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> - <refpurpose>Calculate the hash value needed by EZMLM</refpurpose> + <refpurpose>çùá àú òøê ä-hash äãøåù òì éãé EZMLM</refpurpose> </refnamediv> <refsect1> - <title>Description</title> + <title>úéàåø</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> - <methodparam><type>string</type><parameter>addr</parameter></methodparam> + <methodparam><type>îçøåæú</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> - <function>ezmlm_hash</function> calculates the hash value needed - when keeping EZMLM mailing lists in a MySQL database. + äôåð÷öéä <function>ezmlm_hash</function> îçùáú àú òøê ä-hash äãøåù ëùùåîøéí øùéîåú + ãåàø EZMLM áîàâø ðúåðéí îñåâ MySql. </simpara> <para> <example> - <title>Calculating the hash and subscribing a user</title> + <title>çéùåá ä-hash åøéùåí îùúîù</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; $hash = ezmlm_hash ($user); $query = sprintf ("INSERT INTO sample VALUES (%s, '%s')", $hash, $user); -$db->query($query); // using PHPLIB db interface +$db->query($query); // PHPLIB db ùéîåù áîîù÷ ]]> </programlisting> </example>