cvs: phpdoc /en/functions http.xml imap.xml mail.xml strings.xml zlib.xml /en/reference/http/functions header.xml /en/reference/imap reference.xml
/en/reference/imap/functions imap-8bit.xml imap-base64.xml imap-binary.xml imap-fetchheader.xml imap-mail-copy.xml imap-mail-move.xml
imap-mime-header-decode.xml imap-qprint.xml imap-rfc822-parse-adrlist.xml imap-rfc822-write-address.xml imap-utf7-decode.xml imap-utf7-encode.xml
imap-utf8.xml /en/reference/mail/functions mail.xml /en/reference/network/functions dns-get-record.xml getmxrr.xml /en/reference/recode
reference.xml /en/reference/strings/functions chunk-split.xml md5-file.xml md5.xml sha1-file.xml sha1.xml /en/reference/url/functions
base64-decode.xml base64-encode.xml rawurlencode.xml /en/reference/zlib/functions gzcompress.xml gzdeflate.xml gzencode.xml /entities global.ent
| From: | Joey Smith | Date: | Wed, 07 May 2003 21:31:31 +0000 |
| Subject: | cvs: phpdoc /en/functions http.xml imap.xml mail.xml strings.xml zlib.xml /en/reference/http/functions header.xml /en/reference/imap reference.xml /en/reference/imap/functions imap-8bit.xml imap-base64.xml imap-binary.xml imap-fetchheader.xml imap-mail-copy.xml imap-mail-move.xml imap-mime-header-decode.xml imap-qprint.xml imap-rfc822-parse-adrlist.xml imap-rfc822-write-address.xml imap-utf7-decode.xml imap-utf7-encode.xml imap-utf8.xml /en/reference/mail/functions mail.xml /en/reference/network/functions dns-get-record.xml getmxrr.xml /en/reference/recode reference.xml /en/reference/strings/functions chunk-split.xml md5-file.xml md5.xml sha1-file.xml sha1.xml /en/reference/url/functions base64-decode.xml base64-encode.xml rawurlencode.xml /en/reference/zlib/functions gzcompress.xml gzdeflate.xml gzencode.xml /entities global.ent |
||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969353255@lists.php.net to get a copy of this message | ||
joey Wed May 7 17:31:31 2003 EDT
Modified files:
/phpdoc/en/functions http.xml imap.xml mail.xml strings.xml
zlib.xml
/phpdoc/en/reference/http/functions header.xml
/phpdoc/en/reference/imap reference.xml
/phpdoc/en/reference/imap/functions imap-8bit.xml imap-base64.xml
imap-binary.xml
imap-fetchheader.xml
imap-mail-copy.xml
imap-mail-move.xml
imap-mime-header-decode.xml
imap-qprint.xml
imap-rfc822-parse-adrlist.xml
imap-rfc822-write-address.xml
imap-utf7-decode.xml
imap-utf7-encode.xml
imap-utf8.xml
/phpdoc/en/reference/mail/functions mail.xml
/phpdoc/en/reference/network/functions dns-get-record.xml
getmxrr.xml
/phpdoc/en/reference/recode reference.xml
/phpdoc/en/reference/strings/functions chunk-split.xml md5-file.xml
md5.xml sha1-file.xml
sha1.xml
/phpdoc/en/reference/url/functions base64-decode.xml
base64-encode.xml
rawurlencode.xml
/phpdoc/en/reference/zlib/functions gzcompress.xml gzdeflate.xml
gzencode.xml
/phpdoc/entities global.ent
Log:
Updating all RFC entities to use new &url.rfc;#### syntax
Index: phpdoc/en/functions/http.xml diff -u phpdoc/en/functions/http.xml:1.45 phpdoc/en/functions/http.xml:1.46 --- phpdoc/en/functions/http.xml:1.45 Wed Apr 17 15:58:42 2002 +++ phpdoc/en/functions/http.xml Wed May 7 17:31:29 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.45 $ --> +<!-- $Revision: 1.46 $ --> <reference id="ref.http"> <title>HTTP functions</title> <titleabbrev>HTTP</titleabbrev> @@ -196,7 +196,7 @@ <para> If you want the user to be prompted to save the data you are sending, such as a generated PDF file, you can use the <ulink - url="&url.rfc2183;">Content-Disposition</ulink> header to + url="&url.rfc;2183">Content-Disposition</ulink> header to supply a recommended filename and force the browser to display the save dialog. <informalexample> Index: phpdoc/en/functions/imap.xml diff -u phpdoc/en/functions/imap.xml:1.64 phpdoc/en/functions/imap.xml:1.65 --- phpdoc/en/functions/imap.xml:1.64 Mon May 20 16:38:39 2002 +++ phpdoc/en/functions/imap.xml Wed May 7 17:31:29 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.64 $ --> +<!-- $Revision: 1.65 $ --> <reference id='ref.imap'> <title>IMAP, POP3 and NNTP functions</title> <titleabbrev>IMAP</titleabbrev> @@ -42,47 +42,47 @@ <itemizedlist> <listitem> <simpara> - <ulink url="&url.rfc;rfc2821.html">RFC2821</ulink>: Simple Mail + <ulink url="&url.rfc;2821">RFC2821</ulink>: Simple Mail Transfer Protocol (SMTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink>: Standard for + <ulink url="&url.rfc;2822">RFC2822</ulink>: Standard for ARPA internet text messages. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>: Internet + <ulink url="&url.rfc;2060">RFC2060</ulink>: Internet Message Access Protocol (IMAP) Version 4rev1. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc1939.html">RFC1939</ulink>: Post + <ulink url="&url.rfc;1939">RFC1939</ulink>: Post Office Protocol Version 3 (POP3). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc977.html">RFC977</ulink>: Network News + <ulink url="&url.rfc;977">RFC977</ulink>: Network News Transfer Protocol (NNTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2076.html">RFC2076</ulink>: Common + <ulink url="&url.rfc;2076">RFC2076</ulink>: Common Internet Message Headers. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink> , <ulink - url="&url.rfc;rfc2046.html">RFC2046</ulink> , <ulink - url="&url.rfc;rfc2047.html">RFC2047</ulink> , <ulink - url="&url.rfc;rfc2048.html">RFC2048</ulink> & <ulink - url="&url.rfc;rfc2049.html">RFC2049</ulink>: Multipurpose + <ulink url="&url.rfc;2045">RFC2045</ulink> , <ulink + url="&url.rfc;2046">RFC2046</ulink> , <ulink + url="&url.rfc;2047">RFC2047</ulink> , <ulink + url="&url.rfc;2048">RFC2048</ulink> & <ulink + url="&url.rfc;2049">RFC2049</ulink>: Multipurpose Internet Mail Extensions (MIME). </simpara> </listitem> @@ -109,7 +109,7 @@ </methodsynopsis> <para> Convert an 8bit string to a quoted-printable string (according to - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> @@ -219,7 +219,7 @@ </methodsynopsis> <para> <function>imap_base64</function> function decodes BASE-64 encoded - text (see <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, + text (see <ulink url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). The decoded message is returned as a string. </para> <para> @@ -243,7 +243,7 @@ </methodsynopsis> <para> Convert an 8bit string to a base64 string (according to <ulink - url="&url.rfc;rfc2045.html">RFC2045</ulink>, Section 6.8). + url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). </para> <para> Returns a base64 string. @@ -841,7 +841,7 @@ </methodsynopsis> <para> This function causes a fetch of the complete, unfiltered - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> format header of the specified message as a text string and returns that text string. </para> @@ -1551,7 +1551,7 @@ Copies mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask of one or more of @@ -1590,7 +1590,7 @@ Moves mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask and may contain the single option @@ -1721,7 +1721,7 @@ <para> <function>imap_mime_header_decode</function> function decodes MIME message header extensions that are non ASCII text - (see <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink>) + (see <ulink url="&url.rfc;2047">RFC2047</ulink>) The decoded elements are returned in an array of objects, where each object has two properties, "charset" & "text". If the element hasn't been encoded, and in other words is in @@ -2031,7 +2031,7 @@ </methodsynopsis> <para> Convert a quoted-printable string to an 8 bit string (according - to <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + to <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> @@ -2140,7 +2140,7 @@ </methodsynopsis> <para> This function parses the address string as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> and + <ulink url="&url.rfc;2822">RFC2822</ulink> and for each address, returns an array of objects. The objects properties are: </para> @@ -2229,7 +2229,7 @@ </methodsynopsis> <para> Returns a properly formatted email address as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> given the mailbox, host, and personal info. </para> <para> @@ -2822,9 +2822,9 @@ not valid modified UTF-7. This function is needed to decode mailbox names that contain international characters outside of the printable ASCII range. The modified UTF-7 encoding is defined - in <ulink url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section + in <ulink url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> </refsect1> </refentry> @@ -2847,9 +2847,9 @@ text. This is needed to encode mailbox names that contain international characters outside of the printable ASCII range. The modified UTF-7 encoding is defined in <ulink - url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section 5.1.3 + url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> <para> Returns the modified UTF-7 text. @@ -2873,7 +2873,7 @@ <para> Converts the given <parameter>text</parameter> to UTF8 (as defined in - <ulink url="&url.rfc;rfc2044.html">RFC2044</ulink>). + <ulink url="&url.rfc;2044">RFC2044</ulink>). </para> </refsect1> </refentry> Index: phpdoc/en/functions/mail.xml diff -u phpdoc/en/functions/mail.xml:1.40 phpdoc/en/functions/mail.xml:1.41 --- phpdoc/en/functions/mail.xml:1.40 Fri Aug 16 21:13:10 2002 +++ phpdoc/en/functions/mail.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.40 $ --> +<!-- $Revision: 1.41 $ --> <reference id="ref.mail"> <title>Mail functions</title> <titleabbrev>Mail</titleabbrev> @@ -102,12 +102,12 @@ </simpara> <simpara> The following RFC's may also be useful: - <ulink url="&url.rfc1896;">RFC 1896</ulink>, - <ulink url="&url.rfc2045;">RFC 2045</ulink>, - <ulink url="&url.rfc2046;">RFC 2046</ulink>, - <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and - <ulink url="&url.rfc2049;">RFC 2049</ulink>. + <ulink url="&url.rfc;1896">RFC 1896</ulink>, + <ulink url="&url.rfc;2045">RFC 2045</ulink>, + <ulink url="&url.rfc;2046">RFC 2046</ulink>, + <ulink url="&url.rfc;2047">RFC 2047</ulink>, + <ulink url="&url.rfc;2048">RFC 2048</ulink>, and + <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> <function>mail</function> returns &true; if the mail Index: phpdoc/en/functions/strings.xml diff -u phpdoc/en/functions/strings.xml:1.172 phpdoc/en/functions/strings.xml:1.173 --- phpdoc/en/functions/strings.xml:1.172 Sat May 11 03:02:28 2002 +++ phpdoc/en/functions/strings.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.172 $ --> +<!-- $Revision: 1.173 $ --> <reference id="ref.strings"> <title>String functions</title> <titleabbrev>Strings</titleabbrev> @@ -1480,7 +1480,7 @@ </methodsynopsis> <para> Calculates the MD5 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. </para> @@ -1504,7 +1504,7 @@ <para> Calculates the MD5 hash of the specified <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. </para> <para> Index: phpdoc/en/functions/zlib.xml diff -u phpdoc/en/functions/zlib.xml:1.27 phpdoc/en/functions/zlib.xml:1.28 --- phpdoc/en/functions/zlib.xml:1.27 Wed Apr 17 15:58:46 2002 +++ phpdoc/en/functions/zlib.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.27 $ --> +<!-- $Revision: 1.28 $ --> <reference id="ref.zlib"> <title>Zlib Compression Functions</title> <titleabbrev>Zlib</titleabbrev> @@ -606,7 +606,7 @@ </para> <para> For details on the ZLIB compression algorithm see the document - "<ulink url="&url.rfc1950;">ZLIB Compressed Data Format + "<ulink url="&url.rfc;1950">ZLIB Compressed Data Format Specification version 3.3</ulink>" (RFC 1950). </para> <note> @@ -675,7 +675,7 @@ </para> <para> For details on the DEFLATE compression algorithm see the document - "<ulink url="&url.rfc1951;">DEFLATE Compressed Data Format + "<ulink url="&url.rfc;1951">DEFLATE Compressed Data Format Specification version 1.3</ulink>" (RFC 1951). </para> <para> @@ -775,7 +775,7 @@ </para> <para> For more information on the GZIP file format, see the document: - <ulink url="&url.rfc1952;">GZIP file format specification + <ulink url="&url.rfc;1952">GZIP file format specification version 4.3</ulink> (RFC 1952). </para> <para> Index: phpdoc/en/reference/http/functions/header.xml diff -u phpdoc/en/reference/http/functions/header.xml:1.12 phpdoc/en/reference/http/functions/header.xml:1.13 --- phpdoc/en/reference/http/functions/header.xml:1.12 Thu Apr 17 17:43:03 2003 +++ phpdoc/en/reference/http/functions/header.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> +<!-- $Revision: 1.13 $ --> <!-- splitted from ./en/functions/http.xml, last change in rev 1.2 --> <refentry id="function.header"> <refnamediv> @@ -196,7 +196,7 @@ <para> If you want the user to be prompted to save the data you are sending, such as a generated PDF file, you can use the <ulink - url="&url.rfc2183;">Content-Disposition</ulink> header to + url="&url.rfc;2183">Content-Disposition</ulink> header to supply a recommended filename and force the browser to display the save dialog. <informalexample> Index: phpdoc/en/reference/imap/reference.xml diff -u phpdoc/en/reference/imap/reference.xml:1.11 phpdoc/en/reference/imap/reference.xml:1.12 --- phpdoc/en/reference/imap/reference.xml:1.11 Mon Jan 20 16:41:12 2003 +++ phpdoc/en/reference/imap/reference.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.11 $ --> +<!-- $Revision: 1.12 $ --> <reference id='ref.imap'> <title>IMAP, POP3 and NNTP functions</title> <titleabbrev>IMAP</titleabbrev> @@ -72,47 +72,47 @@ <itemizedlist> <listitem> <simpara> - <ulink url="&url.rfc;rfc2821.html">RFC2821</ulink>: Simple Mail + <ulink url="&url.rfc;2821">RFC2821</ulink>: Simple Mail Transfer Protocol (SMTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink>: Standard for + <ulink url="&url.rfc;2822">RFC2822</ulink>: Standard for ARPA internet text messages. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>: Internet + <ulink url="&url.rfc;2060">RFC2060</ulink>: Internet Message Access Protocol (IMAP) Version 4rev1. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc1939.html">RFC1939</ulink>: Post + <ulink url="&url.rfc;1939">RFC1939</ulink>: Post Office Protocol Version 3 (POP3). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc977.html">RFC977</ulink>: Network News + <ulink url="&url.rfc;977">RFC977</ulink>: Network News Transfer Protocol (NNTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2076.html">RFC2076</ulink>: Common + <ulink url="&url.rfc;2076">RFC2076</ulink>: Common Internet Message Headers. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink> , <ulink - url="&url.rfc;rfc2046.html">RFC2046</ulink> , <ulink - url="&url.rfc;rfc2047.html">RFC2047</ulink> , <ulink - url="&url.rfc;rfc2048.html">RFC2048</ulink> & <ulink - url="&url.rfc;rfc2049.html">RFC2049</ulink>: Multipurpose + <ulink url="&url.rfc;2045">RFC2045</ulink> , <ulink + url="&url.rfc;2046">RFC2046</ulink> , <ulink + url="&url.rfc;2047">RFC2047</ulink> , <ulink + url="&url.rfc;2048">RFC2048</ulink> & <ulink + url="&url.rfc;2049">RFC2049</ulink>: Multipurpose Internet Mail Extensions (MIME). </simpara> </listitem> Index: phpdoc/en/reference/imap/functions/imap-8bit.xml diff -u phpdoc/en/reference/imap/functions/imap-8bit.xml:1.2 phpdoc/en/reference/imap/functions/imap-8bit.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-8bit.xml:1.2 Wed Apr 17 02:39:15 2002 +++ phpdoc/en/reference/imap/functions/imap-8bit.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-8bit"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> Convert an 8bit string to a quoted-printable string (according to - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> Index: phpdoc/en/reference/imap/functions/imap-base64.xml diff -u phpdoc/en/reference/imap/functions/imap-base64.xml:1.2 phpdoc/en/reference/imap/functions/imap-base64.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-base64.xml:1.2 Wed Apr 17 02:39:16 2002 +++ phpdoc/en/reference/imap/functions/imap-base64.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-base64"> <refnamediv> @@ -14,7 +14,7 @@ </methodsynopsis> <para> <function>imap_base64</function> function decodes BASE-64 encoded - text (see <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, + text (see <ulink url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). The decoded message is returned as a string. </para> <para> Index: phpdoc/en/reference/imap/functions/imap-binary.xml diff -u phpdoc/en/reference/imap/functions/imap-binary.xml:1.2 phpdoc/en/reference/imap/functions/imap-binary.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-binary.xml:1.2 Wed Apr 17 02:39:16 2002 +++ phpdoc/en/reference/imap/functions/imap-binary.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-binary"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> Convert an 8bit string to a base64 string (according to <ulink - url="&url.rfc;rfc2045.html">RFC2045</ulink>, Section 6.8). + url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). </para> <para> Returns a base64 string. Index: phpdoc/en/reference/imap/functions/imap-fetchheader.xml diff -u phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.3 phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.3 Wed Oct 9 10:55:05 2002 +++ phpdoc/en/reference/imap/functions/imap-fetchheader.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-fetchheader"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> This function causes a fetch of the complete, unfiltered - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> format header of the specified message as a text string and returns that text string. </para> Index: phpdoc/en/reference/imap/functions/imap-mail-copy.xml diff -u phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.3 phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.3 Wed Oct 9 10:55:05 2002 +++ phpdoc/en/reference/imap/functions/imap-mail-copy.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-mail-copy"> <refnamediv> @@ -22,7 +22,7 @@ Copies mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask of one or more of Index: phpdoc/en/reference/imap/functions/imap-mail-move.xml diff -u phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.4 phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.5 --- phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.4 Wed Feb 5 22:08:22 2003 +++ phpdoc/en/reference/imap/functions/imap-mail-move.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-mail-move"> <refnamediv> @@ -19,7 +19,7 @@ Moves mail messages specified by <parameter>msglist</parameter> to specified mailbox <parameter>mbox</parameter>. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> &return.success; Index: phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml diff -u phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.2 phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.2 Wed Apr 17 02:39:20 2002 +++ phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-mime-header-decode"> <refnamediv> @@ -15,7 +15,7 @@ <para> <function>imap_mime_header_decode</function> function decodes MIME message header extensions that are non ASCII text - (see <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink>) + (see <ulink url="&url.rfc;2047">RFC2047</ulink>) The decoded elements are returned in an array of objects, where each object has two properties, "charset" & "text". If the element hasn't been encoded, and in other words is in Index: phpdoc/en/reference/imap/functions/imap-qprint.xml diff -u phpdoc/en/reference/imap/functions/imap-qprint.xml:1.2 phpdoc/en/reference/imap/functions/imap-qprint.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-qprint.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-qprint.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-qprint"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> Convert a quoted-printable string to an 8 bit string (according - to <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + to <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> Index: phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml diff -u phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.2 phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-rfc822-parse-adrlist"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> This function parses the address string as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> and + <ulink url="&url.rfc;2822">RFC2822</ulink> and for each address, returns an array of objects. The objects properties are: </para> Index: phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml diff -u phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.2 phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-rfc822-write-address"> <refnamediv> @@ -19,7 +19,7 @@ </methodsynopsis> <para> Returns a properly formatted email address as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> given the mailbox, host, and personal info. </para> <para> Index: phpdoc/en/reference/imap/functions/imap-utf7-decode.xml diff -u phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.3 phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.3 Mon Mar 31 15:25:57 2003 +++ phpdoc/en/reference/imap/functions/imap-utf7-decode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.16 --> <refentry id="function.imap-utf7-decode"> <refnamediv> @@ -26,9 +26,9 @@ This function is needed to decode mailbox names that contain certain characters which are not in range of printable ASCII characters. The modified UTF-7 encoding is defined in - <ulink url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section + <ulink url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> </refsect1> </refentry> Index: phpdoc/en/reference/imap/functions/imap-utf7-encode.xml diff -u phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.4 phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.5 --- phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.4 Mon Mar 31 15:27:58 2003 +++ phpdoc/en/reference/imap/functions/imap-utf7-encode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.9 --> <refentry id="function.imap-utf7-encode"> <refnamediv> @@ -20,9 +20,9 @@ characters which are not in range of printable ASCII characters. Note that <parameter>data</parameter> is expected to be encoded in ISO-8859-1. The modified UTF-7 encoding is defined in <ulink - url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section 5.1.3 + url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> <para> Returns the modified UTF-7 text. Index: phpdoc/en/reference/imap/functions/imap-utf8.xml diff -u phpdoc/en/reference/imap/functions/imap-utf8.xml:1.3 phpdoc/en/reference/imap/functions/imap-utf8.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-utf8.xml:1.3 Mon Mar 31 15:25:57 2003 +++ phpdoc/en/reference/imap/functions/imap-utf8.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.7 --> <refentry id="function.imap-utf8"> <refnamediv> @@ -19,8 +19,8 @@ <para> Converts the given <parameter>mime_encoded_text</parameter> to UTF-8. MIME encoding method and the UTF-8 specification are described in - <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink> and - <ulink url="&url.rfc;rfc2044.html">RFC2044</ulink> respectively. + <ulink url="&url.rfc;2047">RFC2047</ulink> and + <ulink url="&url.rfc;2044">RFC2044</ulink> respectively. </para> </refsect1> </refentry> Index: phpdoc/en/reference/mail/functions/mail.xml diff -u phpdoc/en/reference/mail/functions/mail.xml:1.15 phpdoc/en/reference/mail/functions/mail.xml:1.16 --- phpdoc/en/reference/mail/functions/mail.xml:1.15 Tue Apr 29 05:53:11 2003 +++ phpdoc/en/reference/mail/functions/mail.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.15 $ --> +<!-- $Revision: 1.16 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> @@ -30,12 +30,12 @@ </simpara> <simpara> The following RFC's may also be useful: - <ulink url="&url.rfc1896;">RFC 1896</ulink>, - <ulink url="&url.rfc2045;">RFC 2045</ulink>, - <ulink url="&url.rfc2046;">RFC 2046</ulink>, - <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and - <ulink url="&url.rfc2049;">RFC 2049</ulink>. + <ulink url="&url.rfc;1896">RFC 1896</ulink>, + <ulink url="&url.rfc;2045">RFC 2045</ulink>, + <ulink url="&url.rfc;2046">RFC 2046</ulink>, + <ulink url="&url.rfc;2047">RFC 2047</ulink>, + <ulink url="&url.rfc;2048">RFC 2048</ulink>, and + <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> <function>mail</function> returns &true; if the mail was successfully Index: phpdoc/en/reference/network/functions/dns-get-record.xml diff -u phpdoc/en/reference/network/functions/dns-get-record.xml:1.12 phpdoc/en/reference/network/functions/dns-get-record.xml:1.13 --- phpdoc/en/reference/network/functions/dns-get-record.xml:1.12 Tue May 6 19:26:33 2003 +++ phpdoc/en/reference/network/functions/dns-get-record.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> +<!-- $Revision: 1.13 $ --> <refentry id="function.dns-get-record"> <refnamediv> <refname>dns_get_record</refname> @@ -209,7 +209,7 @@ <parameter>targets</parameter> should be chosen at random. <literal>target</literal> and <literal>port</literal>: hostname and port where the requested service can be found. - For additional information see: <ulink url="&url.rfc2782;">RFC 2782</ulink> + For additional information see: <ulink url="&url.rfc;2782">RFC 2782</ulink> </entry> </row> <row> @@ -219,7 +219,7 @@ <parameter>pri</parameter> and <parameter>weight</parameter> above. <literal>flags</literal>, <literal>services</literal>, <literal>regex</literal>, and <literal>replacement</literal>: Parameters as defined by - <ulink url="&url.rfc2915;">RFC 2915</ulink>. + <ulink url="&url.rfc;2915">RFC 2915</ulink>. </entry> </row> </tbody> Index: phpdoc/en/reference/network/functions/getmxrr.xml diff -u phpdoc/en/reference/network/functions/getmxrr.xml:1.6 phpdoc/en/reference/network/functions/getmxrr.xml:1.7 --- phpdoc/en/reference/network/functions/getmxrr.xml:1.6 Tue May 6 18:46:02 2003 +++ phpdoc/en/reference/network/functions/getmxrr.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.6 $ --> +<!-- $Revision: 1.7 $ --> <!-- splitted from ./en/functions/network.xml, last change in rev 1.2 --> <refentry id="function.getmxrr"> <refnamediv> @@ -33,7 +33,7 @@ <simpara> This function should not be used for the purposes of address verification. Only the mailexchangers found in DNS are returned, - however, according to <ulink url="&url.rfc2821;">RFC 2821</ulink> + however, according to <ulink url="&url.rfc;2821">RFC 2821</ulink> when no mail exchangers are listed, <parameter>hostname</parameter> itself should be used as the only mail exchanger with a priority of <literal>0</literal>. Index: phpdoc/en/reference/recode/reference.xml diff -u phpdoc/en/reference/recode/reference.xml:1.6 phpdoc/en/reference/recode/reference.xml:1.7 --- phpdoc/en/reference/recode/reference.xml:1.6 Mon Dec 2 07:55:39 2002 +++ phpdoc/en/reference/recode/reference.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.6 $ --> +<!-- $Revision: 1.7 $ --> <reference id="ref.recode"> <title>GNU Recode functions</title> <titleabbrev>Recode</titleabbrev> @@ -15,7 +15,7 @@ fall back on approximations. The library recognises or produces nearly 150 different character sets and is able to convert files between almost any pair. - Most <ulink url="&url.rfc;rfc1345.html">RFC 1345</ulink> character sets + Most <ulink url="&url.rfc;1345">RFC 1345</ulink> character sets are supported. </para> ¬e.no-windows.extension; Index: phpdoc/en/reference/strings/functions/chunk-split.xml diff -u phpdoc/en/reference/strings/functions/chunk-split.xml:1.3 phpdoc/en/reference/strings/functions/chunk-split.xml:1.4 --- phpdoc/en/reference/strings/functions/chunk-split.xml:1.3 Tue Jul 30 05:26:16 2002 +++ phpdoc/en/reference/strings/functions/chunk-split.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.2 --> <refentry id="function.chunk-split"> <refnamediv> @@ -35,7 +35,7 @@ <simpara> See also <function>explode</function>, <function>split</function> <function>wordwrap</function> and - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink>. + <ulink url="&url.rfc;2045">RFC 2045</ulink>. </simpara> </refsect1> </refentry> Index: phpdoc/en/reference/strings/functions/md5-file.xml diff -u phpdoc/en/reference/strings/functions/md5-file.xml:1.4 phpdoc/en/reference/strings/functions/md5-file.xml:1.5 --- phpdoc/en/reference/strings/functions/md5-file.xml:1.4 Thu Feb 20 05:54:32 2003 +++ phpdoc/en/reference/strings/functions/md5-file.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.2 --> <refentry id="function.md5-file"> <refnamediv> @@ -16,7 +16,7 @@ <para> Calculates the MD5 hash of the specified <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the md5 digest Index: phpdoc/en/reference/strings/functions/md5.xml diff -u phpdoc/en/reference/strings/functions/md5.xml:1.5 phpdoc/en/reference/strings/functions/md5.xml:1.6 --- phpdoc/en/reference/strings/functions/md5.xml:1.5 Thu Feb 20 05:54:32 2003 +++ phpdoc/en/reference/strings/functions/md5.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.5 $ --> +<!-- $Revision: 1.6 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.135 --> <refentry id="function.md5"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> Calculates the MD5 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the md5 digest Index: phpdoc/en/reference/strings/functions/sha1-file.xml diff -u phpdoc/en/reference/strings/functions/sha1-file.xml:1.3 phpdoc/en/reference/strings/functions/sha1-file.xml:1.4 --- phpdoc/en/reference/strings/functions/sha1-file.xml:1.3 Thu Feb 20 05:57:56 2003 +++ phpdoc/en/reference/strings/functions/sha1-file.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <refentry id="function.sha1-file"> <refnamediv> <refname>sha1_file</refname> @@ -14,7 +14,7 @@ </methodsynopsis> <simpara> Calculates the sha1 hash of <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc3174.html">US Secure Hash Algorithm 1</ulink>, + <ulink url="&url.rfc;3174">US Secure Hash Algorithm 1</ulink>, and returns that hash. The hash is a 40-character hexadecimal number. Upon failure, &false; is returned. If the optional <parameter>raw_output</parameter> is set to &true;, then the sha1 digest Index: phpdoc/en/reference/strings/functions/sha1.xml diff -u phpdoc/en/reference/strings/functions/sha1.xml:1.4 phpdoc/en/reference/strings/functions/sha1.xml:1.5 --- phpdoc/en/reference/strings/functions/sha1.xml:1.4 Thu Feb 20 05:57:56 2003 +++ phpdoc/en/reference/strings/functions/sha1.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <refentry id="function.sha1"> <refnamediv> <refname>sha1</refname> @@ -14,7 +14,7 @@ </methodsynopsis> <simpara> Calculates the sha1 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc3174.html">US Secure Hash Algorithm 1</ulink>, + <ulink url="&url.rfc;3174">US Secure Hash Algorithm 1</ulink>, and returns that hash. The hash is a 40-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the sha1 digest is instead returned in raw binary format with a Index: phpdoc/en/reference/url/functions/base64-decode.xml diff -u phpdoc/en/reference/url/functions/base64-decode.xml:1.3 phpdoc/en/reference/url/functions/base64-decode.xml:1.4 --- phpdoc/en/reference/url/functions/base64-decode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/base64-decode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.2 --> <refentry id="function.base64-decode"> <refnamediv> @@ -19,7 +19,7 @@ </para> <para> See also: <function>base64_encode</function>, - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink> section 6.8. + <ulink url="&url.rfc;2045">RFC 2045</ulink> section 6.8. </para> </refsect1> </refentry> Index: phpdoc/en/reference/url/functions/base64-encode.xml diff -u phpdoc/en/reference/url/functions/base64-encode.xml:1.3 phpdoc/en/reference/url/functions/base64-encode.xml:1.4 --- phpdoc/en/reference/url/functions/base64-encode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/base64-encode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.2 --> <refentry id="function.base64-encode"> <refnamediv> @@ -25,7 +25,7 @@ See also: <function>base64_decode</function>, <function>chunk_split</function>, - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink> section 6.8. + <ulink url="&url.rfc;2045">RFC 2045</ulink> section 6.8. </para> </refsect1> </refentry> Index: phpdoc/en/reference/url/functions/rawurlencode.xml diff -u phpdoc/en/reference/url/functions/rawurlencode.xml:1.3 phpdoc/en/reference/url/functions/rawurlencode.xml:1.4 --- phpdoc/en/reference/url/functions/rawurlencode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/rawurlencode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.6 --> <refentry id="function.rawurlencode"> <refnamediv> @@ -47,7 +47,7 @@ See also <function>rawurldecode</function>, <function>urldecode</function>, <function>urlencode</function> and - <ulink url="&url.rfc;rfc1738.html">RFC 1738</ulink> + <ulink url="&url.rfc;1738">RFC 1738</ulink> </simpara> </refsect1> </refentry> Index: phpdoc/en/reference/zlib/functions/gzcompress.xml diff -u phpdoc/en/reference/zlib/functions/gzcompress.xml:1.2 phpdoc/en/reference/zlib/functions/gzcompress.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzcompress.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzcompress.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.4 --> <refentry id="function.gzcompress"> <refnamediv> @@ -22,7 +22,7 @@ </para> <para> For details on the ZLIB compression algorithm see the document - "<ulink url="&url.rfc1950;">ZLIB Compressed Data Format + "<ulink url="&url.rfc;1950">ZLIB Compressed Data Format Specification version 3.3</ulink>" (RFC 1950). </para> <note> Index: phpdoc/en/reference/zlib/functions/gzdeflate.xml diff -u phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.2 phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzdeflate.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.11 --> <refentry id="function.gzdeflate"> <refnamediv> @@ -22,7 +22,7 @@ </para> <para> For details on the DEFLATE compression algorithm see the document - "<ulink url="&url.rfc1951;">DEFLATE Compressed Data Format + "<ulink url="&url.rfc;1951">DEFLATE Compressed Data Format Specification version 1.3</ulink>" (RFC 1951). </para> <para> Index: phpdoc/en/reference/zlib/functions/gzencode.xml diff -u phpdoc/en/reference/zlib/functions/gzencode.xml:1.2 phpdoc/en/reference/zlib/functions/gzencode.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzencode.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzencode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.4 --> <refentry id="function.gzencode"> <refnamediv> @@ -59,7 +59,7 @@ </para> <para> For more information on the GZIP file format, see the document: - <ulink url="&url.rfc1952;">GZIP file format specification + <ulink url="&url.rfc;1952">GZIP file format specification version 4.3</ulink> (RFC 1952). </para> <para> Index: phpdoc/entities/global.ent diff -u phpdoc/entities/global.ent:1.101 phpdoc/entities/global.ent:1.102 --- phpdoc/entities/global.ent:1.101 Tue May 6 19:51:48 2003 +++ phpdoc/entities/global.ent Wed May 7 17:31:31 2003 @@ -1,6 +1,6 @@ <!-- -*- SGML -*- - $Id: global.ent,v 1.101 2003/05/06 23:51:48 joey Exp $ + $Id: global.ent,v 1.102 2003/05/07 21:31:31 joey Exp $ Contains global "macros" for all the XML documents. @@ -223,6 +223,7 @@ <!ENTITY url.redhat.support "http://redhat.com/docs/manuals/ccvs/"> <!ENTITY url.redhat.mcve "http://www.mcve.com/"> <!ENTITY url.rfc 'http://www.faqs.org/rfcs/rfc'> +<!-- To link to an RFC, you can use &url.rfc;####, where #### is the RFC number <!ENTITY url.rfc1896 'http://www.ietf.org/rfc/rfc1896.txt'> <!ENTITY url.rfc1950 'http://www.ietf.org/rfc/rfc1950.txt'> <!ENTITY url.rfc1951 'http://www.ietf.org/rfc/rfc1951.txt'> @@ -237,6 +238,7 @@ <!ENTITY url.rfc2782 'http://www.ietf.org/rfc/rfc2782.txt'> <!ENTITY url.rfc2821 'http://www.ietf.org/rfc/rfc2821.txt'> <!ENTITY url.rfc2915 'http://www.ietf.org/rfc/rfc2915.txt'> +--> <!ENTITY url.iana.system-names 'http://www.iana.org/assignments/operating-system-names'> <!ENTITY url.rpmfind "http://www.rpmfind.net/"> <!ENTITY url.sablotron "http://www.gingerall.com/">
Index: phpdoc/en/functions/http.xml diff -u phpdoc/en/functions/http.xml:1.45 phpdoc/en/functions/http.xml:1.46 --- phpdoc/en/functions/http.xml:1.45 Wed Apr 17 15:58:42 2002 +++ phpdoc/en/functions/http.xml Wed May 7 17:31:29 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.45 $ --> +<!-- $Revision: 1.46 $ --> <reference id="ref.http"> <title>HTTP functions</title> <titleabbrev>HTTP</titleabbrev> @@ -196,7 +196,7 @@ <para> If you want the user to be prompted to save the data you are sending, such as a generated PDF file, you can use the <ulink - url="&url.rfc2183;">Content-Disposition</ulink> header to + url="&url.rfc;2183">Content-Disposition</ulink> header to supply a recommended filename and force the browser to display the save dialog. <informalexample> Index: phpdoc/en/functions/imap.xml diff -u phpdoc/en/functions/imap.xml:1.64 phpdoc/en/functions/imap.xml:1.65 --- phpdoc/en/functions/imap.xml:1.64 Mon May 20 16:38:39 2002 +++ phpdoc/en/functions/imap.xml Wed May 7 17:31:29 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.64 $ --> +<!-- $Revision: 1.65 $ --> <reference id='ref.imap'> <title>IMAP, POP3 and NNTP functions</title> <titleabbrev>IMAP</titleabbrev> @@ -42,47 +42,47 @@ <itemizedlist> <listitem> <simpara> - <ulink url="&url.rfc;rfc2821.html">RFC2821</ulink>: Simple Mail + <ulink url="&url.rfc;2821">RFC2821</ulink>: Simple Mail Transfer Protocol (SMTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink>: Standard for + <ulink url="&url.rfc;2822">RFC2822</ulink>: Standard for ARPA internet text messages. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>: Internet + <ulink url="&url.rfc;2060">RFC2060</ulink>: Internet Message Access Protocol (IMAP) Version 4rev1. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc1939.html">RFC1939</ulink>: Post + <ulink url="&url.rfc;1939">RFC1939</ulink>: Post Office Protocol Version 3 (POP3). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc977.html">RFC977</ulink>: Network News + <ulink url="&url.rfc;977">RFC977</ulink>: Network News Transfer Protocol (NNTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2076.html">RFC2076</ulink>: Common + <ulink url="&url.rfc;2076">RFC2076</ulink>: Common Internet Message Headers. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink> , <ulink - url="&url.rfc;rfc2046.html">RFC2046</ulink> , <ulink - url="&url.rfc;rfc2047.html">RFC2047</ulink> , <ulink - url="&url.rfc;rfc2048.html">RFC2048</ulink> & <ulink - url="&url.rfc;rfc2049.html">RFC2049</ulink>: Multipurpose + <ulink url="&url.rfc;2045">RFC2045</ulink> , <ulink + url="&url.rfc;2046">RFC2046</ulink> , <ulink + url="&url.rfc;2047">RFC2047</ulink> , <ulink + url="&url.rfc;2048">RFC2048</ulink> & <ulink + url="&url.rfc;2049">RFC2049</ulink>: Multipurpose Internet Mail Extensions (MIME). </simpara> </listitem> @@ -109,7 +109,7 @@ </methodsynopsis> <para> Convert an 8bit string to a quoted-printable string (according to - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> @@ -219,7 +219,7 @@ </methodsynopsis> <para> <function>imap_base64</function> function decodes BASE-64 encoded - text (see <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, + text (see <ulink url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). The decoded message is returned as a string. </para> <para> @@ -243,7 +243,7 @@ </methodsynopsis> <para> Convert an 8bit string to a base64 string (according to <ulink - url="&url.rfc;rfc2045.html">RFC2045</ulink>, Section 6.8). + url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). </para> <para> Returns a base64 string. @@ -841,7 +841,7 @@ </methodsynopsis> <para> This function causes a fetch of the complete, unfiltered - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> format header of the specified message as a text string and returns that text string. </para> @@ -1551,7 +1551,7 @@ Copies mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask of one or more of @@ -1590,7 +1590,7 @@ Moves mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask and may contain the single option @@ -1721,7 +1721,7 @@ <para> <function>imap_mime_header_decode</function> function decodes MIME message header extensions that are non ASCII text - (see <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink>) + (see <ulink url="&url.rfc;2047">RFC2047</ulink>) The decoded elements are returned in an array of objects, where each object has two properties, "charset" & "text". If the element hasn't been encoded, and in other words is in @@ -2031,7 +2031,7 @@ </methodsynopsis> <para> Convert a quoted-printable string to an 8 bit string (according - to <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + to <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> @@ -2140,7 +2140,7 @@ </methodsynopsis> <para> This function parses the address string as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> and + <ulink url="&url.rfc;2822">RFC2822</ulink> and for each address, returns an array of objects. The objects properties are: </para> @@ -2229,7 +2229,7 @@ </methodsynopsis> <para> Returns a properly formatted email address as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> given the mailbox, host, and personal info. </para> <para> @@ -2822,9 +2822,9 @@ not valid modified UTF-7. This function is needed to decode mailbox names that contain international characters outside of the printable ASCII range. The modified UTF-7 encoding is defined - in <ulink url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section + in <ulink url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> </refsect1> </refentry> @@ -2847,9 +2847,9 @@ text. This is needed to encode mailbox names that contain international characters outside of the printable ASCII range. The modified UTF-7 encoding is defined in <ulink - url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section 5.1.3 + url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> <para> Returns the modified UTF-7 text. @@ -2873,7 +2873,7 @@ <para> Converts the given <parameter>text</parameter> to UTF8 (as defined in - <ulink url="&url.rfc;rfc2044.html">RFC2044</ulink>). + <ulink url="&url.rfc;2044">RFC2044</ulink>). </para> </refsect1> </refentry> Index: phpdoc/en/functions/mail.xml diff -u phpdoc/en/functions/mail.xml:1.40 phpdoc/en/functions/mail.xml:1.41 --- phpdoc/en/functions/mail.xml:1.40 Fri Aug 16 21:13:10 2002 +++ phpdoc/en/functions/mail.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.40 $ --> +<!-- $Revision: 1.41 $ --> <reference id="ref.mail"> <title>Mail functions</title> <titleabbrev>Mail</titleabbrev> @@ -102,12 +102,12 @@ </simpara> <simpara> The following RFC's may also be useful: - <ulink url="&url.rfc1896;">RFC 1896</ulink>, - <ulink url="&url.rfc2045;">RFC 2045</ulink>, - <ulink url="&url.rfc2046;">RFC 2046</ulink>, - <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and - <ulink url="&url.rfc2049;">RFC 2049</ulink>. + <ulink url="&url.rfc;1896">RFC 1896</ulink>, + <ulink url="&url.rfc;2045">RFC 2045</ulink>, + <ulink url="&url.rfc;2046">RFC 2046</ulink>, + <ulink url="&url.rfc;2047">RFC 2047</ulink>, + <ulink url="&url.rfc;2048">RFC 2048</ulink>, and + <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> <function>mail</function> returns &true; if the mail Index: phpdoc/en/functions/strings.xml diff -u phpdoc/en/functions/strings.xml:1.172 phpdoc/en/functions/strings.xml:1.173 --- phpdoc/en/functions/strings.xml:1.172 Sat May 11 03:02:28 2002 +++ phpdoc/en/functions/strings.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.172 $ --> +<!-- $Revision: 1.173 $ --> <reference id="ref.strings"> <title>String functions</title> <titleabbrev>Strings</titleabbrev> @@ -1480,7 +1480,7 @@ </methodsynopsis> <para> Calculates the MD5 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. </para> @@ -1504,7 +1504,7 @@ <para> Calculates the MD5 hash of the specified <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. </para> <para> Index: phpdoc/en/functions/zlib.xml diff -u phpdoc/en/functions/zlib.xml:1.27 phpdoc/en/functions/zlib.xml:1.28 --- phpdoc/en/functions/zlib.xml:1.27 Wed Apr 17 15:58:46 2002 +++ phpdoc/en/functions/zlib.xml Wed May 7 17:31:30 2003 @@ -8,7 +8,7 @@ instead --> <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.27 $ --> +<!-- $Revision: 1.28 $ --> <reference id="ref.zlib"> <title>Zlib Compression Functions</title> <titleabbrev>Zlib</titleabbrev> @@ -606,7 +606,7 @@ </para> <para> For details on the ZLIB compression algorithm see the document - "<ulink url="&url.rfc1950;">ZLIB Compressed Data Format + "<ulink url="&url.rfc;1950">ZLIB Compressed Data Format Specification version 3.3</ulink>" (RFC 1950). </para> <note> @@ -675,7 +675,7 @@ </para> <para> For details on the DEFLATE compression algorithm see the document - "<ulink url="&url.rfc1951;">DEFLATE Compressed Data Format + "<ulink url="&url.rfc;1951">DEFLATE Compressed Data Format Specification version 1.3</ulink>" (RFC 1951). </para> <para> @@ -775,7 +775,7 @@ </para> <para> For more information on the GZIP file format, see the document: - <ulink url="&url.rfc1952;">GZIP file format specification + <ulink url="&url.rfc;1952">GZIP file format specification version 4.3</ulink> (RFC 1952). </para> <para> Index: phpdoc/en/reference/http/functions/header.xml diff -u phpdoc/en/reference/http/functions/header.xml:1.12 phpdoc/en/reference/http/functions/header.xml:1.13 --- phpdoc/en/reference/http/functions/header.xml:1.12 Thu Apr 17 17:43:03 2003 +++ phpdoc/en/reference/http/functions/header.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> +<!-- $Revision: 1.13 $ --> <!-- splitted from ./en/functions/http.xml, last change in rev 1.2 --> <refentry id="function.header"> <refnamediv> @@ -196,7 +196,7 @@ <para> If you want the user to be prompted to save the data you are sending, such as a generated PDF file, you can use the <ulink - url="&url.rfc2183;">Content-Disposition</ulink> header to + url="&url.rfc;2183">Content-Disposition</ulink> header to supply a recommended filename and force the browser to display the save dialog. <informalexample> Index: phpdoc/en/reference/imap/reference.xml diff -u phpdoc/en/reference/imap/reference.xml:1.11 phpdoc/en/reference/imap/reference.xml:1.12 --- phpdoc/en/reference/imap/reference.xml:1.11 Mon Jan 20 16:41:12 2003 +++ phpdoc/en/reference/imap/reference.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.11 $ --> +<!-- $Revision: 1.12 $ --> <reference id='ref.imap'> <title>IMAP, POP3 and NNTP functions</title> <titleabbrev>IMAP</titleabbrev> @@ -72,47 +72,47 @@ <itemizedlist> <listitem> <simpara> - <ulink url="&url.rfc;rfc2821.html">RFC2821</ulink>: Simple Mail + <ulink url="&url.rfc;2821">RFC2821</ulink>: Simple Mail Transfer Protocol (SMTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink>: Standard for + <ulink url="&url.rfc;2822">RFC2822</ulink>: Standard for ARPA internet text messages. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>: Internet + <ulink url="&url.rfc;2060">RFC2060</ulink>: Internet Message Access Protocol (IMAP) Version 4rev1. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc1939.html">RFC1939</ulink>: Post + <ulink url="&url.rfc;1939">RFC1939</ulink>: Post Office Protocol Version 3 (POP3). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc977.html">RFC977</ulink>: Network News + <ulink url="&url.rfc;977">RFC977</ulink>: Network News Transfer Protocol (NNTP). </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2076.html">RFC2076</ulink>: Common + <ulink url="&url.rfc;2076">RFC2076</ulink>: Common Internet Message Headers. </simpara> </listitem> <listitem> <simpara> - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink> , <ulink - url="&url.rfc;rfc2046.html">RFC2046</ulink> , <ulink - url="&url.rfc;rfc2047.html">RFC2047</ulink> , <ulink - url="&url.rfc;rfc2048.html">RFC2048</ulink> & <ulink - url="&url.rfc;rfc2049.html">RFC2049</ulink>: Multipurpose + <ulink url="&url.rfc;2045">RFC2045</ulink> , <ulink + url="&url.rfc;2046">RFC2046</ulink> , <ulink + url="&url.rfc;2047">RFC2047</ulink> , <ulink + url="&url.rfc;2048">RFC2048</ulink> & <ulink + url="&url.rfc;2049">RFC2049</ulink>: Multipurpose Internet Mail Extensions (MIME). </simpara> </listitem> Index: phpdoc/en/reference/imap/functions/imap-8bit.xml diff -u phpdoc/en/reference/imap/functions/imap-8bit.xml:1.2 phpdoc/en/reference/imap/functions/imap-8bit.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-8bit.xml:1.2 Wed Apr 17 02:39:15 2002 +++ phpdoc/en/reference/imap/functions/imap-8bit.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-8bit"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> Convert an 8bit string to a quoted-printable string (according to - <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> Index: phpdoc/en/reference/imap/functions/imap-base64.xml diff -u phpdoc/en/reference/imap/functions/imap-base64.xml:1.2 phpdoc/en/reference/imap/functions/imap-base64.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-base64.xml:1.2 Wed Apr 17 02:39:16 2002 +++ phpdoc/en/reference/imap/functions/imap-base64.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-base64"> <refnamediv> @@ -14,7 +14,7 @@ </methodsynopsis> <para> <function>imap_base64</function> function decodes BASE-64 encoded - text (see <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, + text (see <ulink url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). The decoded message is returned as a string. </para> <para> Index: phpdoc/en/reference/imap/functions/imap-binary.xml diff -u phpdoc/en/reference/imap/functions/imap-binary.xml:1.2 phpdoc/en/reference/imap/functions/imap-binary.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-binary.xml:1.2 Wed Apr 17 02:39:16 2002 +++ phpdoc/en/reference/imap/functions/imap-binary.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-binary"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> Convert an 8bit string to a base64 string (according to <ulink - url="&url.rfc;rfc2045.html">RFC2045</ulink>, Section 6.8). + url="&url.rfc;2045">RFC2045</ulink>, Section 6.8). </para> <para> Returns a base64 string. Index: phpdoc/en/reference/imap/functions/imap-fetchheader.xml diff -u phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.3 phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-fetchheader.xml:1.3 Wed Oct 9 10:55:05 2002 +++ phpdoc/en/reference/imap/functions/imap-fetchheader.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-fetchheader"> <refnamediv> @@ -16,7 +16,7 @@ </methodsynopsis> <para> This function causes a fetch of the complete, unfiltered - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> format header of the specified message as a text string and returns that text string. </para> Index: phpdoc/en/reference/imap/functions/imap-mail-copy.xml diff -u phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.3 phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-mail-copy.xml:1.3 Wed Oct 9 10:55:05 2002 +++ phpdoc/en/reference/imap/functions/imap-mail-copy.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-mail-copy"> <refnamediv> @@ -22,7 +22,7 @@ Copies mail messages specified by <parameter>msglist</parameter> to specified mailbox. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> Flags is a bitmask of one or more of Index: phpdoc/en/reference/imap/functions/imap-mail-move.xml diff -u phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.4 phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.5 --- phpdoc/en/reference/imap/functions/imap-mail-move.xml:1.4 Wed Feb 5 22:08:22 2003 +++ phpdoc/en/reference/imap/functions/imap-mail-move.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-mail-move"> <refnamediv> @@ -19,7 +19,7 @@ Moves mail messages specified by <parameter>msglist</parameter> to specified mailbox <parameter>mbox</parameter>. <parameter>msglist</parameter> is a range not just message numbers (as described in - <ulink url="&url.rfc;rfc2060.html">RFC2060</ulink>). + <ulink url="&url.rfc;2060">RFC2060</ulink>). </para> <para> &return.success; Index: phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml diff -u phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.2 phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml:1.2 Wed Apr 17 02:39:20 2002 +++ phpdoc/en/reference/imap/functions/imap-mime-header-decode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.33 --> <refentry id="function.imap-mime-header-decode"> <refnamediv> @@ -15,7 +15,7 @@ <para> <function>imap_mime_header_decode</function> function decodes MIME message header extensions that are non ASCII text - (see <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink>) + (see <ulink url="&url.rfc;2047">RFC2047</ulink>) The decoded elements are returned in an array of objects, where each object has two properties, "charset" & "text". If the element hasn't been encoded, and in other words is in Index: phpdoc/en/reference/imap/functions/imap-qprint.xml diff -u phpdoc/en/reference/imap/functions/imap-qprint.xml:1.2 phpdoc/en/reference/imap/functions/imap-qprint.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-qprint.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-qprint.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-qprint"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> Convert a quoted-printable string to an 8 bit string (according - to <ulink url="&url.rfc;rfc2045.html">RFC2045</ulink>, section + to <ulink url="&url.rfc;2045">RFC2045</ulink>, section 6.7). </para> <para> Index: phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml diff -u phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.2 phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-rfc822-parse-adrlist.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-rfc822-parse-adrlist"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> This function parses the address string as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> and + <ulink url="&url.rfc;2822">RFC2822</ulink> and for each address, returns an array of objects. The objects properties are: </para> Index: phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml diff -u phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.2 phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.3 --- phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml:1.2 Wed Apr 17 02:39:21 2002 +++ phpdoc/en/reference/imap/functions/imap-rfc822-write-address.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.2 --> <refentry id="function.imap-rfc822-write-address"> <refnamediv> @@ -19,7 +19,7 @@ </methodsynopsis> <para> Returns a properly formatted email address as defined in - <ulink url="&url.rfc;rfc2822.html">RFC2822</ulink> + <ulink url="&url.rfc;2822">RFC2822</ulink> given the mailbox, host, and personal info. </para> <para> Index: phpdoc/en/reference/imap/functions/imap-utf7-decode.xml diff -u phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.3 phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-utf7-decode.xml:1.3 Mon Mar 31 15:25:57 2003 +++ phpdoc/en/reference/imap/functions/imap-utf7-decode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.16 --> <refentry id="function.imap-utf7-decode"> <refnamediv> @@ -26,9 +26,9 @@ This function is needed to decode mailbox names that contain certain characters which are not in range of printable ASCII characters. The modified UTF-7 encoding is defined in - <ulink url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section + <ulink url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> </refsect1> </refentry> Index: phpdoc/en/reference/imap/functions/imap-utf7-encode.xml diff -u phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.4 phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.5 --- phpdoc/en/reference/imap/functions/imap-utf7-encode.xml:1.4 Mon Mar 31 15:27:58 2003 +++ phpdoc/en/reference/imap/functions/imap-utf7-encode.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.9 --> <refentry id="function.imap-utf7-encode"> <refnamediv> @@ -20,9 +20,9 @@ characters which are not in range of printable ASCII characters. Note that <parameter>data</parameter> is expected to be encoded in ISO-8859-1. The modified UTF-7 encoding is defined in <ulink - url="&url.rfc;rfc2060.html">RFC 2060</ulink>, section 5.1.3 + url="&url.rfc;2060">RFC 2060</ulink>, section 5.1.3 (original UTF-7 was defned in <ulink - url="&url.rfc;rfc1642.html">RFC1642</ulink>). + url="&url.rfc;1642">RFC1642</ulink>). </para> <para> Returns the modified UTF-7 text. Index: phpdoc/en/reference/imap/functions/imap-utf8.xml diff -u phpdoc/en/reference/imap/functions/imap-utf8.xml:1.3 phpdoc/en/reference/imap/functions/imap-utf8.xml:1.4 --- phpdoc/en/reference/imap/functions/imap-utf8.xml:1.3 Mon Mar 31 15:25:57 2003 +++ phpdoc/en/reference/imap/functions/imap-utf8.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/imap.xml, last change in rev 1.7 --> <refentry id="function.imap-utf8"> <refnamediv> @@ -19,8 +19,8 @@ <para> Converts the given <parameter>mime_encoded_text</parameter> to UTF-8. MIME encoding method and the UTF-8 specification are described in - <ulink url="&url.rfc;rfc2047.html">RFC2047</ulink> and - <ulink url="&url.rfc;rfc2044.html">RFC2044</ulink> respectively. + <ulink url="&url.rfc;2047">RFC2047</ulink> and + <ulink url="&url.rfc;2044">RFC2044</ulink> respectively. </para> </refsect1> </refentry> Index: phpdoc/en/reference/mail/functions/mail.xml diff -u phpdoc/en/reference/mail/functions/mail.xml:1.15 phpdoc/en/reference/mail/functions/mail.xml:1.16 --- phpdoc/en/reference/mail/functions/mail.xml:1.15 Tue Apr 29 05:53:11 2003 +++ phpdoc/en/reference/mail/functions/mail.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.15 $ --> +<!-- $Revision: 1.16 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> @@ -30,12 +30,12 @@ </simpara> <simpara> The following RFC's may also be useful: - <ulink url="&url.rfc1896;">RFC 1896</ulink>, - <ulink url="&url.rfc2045;">RFC 2045</ulink>, - <ulink url="&url.rfc2046;">RFC 2046</ulink>, - <ulink url="&url.rfc2047;">RFC 2047</ulink>, - <ulink url="&url.rfc2048;">RFC 2048</ulink>, and - <ulink url="&url.rfc2049;">RFC 2049</ulink>. + <ulink url="&url.rfc;1896">RFC 1896</ulink>, + <ulink url="&url.rfc;2045">RFC 2045</ulink>, + <ulink url="&url.rfc;2046">RFC 2046</ulink>, + <ulink url="&url.rfc;2047">RFC 2047</ulink>, + <ulink url="&url.rfc;2048">RFC 2048</ulink>, and + <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> <function>mail</function> returns &true; if the mail was successfully Index: phpdoc/en/reference/network/functions/dns-get-record.xml diff -u phpdoc/en/reference/network/functions/dns-get-record.xml:1.12 phpdoc/en/reference/network/functions/dns-get-record.xml:1.13 --- phpdoc/en/reference/network/functions/dns-get-record.xml:1.12 Tue May 6 19:26:33 2003 +++ phpdoc/en/reference/network/functions/dns-get-record.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> +<!-- $Revision: 1.13 $ --> <refentry id="function.dns-get-record"> <refnamediv> <refname>dns_get_record</refname> @@ -209,7 +209,7 @@ <parameter>targets</parameter> should be chosen at random. <literal>target</literal> and <literal>port</literal>: hostname and port where the requested service can be found. - For additional information see: <ulink url="&url.rfc2782;">RFC 2782</ulink> + For additional information see: <ulink url="&url.rfc;2782">RFC 2782</ulink> </entry> </row> <row> @@ -219,7 +219,7 @@ <parameter>pri</parameter> and <parameter>weight</parameter> above. <literal>flags</literal>, <literal>services</literal>, <literal>regex</literal>, and <literal>replacement</literal>: Parameters as defined by - <ulink url="&url.rfc2915;">RFC 2915</ulink>. + <ulink url="&url.rfc;2915">RFC 2915</ulink>. </entry> </row> </tbody> Index: phpdoc/en/reference/network/functions/getmxrr.xml diff -u phpdoc/en/reference/network/functions/getmxrr.xml:1.6 phpdoc/en/reference/network/functions/getmxrr.xml:1.7 --- phpdoc/en/reference/network/functions/getmxrr.xml:1.6 Tue May 6 18:46:02 2003 +++ phpdoc/en/reference/network/functions/getmxrr.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.6 $ --> +<!-- $Revision: 1.7 $ --> <!-- splitted from ./en/functions/network.xml, last change in rev 1.2 --> <refentry id="function.getmxrr"> <refnamediv> @@ -33,7 +33,7 @@ <simpara> This function should not be used for the purposes of address verification. Only the mailexchangers found in DNS are returned, - however, according to <ulink url="&url.rfc2821;">RFC 2821</ulink> + however, according to <ulink url="&url.rfc;2821">RFC 2821</ulink> when no mail exchangers are listed, <parameter>hostname</parameter> itself should be used as the only mail exchanger with a priority of <literal>0</literal>. Index: phpdoc/en/reference/recode/reference.xml diff -u phpdoc/en/reference/recode/reference.xml:1.6 phpdoc/en/reference/recode/reference.xml:1.7 --- phpdoc/en/reference/recode/reference.xml:1.6 Mon Dec 2 07:55:39 2002 +++ phpdoc/en/reference/recode/reference.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.6 $ --> +<!-- $Revision: 1.7 $ --> <reference id="ref.recode"> <title>GNU Recode functions</title> <titleabbrev>Recode</titleabbrev> @@ -15,7 +15,7 @@ fall back on approximations. The library recognises or produces nearly 150 different character sets and is able to convert files between almost any pair. - Most <ulink url="&url.rfc;rfc1345.html">RFC 1345</ulink> character sets + Most <ulink url="&url.rfc;1345">RFC 1345</ulink> character sets are supported. </para> ¬e.no-windows.extension; Index: phpdoc/en/reference/strings/functions/chunk-split.xml diff -u phpdoc/en/reference/strings/functions/chunk-split.xml:1.3 phpdoc/en/reference/strings/functions/chunk-split.xml:1.4 --- phpdoc/en/reference/strings/functions/chunk-split.xml:1.3 Tue Jul 30 05:26:16 2002 +++ phpdoc/en/reference/strings/functions/chunk-split.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.2 --> <refentry id="function.chunk-split"> <refnamediv> @@ -35,7 +35,7 @@ <simpara> See also <function>explode</function>, <function>split</function> <function>wordwrap</function> and - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink>. + <ulink url="&url.rfc;2045">RFC 2045</ulink>. </simpara> </refsect1> </refentry> Index: phpdoc/en/reference/strings/functions/md5-file.xml diff -u phpdoc/en/reference/strings/functions/md5-file.xml:1.4 phpdoc/en/reference/strings/functions/md5-file.xml:1.5 --- phpdoc/en/reference/strings/functions/md5-file.xml:1.4 Thu Feb 20 05:54:32 2003 +++ phpdoc/en/reference/strings/functions/md5-file.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.2 --> <refentry id="function.md5-file"> <refnamediv> @@ -16,7 +16,7 @@ <para> Calculates the MD5 hash of the specified <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the md5 digest Index: phpdoc/en/reference/strings/functions/md5.xml diff -u phpdoc/en/reference/strings/functions/md5.xml:1.5 phpdoc/en/reference/strings/functions/md5.xml:1.6 --- phpdoc/en/reference/strings/functions/md5.xml:1.5 Thu Feb 20 05:54:32 2003 +++ phpdoc/en/reference/strings/functions/md5.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.5 $ --> +<!-- $Revision: 1.6 $ --> <!-- splitted from ./en/functions/strings.xml, last change in rev 1.135 --> <refentry id="function.md5"> <refnamediv> @@ -15,7 +15,7 @@ </methodsynopsis> <para> Calculates the MD5 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc1321.html">RSA Data Security, Inc. + <ulink url="&url.rfc;1321">RSA Data Security, Inc. MD5 Message-Digest Algorithm</ulink>, and returns that hash. The hash is a 32-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the md5 digest Index: phpdoc/en/reference/strings/functions/sha1-file.xml diff -u phpdoc/en/reference/strings/functions/sha1-file.xml:1.3 phpdoc/en/reference/strings/functions/sha1-file.xml:1.4 --- phpdoc/en/reference/strings/functions/sha1-file.xml:1.3 Thu Feb 20 05:57:56 2003 +++ phpdoc/en/reference/strings/functions/sha1-file.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <refentry id="function.sha1-file"> <refnamediv> <refname>sha1_file</refname> @@ -14,7 +14,7 @@ </methodsynopsis> <simpara> Calculates the sha1 hash of <parameter>filename</parameter> using the - <ulink url="&url.rfc;rfc3174.html">US Secure Hash Algorithm 1</ulink>, + <ulink url="&url.rfc;3174">US Secure Hash Algorithm 1</ulink>, and returns that hash. The hash is a 40-character hexadecimal number. Upon failure, &false; is returned. If the optional <parameter>raw_output</parameter> is set to &true;, then the sha1 digest Index: phpdoc/en/reference/strings/functions/sha1.xml diff -u phpdoc/en/reference/strings/functions/sha1.xml:1.4 phpdoc/en/reference/strings/functions/sha1.xml:1.5 --- phpdoc/en/reference/strings/functions/sha1.xml:1.4 Thu Feb 20 05:57:56 2003 +++ phpdoc/en/reference/strings/functions/sha1.xml Wed May 7 17:31:30 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.4 $ --> +<!-- $Revision: 1.5 $ --> <refentry id="function.sha1"> <refnamediv> <refname>sha1</refname> @@ -14,7 +14,7 @@ </methodsynopsis> <simpara> Calculates the sha1 hash of <parameter>str</parameter> using the - <ulink url="&url.rfc;rfc3174.html">US Secure Hash Algorithm 1</ulink>, + <ulink url="&url.rfc;3174">US Secure Hash Algorithm 1</ulink>, and returns that hash. The hash is a 40-character hexadecimal number. If the optional <parameter>raw_output</parameter> is set to &true;, then the sha1 digest is instead returned in raw binary format with a Index: phpdoc/en/reference/url/functions/base64-decode.xml diff -u phpdoc/en/reference/url/functions/base64-decode.xml:1.3 phpdoc/en/reference/url/functions/base64-decode.xml:1.4 --- phpdoc/en/reference/url/functions/base64-decode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/base64-decode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.2 --> <refentry id="function.base64-decode"> <refnamediv> @@ -19,7 +19,7 @@ </para> <para> See also: <function>base64_encode</function>, - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink> section 6.8. + <ulink url="&url.rfc;2045">RFC 2045</ulink> section 6.8. </para> </refsect1> </refentry> Index: phpdoc/en/reference/url/functions/base64-encode.xml diff -u phpdoc/en/reference/url/functions/base64-encode.xml:1.3 phpdoc/en/reference/url/functions/base64-encode.xml:1.4 --- phpdoc/en/reference/url/functions/base64-encode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/base64-encode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.2 --> <refentry id="function.base64-encode"> <refnamediv> @@ -25,7 +25,7 @@ See also: <function>base64_decode</function>, <function>chunk_split</function>, - <ulink url="&url.rfc;rfc2045.html">RFC 2045</ulink> section 6.8. + <ulink url="&url.rfc;2045">RFC 2045</ulink> section 6.8. </para> </refsect1> </refentry> Index: phpdoc/en/reference/url/functions/rawurlencode.xml diff -u phpdoc/en/reference/url/functions/rawurlencode.xml:1.3 phpdoc/en/reference/url/functions/rawurlencode.xml:1.4 --- phpdoc/en/reference/url/functions/rawurlencode.xml:1.3 Tue Jul 30 05:25:35 2002 +++ phpdoc/en/reference/url/functions/rawurlencode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.3 $ --> +<!-- $Revision: 1.4 $ --> <!-- splitted from ./en/functions/url.xml, last change in rev 1.6 --> <refentry id="function.rawurlencode"> <refnamediv> @@ -47,7 +47,7 @@ See also <function>rawurldecode</function>, <function>urldecode</function>, <function>urlencode</function> and - <ulink url="&url.rfc;rfc1738.html">RFC 1738</ulink> + <ulink url="&url.rfc;1738">RFC 1738</ulink> </simpara> </refsect1> </refentry> Index: phpdoc/en/reference/zlib/functions/gzcompress.xml diff -u phpdoc/en/reference/zlib/functions/gzcompress.xml:1.2 phpdoc/en/reference/zlib/functions/gzcompress.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzcompress.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzcompress.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.4 --> <refentry id="function.gzcompress"> <refnamediv> @@ -22,7 +22,7 @@ </para> <para> For details on the ZLIB compression algorithm see the document - "<ulink url="&url.rfc1950;">ZLIB Compressed Data Format + "<ulink url="&url.rfc;1950">ZLIB Compressed Data Format Specification version 3.3</ulink>" (RFC 1950). </para> <note> Index: phpdoc/en/reference/zlib/functions/gzdeflate.xml diff -u phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.2 phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzdeflate.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzdeflate.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.11 --> <refentry id="function.gzdeflate"> <refnamediv> @@ -22,7 +22,7 @@ </para> <para> For details on the DEFLATE compression algorithm see the document - "<ulink url="&url.rfc1951;">DEFLATE Compressed Data Format + "<ulink url="&url.rfc;1951">DEFLATE Compressed Data Format Specification version 1.3</ulink>" (RFC 1951). </para> <para> Index: phpdoc/en/reference/zlib/functions/gzencode.xml diff -u phpdoc/en/reference/zlib/functions/gzencode.xml:1.2 phpdoc/en/reference/zlib/functions/gzencode.xml:1.3 --- phpdoc/en/reference/zlib/functions/gzencode.xml:1.2 Wed Apr 17 02:45:32 2002 +++ phpdoc/en/reference/zlib/functions/gzencode.xml Wed May 7 17:31:31 2003 @@ -1,5 +1,5 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.2 $ --> +<!-- $Revision: 1.3 $ --> <!-- splitted from ./en/functions/zlib.xml, last change in rev 1.4 --> <refentry id="function.gzencode"> <refnamediv> @@ -59,7 +59,7 @@ </para> <para> For more information on the GZIP file format, see the document: - <ulink url="&url.rfc1952;">GZIP file format specification + <ulink url="&url.rfc;1952">GZIP file format specification version 4.3</ulink> (RFC 1952). </para> <para> Index: phpdoc/entities/global.ent diff -u phpdoc/entities/global.ent:1.101 phpdoc/entities/global.ent:1.102 --- phpdoc/entities/global.ent:1.101 Tue May 6 19:51:48 2003 +++ phpdoc/entities/global.ent Wed May 7 17:31:31 2003 @@ -1,6 +1,6 @@ <!-- -*- SGML -*- - $Id: global.ent,v 1.101 2003/05/06 23:51:48 joey Exp $ + $Id: global.ent,v 1.102 2003/05/07 21:31:31 joey Exp $ Contains global "macros" for all the XML documents. @@ -223,6 +223,7 @@ <!ENTITY url.redhat.support "http://redhat.com/docs/manuals/ccvs/"> <!ENTITY url.redhat.mcve "http://www.mcve.com/"> <!ENTITY url.rfc 'http://www.faqs.org/rfcs/rfc'> +<!-- To link to an RFC, you can use &url.rfc;####, where #### is the RFC number <!ENTITY url.rfc1896 'http://www.ietf.org/rfc/rfc1896.txt'> <!ENTITY url.rfc1950 'http://www.ietf.org/rfc/rfc1950.txt'> <!ENTITY url.rfc1951 'http://www.ietf.org/rfc/rfc1951.txt'> @@ -237,6 +238,7 @@ <!ENTITY url.rfc2782 'http://www.ietf.org/rfc/rfc2782.txt'> <!ENTITY url.rfc2821 'http://www.ietf.org/rfc/rfc2821.txt'> <!ENTITY url.rfc2915 'http://www.ietf.org/rfc/rfc2915.txt'> +--> <!ENTITY url.iana.system-names 'http://www.iana.org/assignments/operating-system-names'> <!ENTITY url.rpmfind "http://www.rpmfind.net/"> <!ENTITY url.sablotron "http://www.gingerall.com/">