#24102 [Opn->Csd]: log_errors_max_len default wrong in doc
| From: | derick@php.net | Date: | Mon, 09 Jun 2003 20:41:56 +0000 |
| Subject: | #24102 [Opn->Csd]: log_errors_max_len default wrong in doc | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969354367@lists.php.net to get a copy of this message | ||
ID: 24102
Updated by: derick@php.net
Reported By: kop at meme dot com
-Status: Open
+Status: Closed
Bug Type: Documentation problem
Operating System: RH 7.3
PHP Version: 4.3.2
New Comment:
The unit was wrong, it should have been bytes. I fixed it in the
documentation and it should show up at the next doc build.
Previous Comments:
------------------------------------------------------------------------
[2003-06-09 15:30:55] kop at meme dot com
The documentation on "error handling and reporting functions" says that
the default value for log_errors_max_len is 1024 and that the units are
Kbytes.
A 1 MB default sounds wrong. I tried using trigger_error to send a
large log messsage and it got truncated to (about) 1K. So, either the
documented default or the documented units are wrong. (If it's the
default value, don't forget to change the ini_set() documentation
too.)
This script tested with php 4.1.2. (And I don't see log_errors_max_len
in php_info() output so I'm not inclined to muck about changing the
config to see what the units are.)
trigger_error("AAAAAAAAAAAAAAAAAAAAAAAAaaaaa
Reeeeeeeeeeeeeeeeeeeeeaaaaaaaaaaaa\aaaaaallllllllllllllllllllllllllyyyyyyyyyyyyyyyyyyyyyy lllllllllllllllllllllllo\ooooooooooooooooooooonnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnnggggggggggggggggggggg
eeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee\eeeeeeeeeerror message to
test the log limit.");
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=24102&edit=1