cvs: phpdoc /en/reference/mail/functions ezmlm-hash.xml mail.xml
| From: | Derick Rethans | Date: | Sun, 20 Jul 2003 08:02:20 +0000 |
| Subject: | cvs: phpdoc /en/reference/mail/functions ezmlm-hash.xml mail.xml | ||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969355386@lists.php.net to get a copy of this message | ||
derick Sun Jul 20 04:02:20 2003 EDT
Modified files:
/phpdoc/en/reference/mail/functions ezmlm-hash.xml mail.xml
Log:
- Reverting Greek in the English tree
Index: phpdoc/en/reference/mail/functions/ezmlm-hash.xml diff -u phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.10 phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.11 --- phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.10 Sat Jul 19 20:09:10 2003 +++ phpdoc/en/reference/mail/functions/ezmlm-hash.xml Sun Jul 20 04:02:20 2003 @@ -1,25 +1,24 @@ -<?xml version="1.0" encoding="iso-8859-7"?> -<!-- $Revision: 1.10 $ --> -<!-- En-Revision: 1.9 Maintainer: legionnaire Status: ready --> +<?xml version="1.0" encoding="iso-8859-1"?> +<!-- $Revision: 1.11 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.6 --> <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> - <refpurpose>Õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé áðü ôï EZMLM</refpurpose> + <refpurpose>Calculate the hash value needed by EZMLM</refpurpose> </refnamediv> <refsect1> - <title>ÐåñéãñáöÞ</title> + <title>Description</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> <methodparam><type>string</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> - Ç <function>ezmlm_hash</function> õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé - êáôÜ ôçí äéáôÞñçóç EZMLM mailing lists óå ìéá MySQL database. + <function>ezmlm_hash</function> calculates the hash value needed + when keeping EZMLM mailing lists in a MySQL database. </simpara> <para> <example> - <title>Õðïëïãßæïíôáò ôï hash êáé åããñÜöïíôáò Ýíá ÷ñÞóôç</title> + <title>Calculating the hash and subscribing a user</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; Index: phpdoc/en/reference/mail/functions/mail.xml diff -u phpdoc/en/reference/mail/functions/mail.xml:1.18 phpdoc/en/reference/mail/functions/mail.xml:1.19 --- phpdoc/en/reference/mail/functions/mail.xml:1.18 Sat Jul 19 20:09:10 2003 +++ phpdoc/en/reference/mail/functions/mail.xml Sun Jul 20 04:02:20 2003 @@ -1,14 +1,13 @@ -<?xml version="1.0" encoding="iso-8859-7"?> -<!-- $Revision: 1.18 $ --> -<!-- En-Revision: 1.17 Maintainer: legionnaire Status: ready --> +<?xml version="1.0" encoding="iso-8859-1"?> +<!-- $Revision: 1.19 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> - <refpurpose>ÁðïóôïëÞ mail</refpurpose> + <refpurpose>send mail</refpurpose> </refnamediv> <refsect1> - <title>ÐåñéãñáöÞ</title> + <title>Description</title> <methodsynopsis> <type>bool</type><methodname>mail</methodname> <methodparam><type>string</type><parameter>to</parameter></methodparam> @@ -18,19 +17,19 @@ <methodparam choice="opt"><type>string</type><parameter>additional_parameters</parameter></methodparam> </methodsynopsis> <simpara> - Ç <function>mail</function> áõôïìÜôá óôÝëíåé ìå mail ôï ìÞíõìá - üðùò ïñßæåôáé óôï <parameter>message</parameter> óôïí ðáñáëÞðôç - üðùò ïñßæåôáé óôï <parameter>to</parameter>. Ðïëëáðëïß ðáñáëÞðôåò ìðïñïýí - íá ïñéóôïýí ìå ôçí ðñïóèÞêç åíüò êüììáôïò áíÜìåóá óå êÜèå äéåýèõíóç óôï - <parameter>to</parameter>. Email ìå óõííçìÝíá áñ÷åßá êáé åéäéêïýò - ôýðïõò ðåñéå÷ïìÝíïõ ìðïñïýí íá áðïóôáëïýí ìå ôçí ÷ñÞóç áõôÞò ôçò óõíÜñôçóçò. Áõôü ðñáãìáôïðïéåßôáé - ìÝóù MIME-êùäéêïðïßçóçò - ãéá ðåñéóóüôåñåò ðëçñïöïñßåò, äåßôå áõôü: + <function>mail</function> automatically mails the message + specified in <parameter>message</parameter> to the receiver + specified in <parameter>to</parameter>. Multiple recipients can + be specified by putting a comma between each address in + <parameter>to</parameter>. Email with attachments and special + types of content can be sent using this function. This is + accomplished via MIME-encoding - for more information, see this <ulink url="&url.email.mime.zend;"> - ôï Üñèñï Zend</ulink> Þ ôéò<ulink url="&url.email.mime.pear;"> + Zend article</ulink> or the <ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> - Ôá ðáñáêÜôù RFC's ìðïñïýí åðéóÞò íá âïçèÞóïõí: + The following RFC's may also be useful: <ulink url="&url.rfc;1896">RFC 1896</ulink>, <ulink url="&url.rfc;2045">RFC 2045</ulink>, <ulink url="&url.rfc;2046">RFC 2046</ulink>, @@ -39,29 +38,29 @@ <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> - Ç <function>mail</function> åðéóôñÝöåé &true; åÜí ôï mail ðáñáäüèçêå - åðéôõ÷þò, &false; óå áíôßèåôç ðåñßðôùóç. + <function>mail</function> returns &true; if the mail was successfully + accepted for delivery, &false; otherwise. </para> <warning> <para> - Ç åãêáôÜóôáóç óôá Windows ôçò <function>mail</function> äéáöÝñåé ðïéêéëïôñüðùò - áðü ôçí áíôßóôïé÷ç óôï UNIX. Êáôáñ÷Þí, äåí ÷ñçóéìïðïéåß Ýíá ôïðéêü binary áñ÷åßï - ãéá íá óõíèÝôåé ìçíýìáôá áëëÜ ìüíï åíåñãåß óå direct sockets ðïõ óçìáßíåé üôé Ýíá - <literal>MTA</literal> áðáéôåßôáé ðïõ èá "áêïýåé" óå Ýíá network socket (ôï ïðïßï - ìðïñåß íá åßíáé åßôå óôï localhost -ôïðéêÜ- åßôå óôï áðïìáêñõóìÝíï ìç÷Üíçìá). ¸ðåéôá, ôá custom - headers üðùò <literal>From:</literal>, <literal>Cc:</literal>, - <literal>Bcc:</literal> êáé <literal>Date:</literal> <emphasis - role="strong">äåí</emphasis> åñìçíåýïíôáé áðü ôï <literal>MTA</literal> - óôçí áñ÷Þ, áëëÜ áíáëýïíôáé áðü ôçí <literal>PHP</literal>. - Ç <literal>PHP</literal> < 4.3 õðïóôÞñéæå ìüíï ôï óôïé÷åßï header <literal>Cc:</literal> - (êáé Þôáí case-sensitive). Ç <literal>PHP</literal> >= 4.3 - õðïóôçñßæåé üëá ôá ðñïáíáöåñèÝíôá óôïé÷åßá header êáé äåí åßíáé ðëÝïí + The Windows implementation of <function>mail</function> differs in many + ways from the Unix implementation. First, it doesn't use a local binary + for composing messages but only operates on direct sockets which means a + <literal>MTA</literal> is needed listening on a network socket (which + can either on the localhost or a remote machine). Second, the custom + headers like <literal>From:</literal>, <literal>Cc:</literal>, + <literal>Bcc:</literal> and <literal>Date:</literal> are <emphasis + role="strong">not</emphasis> interpreted by the <literal>MTA</literal> + in the first place, but are parsed by <literal>PHP</literal>. + <literal>PHP</literal> < 4.3 only supported the <literal>Cc:</literal> + header element (and was case-sensitive). <literal>PHP</literal> >= 4.3 + supports all the mentioned header elements and is no longer case-sensitive. </para> </warning> <para> <example> - <title>ÓôÝëíïíôáò mail.</title> + <title>Sending mail.</title> <programlisting> <![CDATA[ <?php @@ -72,21 +71,21 @@ </example> </para> <simpara> - ÅÜí ðåñáóôåß Ýíá fourth string argument, áõôü ôï string åéóÜãåôáé óôï - ôÝëïò ôïõ header. Áõôü ÷ñçóéìïðïéåßôáé êõñßùò ãéá íá ðñïóôåèïýí åðéðëÝïí - headers. Ðïëëáðëïß åðéðëÝïí headers ÷ùñßæïíôáé ìå Ýíá return (enter) - êáé ìéá íÝá ãñáììÞ. + If a fourth string argument is passed, this string is inserted at + the end of the header. This is typically used to add extra + headers. Multiple extra headers are separated with a carriage return + and newline. </simpara> <note> <para> - ÐñÝðåé íá ÷ñçóéìïðïéåßôå ôï <literal>\r\n</literal> ãéá íá ÷ùñßæåôå ôá headers, áí êáé - êÜðïéïé Unix mail transfer agents åíäÝ÷åôáé íá äïõëåýïõí ìüíï ìå ìéÜ íÝá ãñáììÞ + You must use <literal>\r\n</literal> to separate headers, although + some Unix mail transfer agents may work with just a single newline (<literal>\n</literal>). </para> </note> <para> <example> - <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers.</title> + <title>Sending mail with extra headers.</title> <programlisting> <![CDATA[ <?php @@ -100,17 +99,17 @@ </example> </para> <para> - Ç ðáñÜìåôñïò <parameter>additional_parameters</parameter> - ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ðåñáóôåß ìéá åðéðñüóèåôç ðáñÜìåôñïò óôï ðñüãñáììá, ôï ïðïßï Ý÷åé ñõèìéóôåß - íá ÷ñçóéìïðïéåß üôáí óôÝëíåôáé mail ìå ÷ñÞóç ôçò <literal>sendmail_path</literal> - ñýèìéóçò. Ãéá ðáñÜäåéãìá, áõôü ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ïñßóåé - ôçí äéåýèõíóç ôïõ áðïóôïëÝá üôáí ãßíåôáé ÷ñÞóç ôïõ sendmail ìå ôçí åðéëïãÞ - <literal>-f</literal>. ºóùò ÷ñåéáóôåß íá ðñïóèÝóåôå - ôïí ÷ñÞóôç, ðïõ ï web server óáò ÷ñçóéìïðïéåß óýìöùíá ìå ôéò ñõèìßóåéò ôïõ sendmail, - ãéá íá áðïôñÝøåôå íá ðñïóôåèåß óôï ìÞíõìá Ýíá 'X-Warning' header üôáí - ïñßæåôå ôïí áðïóôïëÝá ìå áõôÞ ôç ìÝèïäï. + The <parameter>additional_parameters</parameter> parameter + can be used to pass an additional parameter to the program configured + to use when sending mail using the <literal>sendmail_path</literal> + configuration setting. For example, this can be used to set the + envelope sender address when using sendmail with the + <literal>-f</literal> sendmail option. You may need to add + the user that your web server runs as to your sendmail configuration + to prevent a 'X-Warning' header from being added to the message when + you set the envelope sender using this method. <example> - <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers êáé ïñßæïíôáò ìéá åðéðñüóèåôç command line ðáñÜìåôñï.</title> + <title>Sending mail with extra headers and setting an additional command line parameter.</title> <programlisting> <![CDATA[ <?php @@ -123,17 +122,17 @@ </para> <note> <para> - ÁõôÞ ç ðÝìðôç ðáñÜìåôñïò ðñïóôÝèçêå óôçí PHP 4.0.5. Áðü ôçí PHP 4.2.3 áõôÞ - ç ðáñÜìåôñïò åßíáé áðåíåñãïðïéçìÝíç óôï <link linkend="ini.safe-mode">safe_mode</link> - êáé ç óõíÜñôçóç <function>mail</function> èá åìöáíßóåé Ýíá ìÞíõìá ðñïçäïðïéÞóçò - êáé èá åðéóôñÝøåé &false; åÜí ðñïóðáèåßôå íá ôçí ÷ñçóéìïðïéÞóåôå. + This fifth parameter was added in PHP 4.0.5. Since PHP 4.2.3 this + parameter is disabled in <link linkend="ini.safe-mode">safe_mode</link> + and the <function>mail</function> function will expose a warning message + and return &false; if you're trying to use it. </para> </note> <para> - Ìðïñåßôå åðßóçò íá ÷ñçóéìïðïéÞóåôå áðëÝò ôå÷íéêÝò string building ãéá íá äçìéïõñãÞóåôå ðïëýðëïêá - ìçíýìáôá email. + You can also use simple string building techniques to build complex + email messages. <example> - <title>ÓôÝëíïíôáò ðïëýðëïêá email.</title> + <title>Sending complex email.</title> <programlisting> <![CDATA[ <?php @@ -186,21 +185,21 @@ </para> <note> <para> - Öñïíôßóôå íá ìçí Ý÷åôå ôßðïôá newline ÷áñáêôÞñåò óôï - <parameter>to</parameter> Þ <parameter>subject</parameter>, - äéáöïñåôéêÜ ôï mail ßóùò íá ìçí óôáëåß óùóôÜ. + Make sure you do not have any newline characters in the + <parameter>to</parameter> or <parameter>subject</parameter>, + or the mail may not be sent properly. </para> </note> <note> <para> - Ç <parameter>to</parameter> ðáñÜìåôñïò äåí ìðïñåß íá åßíáé ìéá äéåýèõíóç - ôçò ìïñöÞò "Something <someone@example.com>". Ç - åíôïëÞ mail äåí èá ôï áíáëýóåé óùóôÜ êáôÜ ôçí åðéêïéíùíßá ìå ôï - MTA. + The <parameter>to</parameter> parameter cannot be an address + in the form of "Something <someone@example.com>". The + mail command will not parse this properly while talking with + the MTA. </para> </note> <para> - Äåßôå åðßóçò <function>imap_mail</function>. + See also <function>imap_mail</function>. </para> </refsect1> </refentry>
Index: phpdoc/en/reference/mail/functions/ezmlm-hash.xml diff -u phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.10 phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.11 --- phpdoc/en/reference/mail/functions/ezmlm-hash.xml:1.10 Sat Jul 19 20:09:10 2003 +++ phpdoc/en/reference/mail/functions/ezmlm-hash.xml Sun Jul 20 04:02:20 2003 @@ -1,25 +1,24 @@ -<?xml version="1.0" encoding="iso-8859-7"?> -<!-- $Revision: 1.10 $ --> -<!-- En-Revision: 1.9 Maintainer: legionnaire Status: ready --> +<?xml version="1.0" encoding="iso-8859-1"?> +<!-- $Revision: 1.11 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.6 --> <refentry id="function.ezmlm-hash"> <refnamediv> <refname>ezmlm_hash</refname> - <refpurpose>Õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé áðü ôï EZMLM</refpurpose> + <refpurpose>Calculate the hash value needed by EZMLM</refpurpose> </refnamediv> <refsect1> - <title>ÐåñéãñáöÞ</title> + <title>Description</title> <methodsynopsis> <type>int</type><methodname>ezmlm_hash</methodname> <methodparam><type>string</type><parameter>addr</parameter></methodparam> </methodsynopsis> <simpara> - Ç <function>ezmlm_hash</function> õðïëïãßæåé ôçí ôéìÞ hash ðïõ áðáéôåßôáé - êáôÜ ôçí äéáôÞñçóç EZMLM mailing lists óå ìéá MySQL database. + <function>ezmlm_hash</function> calculates the hash value needed + when keeping EZMLM mailing lists in a MySQL database. </simpara> <para> <example> - <title>Õðïëïãßæïíôáò ôï hash êáé åããñÜöïíôáò Ýíá ÷ñÞóôç</title> + <title>Calculating the hash and subscribing a user</title> <programlisting> <![CDATA[ $user = "joecool@example.com"; Index: phpdoc/en/reference/mail/functions/mail.xml diff -u phpdoc/en/reference/mail/functions/mail.xml:1.18 phpdoc/en/reference/mail/functions/mail.xml:1.19 --- phpdoc/en/reference/mail/functions/mail.xml:1.18 Sat Jul 19 20:09:10 2003 +++ phpdoc/en/reference/mail/functions/mail.xml Sun Jul 20 04:02:20 2003 @@ -1,14 +1,13 @@ -<?xml version="1.0" encoding="iso-8859-7"?> -<!-- $Revision: 1.18 $ --> -<!-- En-Revision: 1.17 Maintainer: legionnaire Status: ready --> +<?xml version="1.0" encoding="iso-8859-1"?> +<!-- $Revision: 1.19 $ --> <!-- splitted from ./en/functions/mail.xml, last change in rev 1.2 --> <refentry id="function.mail"> <refnamediv> <refname>mail</refname> - <refpurpose>ÁðïóôïëÞ mail</refpurpose> + <refpurpose>send mail</refpurpose> </refnamediv> <refsect1> - <title>ÐåñéãñáöÞ</title> + <title>Description</title> <methodsynopsis> <type>bool</type><methodname>mail</methodname> <methodparam><type>string</type><parameter>to</parameter></methodparam> @@ -18,19 +17,19 @@ <methodparam choice="opt"><type>string</type><parameter>additional_parameters</parameter></methodparam> </methodsynopsis> <simpara> - Ç <function>mail</function> áõôïìÜôá óôÝëíåé ìå mail ôï ìÞíõìá - üðùò ïñßæåôáé óôï <parameter>message</parameter> óôïí ðáñáëÞðôç - üðùò ïñßæåôáé óôï <parameter>to</parameter>. Ðïëëáðëïß ðáñáëÞðôåò ìðïñïýí - íá ïñéóôïýí ìå ôçí ðñïóèÞêç åíüò êüììáôïò áíÜìåóá óå êÜèå äéåýèõíóç óôï - <parameter>to</parameter>. Email ìå óõííçìÝíá áñ÷åßá êáé åéäéêïýò - ôýðïõò ðåñéå÷ïìÝíïõ ìðïñïýí íá áðïóôáëïýí ìå ôçí ÷ñÞóç áõôÞò ôçò óõíÜñôçóçò. Áõôü ðñáãìáôïðïéåßôáé - ìÝóù MIME-êùäéêïðïßçóçò - ãéá ðåñéóóüôåñåò ðëçñïöïñßåò, äåßôå áõôü: + <function>mail</function> automatically mails the message + specified in <parameter>message</parameter> to the receiver + specified in <parameter>to</parameter>. Multiple recipients can + be specified by putting a comma between each address in + <parameter>to</parameter>. Email with attachments and special + types of content can be sent using this function. This is + accomplished via MIME-encoding - for more information, see this <ulink url="&url.email.mime.zend;"> - ôï Üñèñï Zend</ulink> Þ ôéò<ulink url="&url.email.mime.pear;"> + Zend article</ulink> or the <ulink url="&url.email.mime.pear;"> PEAR Mime Classes</ulink>. </simpara> <simpara> - Ôá ðáñáêÜôù RFC's ìðïñïýí åðéóÞò íá âïçèÞóïõí: + The following RFC's may also be useful: <ulink url="&url.rfc;1896">RFC 1896</ulink>, <ulink url="&url.rfc;2045">RFC 2045</ulink>, <ulink url="&url.rfc;2046">RFC 2046</ulink>, @@ -39,29 +38,29 @@ <ulink url="&url.rfc;2049">RFC 2049</ulink>. </simpara> <para> - Ç <function>mail</function> åðéóôñÝöåé &true; åÜí ôï mail ðáñáäüèçêå - åðéôõ÷þò, &false; óå áíôßèåôç ðåñßðôùóç. + <function>mail</function> returns &true; if the mail was successfully + accepted for delivery, &false; otherwise. </para> <warning> <para> - Ç åãêáôÜóôáóç óôá Windows ôçò <function>mail</function> äéáöÝñåé ðïéêéëïôñüðùò - áðü ôçí áíôßóôïé÷ç óôï UNIX. Êáôáñ÷Þí, äåí ÷ñçóéìïðïéåß Ýíá ôïðéêü binary áñ÷åßï - ãéá íá óõíèÝôåé ìçíýìáôá áëëÜ ìüíï åíåñãåß óå direct sockets ðïõ óçìáßíåé üôé Ýíá - <literal>MTA</literal> áðáéôåßôáé ðïõ èá "áêïýåé" óå Ýíá network socket (ôï ïðïßï - ìðïñåß íá åßíáé åßôå óôï localhost -ôïðéêÜ- åßôå óôï áðïìáêñõóìÝíï ìç÷Üíçìá). ¸ðåéôá, ôá custom - headers üðùò <literal>From:</literal>, <literal>Cc:</literal>, - <literal>Bcc:</literal> êáé <literal>Date:</literal> <emphasis - role="strong">äåí</emphasis> åñìçíåýïíôáé áðü ôï <literal>MTA</literal> - óôçí áñ÷Þ, áëëÜ áíáëýïíôáé áðü ôçí <literal>PHP</literal>. - Ç <literal>PHP</literal> < 4.3 õðïóôÞñéæå ìüíï ôï óôïé÷åßï header <literal>Cc:</literal> - (êáé Þôáí case-sensitive). Ç <literal>PHP</literal> >= 4.3 - õðïóôçñßæåé üëá ôá ðñïáíáöåñèÝíôá óôïé÷åßá header êáé äåí åßíáé ðëÝïí + The Windows implementation of <function>mail</function> differs in many + ways from the Unix implementation. First, it doesn't use a local binary + for composing messages but only operates on direct sockets which means a + <literal>MTA</literal> is needed listening on a network socket (which + can either on the localhost or a remote machine). Second, the custom + headers like <literal>From:</literal>, <literal>Cc:</literal>, + <literal>Bcc:</literal> and <literal>Date:</literal> are <emphasis + role="strong">not</emphasis> interpreted by the <literal>MTA</literal> + in the first place, but are parsed by <literal>PHP</literal>. + <literal>PHP</literal> < 4.3 only supported the <literal>Cc:</literal> + header element (and was case-sensitive). <literal>PHP</literal> >= 4.3 + supports all the mentioned header elements and is no longer case-sensitive. </para> </warning> <para> <example> - <title>ÓôÝëíïíôáò mail.</title> + <title>Sending mail.</title> <programlisting> <![CDATA[ <?php @@ -72,21 +71,21 @@ </example> </para> <simpara> - ÅÜí ðåñáóôåß Ýíá fourth string argument, áõôü ôï string åéóÜãåôáé óôï - ôÝëïò ôïõ header. Áõôü ÷ñçóéìïðïéåßôáé êõñßùò ãéá íá ðñïóôåèïýí åðéðëÝïí - headers. Ðïëëáðëïß åðéðëÝïí headers ÷ùñßæïíôáé ìå Ýíá return (enter) - êáé ìéá íÝá ãñáììÞ. + If a fourth string argument is passed, this string is inserted at + the end of the header. This is typically used to add extra + headers. Multiple extra headers are separated with a carriage return + and newline. </simpara> <note> <para> - ÐñÝðåé íá ÷ñçóéìïðïéåßôå ôï <literal>\r\n</literal> ãéá íá ÷ùñßæåôå ôá headers, áí êáé - êÜðïéïé Unix mail transfer agents åíäÝ÷åôáé íá äïõëåýïõí ìüíï ìå ìéÜ íÝá ãñáììÞ + You must use <literal>\r\n</literal> to separate headers, although + some Unix mail transfer agents may work with just a single newline (<literal>\n</literal>). </para> </note> <para> <example> - <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers.</title> + <title>Sending mail with extra headers.</title> <programlisting> <![CDATA[ <?php @@ -100,17 +99,17 @@ </example> </para> <para> - Ç ðáñÜìåôñïò <parameter>additional_parameters</parameter> - ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ðåñáóôåß ìéá åðéðñüóèåôç ðáñÜìåôñïò óôï ðñüãñáììá, ôï ïðïßï Ý÷åé ñõèìéóôåß - íá ÷ñçóéìïðïéåß üôáí óôÝëíåôáé mail ìå ÷ñÞóç ôçò <literal>sendmail_path</literal> - ñýèìéóçò. Ãéá ðáñÜäåéãìá, áõôü ìðïñåß íá ÷ñçóéìïðïéçèåß ãéá íá ïñßóåé - ôçí äéåýèõíóç ôïõ áðïóôïëÝá üôáí ãßíåôáé ÷ñÞóç ôïõ sendmail ìå ôçí åðéëïãÞ - <literal>-f</literal>. ºóùò ÷ñåéáóôåß íá ðñïóèÝóåôå - ôïí ÷ñÞóôç, ðïõ ï web server óáò ÷ñçóéìïðïéåß óýìöùíá ìå ôéò ñõèìßóåéò ôïõ sendmail, - ãéá íá áðïôñÝøåôå íá ðñïóôåèåß óôï ìÞíõìá Ýíá 'X-Warning' header üôáí - ïñßæåôå ôïí áðïóôïëÝá ìå áõôÞ ôç ìÝèïäï. + The <parameter>additional_parameters</parameter> parameter + can be used to pass an additional parameter to the program configured + to use when sending mail using the <literal>sendmail_path</literal> + configuration setting. For example, this can be used to set the + envelope sender address when using sendmail with the + <literal>-f</literal> sendmail option. You may need to add + the user that your web server runs as to your sendmail configuration + to prevent a 'X-Warning' header from being added to the message when + you set the envelope sender using this method. <example> - <title>ÓôÝëíïíôáò mail ìå åðéðëÝïí headers êáé ïñßæïíôáò ìéá åðéðñüóèåôç command line ðáñÜìåôñï.</title> + <title>Sending mail with extra headers and setting an additional command line parameter.</title> <programlisting> <![CDATA[ <?php @@ -123,17 +122,17 @@ </para> <note> <para> - ÁõôÞ ç ðÝìðôç ðáñÜìåôñïò ðñïóôÝèçêå óôçí PHP 4.0.5. Áðü ôçí PHP 4.2.3 áõôÞ - ç ðáñÜìåôñïò åßíáé áðåíåñãïðïéçìÝíç óôï <link linkend="ini.safe-mode">safe_mode</link> - êáé ç óõíÜñôçóç <function>mail</function> èá åìöáíßóåé Ýíá ìÞíõìá ðñïçäïðïéÞóçò - êáé èá åðéóôñÝøåé &false; åÜí ðñïóðáèåßôå íá ôçí ÷ñçóéìïðïéÞóåôå. + This fifth parameter was added in PHP 4.0.5. Since PHP 4.2.3 this + parameter is disabled in <link linkend="ini.safe-mode">safe_mode</link> + and the <function>mail</function> function will expose a warning message + and return &false; if you're trying to use it. </para> </note> <para> - Ìðïñåßôå åðßóçò íá ÷ñçóéìïðïéÞóåôå áðëÝò ôå÷íéêÝò string building ãéá íá äçìéïõñãÞóåôå ðïëýðëïêá - ìçíýìáôá email. + You can also use simple string building techniques to build complex + email messages. <example> - <title>ÓôÝëíïíôáò ðïëýðëïêá email.</title> + <title>Sending complex email.</title> <programlisting> <![CDATA[ <?php @@ -186,21 +185,21 @@ </para> <note> <para> - Öñïíôßóôå íá ìçí Ý÷åôå ôßðïôá newline ÷áñáêôÞñåò óôï - <parameter>to</parameter> Þ <parameter>subject</parameter>, - äéáöïñåôéêÜ ôï mail ßóùò íá ìçí óôáëåß óùóôÜ. + Make sure you do not have any newline characters in the + <parameter>to</parameter> or <parameter>subject</parameter>, + or the mail may not be sent properly. </para> </note> <note> <para> - Ç <parameter>to</parameter> ðáñÜìåôñïò äåí ìðïñåß íá åßíáé ìéá äéåýèõíóç - ôçò ìïñöÞò "Something <someone@example.com>". Ç - åíôïëÞ mail äåí èá ôï áíáëýóåé óùóôÜ êáôÜ ôçí åðéêïéíùíßá ìå ôï - MTA. + The <parameter>to</parameter> parameter cannot be an address + in the form of "Something <someone@example.com>". The + mail command will not parse this properly while talking with + the MTA. </para> </note> <para> - Äåßôå åðßóçò <function>imap_mail</function>. + See also <function>imap_mail</function>. </para> </refsect1> </refentry>