Re: cvs: phpdoc /en/reference/mysql/functions [snip]
| From: | Georg Richter | Date: | Fri, 20 Feb 2004 19:17:20 +0000 |
| Subject: | Re: cvs: phpdoc /en/reference/mysql/functions [snip] | ||
| References: | 1 2 3 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969359118@lists.php.net to get a copy of this message | ||
> > So what is the appropiate way?
> >
> > a) mysql_query("SELECT col FROM foo WHERE bar='test'");
> > b) mysql_query('SELECT col FROM foo WHERE bar="test"'');
> > c) mysql_query('SELECT col FROM foo WHERE bar=\'test\''); ?
>
> IMO, a) because using " inside a query is not valid SQL and escaping
> decreases readability.
But why do you then change every query from double to single quote?
imho that is very inconsistent (when you agree on a) to have mixed double and
single quotes in queries.
Do whatever you want - seems like some people have too much time..
Georg