#29006 [Com]: install.txt doesn't work for newer versions of Apache
| From: | stephen at greyson-gaito dot demon dot co dot uk | Date: | Sat, 17 Jul 2004 12:59:15 +0000 |
| Subject: | #29006 [Com]: install.txt doesn't work for newer versions of Apache | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969361946@lists.php.net to get a copy of this message | ||
ID: 29006
Comment by: stephen at greyson-gaito dot demon dot co dot uk
Reported By: jmichae3 at yahoo dot com
Status: Bogus
Bug Type: Documentation problem
Operating System: Windows 95b
PHP Version: 4.3.7
New Comment:
I am having the same problem. I have followed the install.txt
instructions.
Apache: 1.3.31 (downloaded the day before yesterday)
Php: 4.3.8-Win32 (downloaded yesterday)
I have copied the php4ts.dll in the sapi beside the php4apache.dll
I am using Windows 2000 professional
Previous Comments:
------------------------------------------------------------------------
[2004-07-06 09:56:42] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
It's still not a bug, and I now notice that you use windows 95, which
we no longer support.
------------------------------------------------------------------------
[2004-07-06 06:05:58] jmichae3 at yahoo dot com
I have tried to follow install.txt directions, but nothing works.
------------------------------------------------------------------------
[2004-07-05 09:49:56] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
.
------------------------------------------------------------------------
[2004-07-04 05:42:41] jmichae3 at yahoo dot com
Description:
------------
I get this on 4.3.3 and 4.3.7. 5.0rc3 gives me a different error.
Using apache 1.3.31 and 2.0.49. default php.ini.
Apache sends me my schedule.php file as a download (to open or save to
disk).
Inserted into httpd.conf the following, as per install.txt:
LoadModule php4_module c:/php4.3.3/sapi/php4apache.dll
# AddModule mod_php4.c
AddType application/x-httpd-php .php
(Apache complains about adding the module twice if I uncomment the
middle line - still doesn't load the module) CGI configuration doesn't
work.
Expected result:
----------------
I expected to see the PHP version text along with the apache version
text.
Actual result:
--------------
C:\Program Files\Apache Group\Apache\logs>..\apache
[Sat Jul 03 19:17:30 2004] [warn] (2)No such file or directory: exec()
may not be safe
Apache/1.3.31 (Win32) running...
[break]
C:\Program Files\Apache Group\Apache\logs>type error.log
[Sat Jul 03 19:17:30 2004] [error] Cannot remove module mod_php4.c: not
found in module list
[Sat Jul 03 19:17:31 2004] [warn] exec() may not be safe
[Sat Jul 03 19:17:31 2004] [warn] exec() may not be safe
[Sat Jul 03 19:17:31 2004] [warn] exec() may not be safe
[Sat Jul 03 19:17:32 2004] [warn] exec() may not be safe
[Sat Jul 03 19:17:39 2004] [error] Cannot remove module mod_php4.c: not
found in module list
[Sat Jul 03 19:17:39 2004] [error] Cannot remove module mod_php4.c: not
found in module list
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29006&edit=1