#23907 [Com]: Need additional installation step for IIS 6.0 / Windows Server 2003

From: Date: Sat, 21 Aug 2004 03:52:50 +0000
Subject: #23907 [Com]: Need additional installation step for IIS 6.0 / Windows Server 2003
References: 1  Groups: php.doc 
Request: Send a blank email to phpdoc+get-969363378@lists.php.net to get a copy of this message
ID: 23907 Comment by: yo at momma dot org Reported By: bryn at mrpath dot com Status: Open Bug Type: Documentation problem Operating System: Windows Server 2003 PHP Version: 4.3.2 New Comment: This need to go on the install.txt file. BIG TIME. Searching google for ""HTTP Error 404 - File or directory not found. PHP IIS 2003"" and this article came up 7th. Does not bode well for noobs (A turn off, as in why bother) as well as experienced developers (A serious irritant, as in "Oh great, another speed bump and another hour or 2 of my time"). Previous Comments: ------------------------------------------------------------------------ [2004-04-08 13:51:08] bryn at mrpath dot com Other things to check on windows server 2003 installations (and other windows installations based on NT/2k server) are that extension DLLs have the appropriate ntfs security permissions (have to be able to execute by IIS acct iusr_machinename) ------------------------------------------------------------------------ [2004-04-08 12:46:39] jrcole at ualr dot edu Does anything special need to be done for other extensions, such as for mssql? Im running Server 2003 with IIS 6, PHP installed as ISAPI, and everything PHP works great. My only problem is using mssql commands. Scripts that work perfect on XP running IIS with PHP as CGI will not even connect to our sql server, fails with @mssql_connect function. Any ideas? Is this even remotely related to extensions? Viewing phpinfo shows mssql installed... Thanks for any help. ------------------------------------------------------------------------ [2004-01-22 11:23:17] farkhad_m at rambler dot ru thanks bryn, your suggestion helped me too. -fm ------------------------------------------------------------------------ [2003-11-19 21:42:58] thenry at mysideproject dot com Okay, I have been having the same issue for a week now on Windows 2003 server/PHP 4.3.4. I added the web service extension as noted in this post. I am still getting the "HTTP Error 404 - File or directory not found. Internet Information Services (IIS)" When I initially installed the Window binary the following alert windows popped up. 1. IIS has been configured. 2. IIsext : Windows cannot find 'iisext' make sure you typed the name correctlly, and try again. To search for a file, click the start button, and then click search. 3. Could not execute the external program iisext. Should I try the zipped version? Any help would be appreciated. ------------------------------------------------------------------------ [2003-09-06 23:39:29] bs_469 at hotmail dot com Thanks for the Help, I have been trying to fix this problem for over a week now. Your the greatest.. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/23907 -- Edit this bug report at http://bugs.php.net/?id=23907&edit=1

« previous php.doc (#969363378) next »