#30715 [NEW]: Permission Denied mk protocol with chm documents
| From: | john_taylo2 at optusnet dot com dot au | Date: | Mon, 08 Nov 2004 04:51:00 +0000 |
| Subject: | #30715 [NEW]: Permission Denied mk protocol with chm documents | ||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969364935@lists.php.net to get a copy of this message | ||
From: john_taylo2 at optusnet dot com dot au
Operating system: MS Windows XP SP2
PHP version: 5.0.2
PHP Bug Type: Documentation problem
Bug description: Permission Denied mk protocol with chm documents
Description:
------------
I tried to use the php_manual_chm_12.zip file on my Windows XP SP2
machine. I unzipped then when clicking on Language Reference under
Contents I get:
Internet Explorer Script Error
An error has occurred in the script on this page.
Line: 6
Char: 19
Error: Permission denied
Code: 0
URL:
mk:@MSITStore:C:\php_manual_chm_12\php_manual_notes.chm::/langref.html
Do you want to continue running scripts on this page
Yes No
NB This works fine for say Getting Started.
Things I noticed/references when trying to fix the problem
http://www.mcpmag.com/columns/print.asp?EditorialsID=716
"...Older help files (IE 3.0) use a protocol called mk:@MSITStore. This
protocol hasnt been given the same kind of exhaustive security scrutiny
as MS-ITS and is blocked by default in XP SP2...."
I also note the following registry key exists:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
Explorer\Main\FeatureControl\FEATURE_DISABLE_MK_PROTOCOL
Am I doing something silly or is "mk" an old protocol vs ms-its and
Microsoft is making things difficult under MS XP SP2?!
--
Edit bug report at http://bugs.php.net/?id=30715&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=30715&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=30715&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=30715&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=30715&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=30715&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=30715&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=30715&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=30715&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=30715&r=support
Expected behavior: http://bugs.php.net/fix.php?id=30715&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=30715&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=30715&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=30715&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=30715&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=30715&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=30715&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=30715&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=30715&r=float
MySQL Configuration Error: http://bugs.php.net/fix.php?id=30715&r=mysqlcfg