#32535 [Opn->Bgs]: Are stream names URLs?
| From: | nlopess@php.net | Date: | Sat, 02 Apr 2005 11:16:19 +0000 |
| Subject: | #32535 [Opn->Bgs]: Are stream names URLs? | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969367235@lists.php.net to get a copy of this message | ||
ID: 32535
Updated by: nlopess@php.net
Reported By: a at b dot c dot de
-Status: Open
+Status: Bogus
Bug Type: Documentation problem
Operating System: *
PHP Version: 5.0.3
New Comment:
I can't see any problem in the documentation. Everything about wrappers
is well explained.
Previous Comments:
------------------------------------------------------------------------
[2005-04-02 08:08:14] sniper@php.net
reclassified
------------------------------------------------------------------------
[2005-04-01 17:01:59] a at b dot c dot de
Description:
------------
As indicated several times in the manual, the "filenames" that result
from using stream wrappers are to be regarded as URLs, just as http,
ftp and file schemes already are.
However, ALL such wrappers separate the scheme (what the manual refers
to as the "protocol" from the rest of the URL with "://" - an example
being the "var://myvar" in the example of the stream_wrapper_register()
page.
This conflicts with RFC3986, the official specification for URIs (of
which URLs are a subclass). The separator is just ":"; the double slash
should only appear if what follows is a hierarchical structure in the
sense given in section 3 of that document.
This is explicitly stated as improper in RFC2718, section 2.1.2 (which
refers to the previous URI standard, RFC2396).
If these streams are supposed to be URLs, then the above example from
the manual should read "var:myvar".
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=32535&edit=1