#32733 [Opn]: libmysqli.dll not included w/5.0.4 & PHP_MySQL.DLL & PHP_MySQL.DLL won't load
| From: | jason at thinkingman dot org | Date: | Sun, 17 Apr 2005 19:09:14 +0000 |
| Subject: | #32733 [Opn]: libmysqli.dll not included w/5.0.4 & PHP_MySQL.DLL & PHP_MySQL.DLL won't load | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969367880@lists.php.net to get a copy of this message | ||
ID: 32733
User updated by: jason at thinkingman dot org
Reported By: jason at thinkingman dot org
Status: Open
Bug Type: Documentation problem
Operating System: XP (SP2)
PHP Version: 5.0.4
New Comment:
I just performed a command line WHICH statement on the following:
PHP.EXE
PHP_MYSQL.DLL
PHP_MYSQLi.DLL
It find'em in
C:\DEV\PHP5 --> php.exe
C:\DEV\PHP5\ext --> PHP_MySQL.DLL
C:\DEV\PHP5\ext --> PHP_MySQLi.DLL
My PHP.INI:
; Directory in which the loadable extensions (modules) reside.
extension_dir = "c:\dev\php5\ext"
Previous Comments:
------------------------------------------------------------------------
[2005-04-17 21:00:39] jason at thinkingman dot org
IT ISN'T MY MISCONIFG PROB. I HAVE STATED THAT ALL MY PATHS ARE
CORRECT IN THE PHP.INI AND OS ENVIRONMENT -- NOTHING HAS CHANGED.
COME'ON PEOPLE.
------------------------------------------------------------------------
[2005-04-17 20:58:56] jason at thinkingman dot org
For giggles; I've redownloaded 5.0.4 ZIP'd distro and reinstalled. I
get the error. Here's what it says exactly:
WARNING:
PHP Startup; Unable to load dynamic library
'\dev\php5\ext\php_mysql.dll' - The specified procedure could not be
found.
Then I get another pop-up warning; same message except for
PHP_MySQLi.DLL.
------------------------------------------------------------------------
[2005-04-17 20:57:40] nlopess@php.net
its your misconfiguration problem.
Or you don't have C:\dev\php5 in the path or something else.
But here it isn't the place to ask for that kind of suppport. The
archive is good, php 5.0.4 works, and the change is documented.
------------------------------------------------------------------------
[2005-04-17 20:51:02] jason at thinkingman dot org
I have read that, although it doesn't explicitly say -- it does imply
in 5.0.3 and above it's just LibMySQL.DLL. However, I'm still left with
the problem of the PHP_MYSQLi.DLL and PHP_MYSQL.DLL extensions not
loading.
My Extensions are located in C:\DEV\PHP5\ext
This path is correctly defined in my PHP.INI and my OS's environment.
Yet each time I restart IIS I get that error; Unable to Load Extension
PHP_MySQLi.DLL (same for PHP_MySQL.DLL) -- cannot be located. And they
do exist in my .;\ext folder
------------------------------------------------------------------------
[2005-04-17 20:38:53] nlopess@php.net
The libmysqli.dll lib was replaced by libmysql.dll.
This is documented at
http://php.net/manual/en/install.windows.extensions.php
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/32733
--
Edit this bug report at http://bugs.php.net/?id=32733&edit=1