#33236 [Opn->Bgs]: Setting up PATH variable correctly
ID: 33236
Updated by: nlopess@php.net
Reported By: steve dot warr at hemdean dot plus dot com
-Status: Open
+Status: Bogus
Bug Type: Documentation problem
Operating System: Win32/2k
PHP Version: Irrelevant
New Comment:
The installation FAQ explains the correct steps, which is linked from
the main installation chapter.
Previous Comments:
------------------------------------------------------------------------
[2005-06-03 18:07:12] steve dot warr at hemdean dot plus dot com
Description:
------------
There are numerous claims online about getting a 'php_mysql.dll -
module not found' error message. I basically encountered this problem,
where the command line 'php -m' showed that mysql was getting loaded
ok, but my IIS webservice kept producing the 'module not found' error
message.
After a very, very painful day of tracing through the install
procedure, I eventually found that the problem was related not
php_mysql.dll itself, but to the dependent 'libMySQL.dll'. I had
followed the install doc to the letter and added 'c:\<php_install_dir>'
to my PATH variable. However, the doc fails to mention that you **must**
add this path as part of the 'system variables' and not to the 'user
variables' section. This explains why the command line worked, but not
the web service. Obvious really when you know, but really difficult to
debug. One extra line of text in the install doc pointing out this
gotcha would have saved a lot of frustration.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33236&edit=1
Thread (4 messages)