#35018 [NEW]: Restart required after changing PATH
| From: | mike at zappmobile dot ro | Date: | Sat, 29 Oct 2005 09:45:54 +0000 |
| Subject: | #35018 [NEW]: Restart required after changing PATH | ||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969370701@lists.php.net to get a copy of this message | ||
From: mike at zappmobile dot ro
Operating system: Windows XP Professional SP2
PHP version: Irrelevant
PHP Bug Type: Documentation problem
Bug description: Restart required after changing PATH
Description:
------------
Restarting Windows is not mentioned in the Windows documentation
(install.txt). I'm aware it's mentioned in the instalation FAQ, but I
think it should be included in the main documentation, because the FAQ is
not included in the php-5.0.5-Win32.zip file, and is only available
online.
I'm using Apache 2.0.55 running as a service, php 5.0.5 installed as a
module, and the mysql module refused to load until reboot, because it
didn't find libmysql.dll. However, the error popup said "unable to load
dynamic library php_mysql.dll", so I lost about an hour making various
changes the "extension_dir = " option.
In the last 4 years, I probably installed PHP on windows/apache 10 times.
Each time, I followed the documentation to the letter, and ran into this
issue. Each time it didn't work, and I had to copy all the dll files to
system32 to make it work.
This is highly annoying, because there are two points where you can get
stuck:
1. Determine the real DLL that cannot be found;
2. Determine why it can't be found;
Even if you read the installation FAQ, it's not obivious what the
problem is, because the section "14. How do I add my PHP directory to the
PATH on Windows?" seems unrelated to the problem. The users will think "I
did set my PATH, why would I need to read that section of the FAQ"?
My problem is very similar to #32625, but that bug is marked as closed,
and I do not agree to that resolution.
--
Edit bug report at http://bugs.php.net/?id=35018&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=35018&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=35018&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=35018&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=35018&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=35018&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=35018&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=35018&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=35018&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=35018&r=support
Expected behavior: http://bugs.php.net/fix.php?id=35018&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=35018&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=35018&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=35018&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=35018&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=35018&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=35018&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=35018&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=35018&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=35018&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=35018&r=mysqlcfg