Conflicting function IDs
| From: | Hannes Magnusson | Date: | Fri, 23 Nov 2007 13:04:20 +0000 |
| Subject: | Conflicting function IDs | ||
| Groups: | php.doc | ||
| Request: | Send a blank email to phpdoc+get-969378358@lists.php.net to get a copy of this message | ||
Hi all
We finally have a problem with conflicting IDs.
In PHP6 we have a function (in ext/unicode) named locale_get_default()
In PHP5 we have a function (in pecl/intl) also named
locale_get_default() (compatibility layer (I guess) for ext/unicode).
Both of these, according to our naming conventions, should get the ID
"function.locale-get-default" :|
Now. We are in luck. pecl/intl has dual interface (OO&procedural) so
the pecl/intl function should have the ID locale.getlocale
(<classname>.<methodname>) according to the proposed OO skels :D
These function ID conventions however could be a problem in the future
so its something worth looking into, I think.
-Hannes