Log files.

From: Date: Fri, 21 Jun 2002 18:13:26 +0000
Subject: Log files.
Groups: php.general 
Request: Send a blank email to php-general+get-103321@lists.php.net to get a copy of this message
I was having some problems with my error logs. I just figured out what the problem was! Thought everybody might benefit from it's solution so here it goes. The problem was that the php error log was only showing errors created by my command line scripts that were being executed by cron. The solution was that one of my cron jobs deleted the PHP error file late every night so it would be fresh and only showing today's errors. The first error output was usually created by one of the PHP scripts run through cron. When this script wrote it's error out it created my error file with the owner being root. Then when the website users started creating errors (later in the morning), apache was unable to write to the file because it was owned by root. Duhhh!! Maybe this will help someone in the future. James E Hicks III

« previous php.general (#103321) next »