Re: PHP 4.2.2 install woe: cannot stat libs/libphp.so
| From: | David Robley | Date: | Wed, 24 Jul 2002 01:35:21 +0000 |
| Subject: | Re: PHP 4.2.2 install woe: cannot stat libs/libphp.so | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-109184@lists.php.net to get a copy of this message | ||
In article <1027434902.5338.20.camel@arcturus.phys.utk.edu>,
reubendb@innovativethought.com says...
>
> I tried to upgrade from PHP 4.2.1 to 4.2.2 due to the security bug
> announce in the web site. When I do make install, it stopped with
> errors. The following are the last few lines from the output:
>
> [activating module `php4' in /usr/local/apache/conf/httpd.conf]
> cp libs/libphp4.so /usr/local/apache/libexec/libphp4.so
> cp: cannot stat `libs/libphp4.so': No such file or directory
> apxs:Break: Command failed with rc=1
> make[1]: *** [install-sapi] Error 1
> make[1]: Leaving directory `/usr/src/php-4.2.2'
> make: *** [install-recursive] Error 1
>
> When I checked the directory libs, there are only files
> libphp4.a libphp4.la
>
> I tried to make symlink called libphp4.so to one of this files, and then
> the make install run without error. But then when I started my apache,
> it gives me:
>
> bash $> /usr/local/apache/bin/apachectl start
> Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
> /usr/local/apache/libexec/libphp4.so: invalid ELF header
> /usr/local/apache/bin/apachectl start: httpd could not be started
>
> Any help on this would be greatly appreciated. Thanks in advance.
> Reuben D. Budiardja
>
>
Did you do 'make install' as root?
--
David Robley
Temporary Kiwi!
Quod subigo farinam